Show Posts
Pages: [1]
1  Using Arduino / Sensors / Re: Cannot detect HMC5883L on the I2C bus on: January 17, 2013, 03:59:31 pm
I want to report back.

I ordered a new saintsmart hmc5883l from ebay and it's working out of the box...
2  Using Arduino / Sensors / Re: Water Pressure Sensor needed ! on: December 30, 2012, 07:49:04 am
I think I'm a little bit late. I like these water pressure sensors: http://www.amsys.de/products/ms5803.htm
3  Using Arduino / Sensors / Re: Cannot detect HMC5883L on the I2C bus on: December 30, 2012, 07:46:04 am
Today I tried the following things without success:
  • Resoldered all pins
  • Connected the sensor board to 5V and 3,3V of my nanowii board
  • Connected the sensor board to 5V and 3,3V of my raspberry pi
  • Enabled / Disabled internal pullups of the nanowii board
  • Measured the voltages on the sensor board (3,3V connection => 3,31V VCC, 3V on SCL and SDA)
  • Measured the capacitors on the sensor board => 3,06uF and 0,20uF (Datasheet says 4,7uF and 0,22uF could this be a problem?)

If no one has another idea what I'm missing, I think I will have to buy a new one...
4  Using Arduino / Sensors / Re: Cannot detect HMC5883L on the I2C bus on: December 29, 2012, 08:15:11 am
Ok, I will resolder all pins and try to connect the 5V line of the sensor board (board has a 5V and 3.3V connector). Hope this helps.
5  Using Arduino / Sensors / Re: Cannot detect HMC5883L on the I2C bus on: December 28, 2012, 05:36:36 pm
Thank you for your replies. On the board are two 4,7k pullup resistors. I tested the I2C bus with a BMP085 pressure sensor and an GPS module. Both are working like a charm.

The 3,3v and 5v lines seem ok.

I'm using Arduino 1.0.1.
6  Using Arduino / Sensors / Cannot detect HMC5883L on the I2C bus on: December 28, 2012, 04:46:58 pm
Hello everyone,

I bought a HMC5883L board from drotek (http://www.drotek.fr/shop/en/25-hmc5883l-magnetometer-compass-sensor.html). After connecting the board to the i2c bus of my nanowii (ATmega32U4) the sensor board is not detected.

I tried the code from this site (http://todbot.com/blog/2009/11/29/i2cscanner-pde-arduino-as-i2c-bus-scanner/comment-page-1/) to scan the i2c bus without success. Nothing found... The same happend if I connect the board to my raspberrypi and scan the bus with i2cscanner.

Any suggestions? Is the sensor board broken?

Thanks.
7  Using Arduino / Sensors / Re: Problem with HMC5883L on: December 23, 2012, 06:15:07 am
Hello,
I have a problem with HMC5883L magnetometer:
card: Arduino 2009
Soft: HMC5883L_Example.pde

The sketch is loaded into the card (arduino) but in the serial monitor I have this:

Constructing new HMC5883L
Setting scale to +/- 1.3 Ga
Entered scale was not valid, valid gauss values are: 0.88, 1.3, 1.9, 2.5, 4.0, 4.7, 5.6, 8.1
Setting measurement mode to continous.
Entered scale was not valid, valid gauss values are: 0.88, 1.3, 1.9, 2.5, 4.0, 4.7, 5.6, 8.1
Raw:   875   1795   883      Scaled:   805.00   1651.40   812.36      Heading:   1.16 Radians      66.63 Degrees      
Raw:   875   1795   883      Scaled:   805.00   1651.40   812.36      Heading:   1.16 Radians      66.63 Degrees      
Raw:   875   1795   883      Scaled:   805.00   1651.40   812.36      Heading:   1.16 Radians      66.63 Degrees      
Raw:   875   1795   883      Scaled:   805.00   1651.40   812.36      Heading:   1.16 Radians      66.63 Degrees      
Raw:   -18176   -15872   322      Scaled:   805.00   1651.40   812.36      Heading:   1.16 Radians      66.63 Degrees      
Raw:   875   1795   883      Scaled:   805.00   1651.40   812.36      Heading:   1.16 Radians      66.63 Degrees      
Raw:   875   1795   883      Scaled:   805.00   1651.40   812.36      Heading:   1.16 Radians      66.63 Degrees      

and so on.

What's happened ?

Thanx


I get the same errors. Any ideas to get this fixed?
Pages: [1]