Show Posts
Pages: [1]
1  Products / Arduino Due / Why do I get servo jitter when disconnected from USB? on: January 22, 2013, 09:01:22 am
I am running a basic servo test and have the Due powered via the 9V power as well as have it plugged in to the USB to upload the code.  The servo is connected to the 5V and Gnd of the Due along with using pin 6 to control the servo.  As long as I keep the Due plugged into the USB, the servo works fine.  However, when I unplug the USB (where the power presumably is only supplied through the 9V input), the servo jitters.  Why would this be?
2  Products / Arduino Due / Re: Hardware Servo: Example Code on: January 14, 2013, 08:30:53 am
Thanks for writing this code, I was also surprised that the Due rolled out without a formal way to manage servo control.  Thanks for the code.  As far as integrating the modified servo.h library to use, how does one take the code for the modified servo.h and integrate into my working copy onto one's computer?
3  Products / Arduino Due / Re: Library Problem With IDE V1.5.1r2 And Due on: January 02, 2013, 09:35:14 pm
I am having the exact same issue.  It's clear the Arduino software is not ready for the Due, if you following my comments, you'll see the troubleshooting shows the same code will work with the Mega selected but not with the Due:

http://arduino.cc/forum/index.php/topic,140128.0.html

I hope someone can fix this as it heavily impacts my work withe Due.
4  Products / Arduino Due / Re: Cannot run include files. Getting 'No such file or directory' for any include. on: January 02, 2013, 09:27:17 pm
Incredible how this problem does continue.  I am able to get the program to compile.  However, when I try to upload it via the Programming Port, it then claims it cannot find the very include file that I had the original problem with, server.h.  If I change it to the Native USB Port, it compiles but then cannot upload.  This Due is becoming quite frustrating!
5  Products / Arduino Due / Re: Cannot run include files. Getting 'No such file or directory' for any include. on: January 02, 2013, 09:02:28 am
Thanks PaulS, your troubleshooting of toggling the Board from Mega to Due seem to have fixed the problem.  I deleted the Arduino folder from my Documents area (seems to be created automatically by Arduino software I think) and then toggled the Board used from Due to Mega, then back to Due and re-compiled.  It compiled the library files correctly and everything was working.

Certainly a bug in the software but I got it working.

Thanks!
6  Products / Arduino Due / Re: Cannot run include files. Getting 'No such file or directory' for any include. on: January 01, 2013, 09:37:07 pm
Nope, that is not the issue I am experiencing.  Can someone else please try to run the sample under the Due setup and see if they experience the same error?  Any help would be appreciated.
7  Products / Arduino Due / Cannot run include files. Getting 'No such file or directory' for any include. on: January 01, 2013, 01:53:48 pm
I am using an Arduino Due with Arduino 1.5.1r2 running Windows 7.  I have installed the drivers and communication with the hardware works fine.  However, whenever I try to make a reference to any include file (files that it was installed with or libraries I download and try), I always receive the same error:

No such file or directory

I tried compiling the example Sketch located at Files - Examples - Starter Kit - p05_ServoMoodIndicator.
This same sample sketch works fine for under the Mega, but not the Due using the same code.

When I look at Sketch-Import Library, it shows a list of libraries I can reference.  When I try those, I get the same error message.

Can anyone help me understand why no include files can be referenced correctly?
8  Products / Arduino Due / Re: Cannot run include files. Getting 'No such file or directory' for any include. on: January 01, 2013, 01:45:47 pm
Thanks for reviewing this and I will move this to the Due part of the forum.
9  Products / Arduino Due / Re: Cannot run include files. Getting 'No such file or directory' for any include. on: January 01, 2013, 01:02:59 pm
Ok, so you had no problem running the Example code for servos?  You can find the code I am referring to at Files - Examples - Starter Kit - p05_ServoMoodIndicator.

Did you install this version of Arduino in any particular path on your hard drive?  It seems like the include files are referenced in a relative path, in which case this might be the issue.

I installed the Arduino software in a folder on root of my C: drive.

Thank you for your reply and any help would be appreciated.
10  Products / Arduino Due / Re: Cannot run include files. Getting 'No such file or directory' for any include. on: January 01, 2013, 12:29:16 pm
Thanks for the reply.

According to the documentation here, the Due should download ver 1.5.1r2:
http://arduino.cc/en/Main/Software

Should I use a different version?
11  Products / Arduino Due / Cannot run include files. Getting 'No such file or directory' for any include. on: January 01, 2013, 10:45:11 am
I am using an Arduino Due with Arduino 1.5.1r2 running Windows 7.  I have installed the drivers and communication with the hardware works fine.  However, whenever I try to make a reference to any include file (files that it was installed with or libraries I download and try), I always receive the same error:

No such file or directory

When I look at Sketch-Import Library, it shows a list of libraries I can reference.  When I try those, I get the same error message.

For example, I want to use the servo.h file.  When I try to reference this file as an include, I get the error message: No such file or directory.

Can someone offer me assistance in why any reference to an include file generates this error?
Pages: [1]