Show Posts
Pages: [1] 2
1  International / Software / Re: Problemas con Attiny85 y LCD I2C on: August 19, 2012, 03:12:32 pm
oook, pues a ver cuando saco un rato y le echo un ojo más detalladamente.

Gracias !
2  International / Software / Re: Problemas con Attiny85 y LCD I2C on: August 19, 2012, 12:27:03 pm
no creo que sea por eso, si selecciono otro chip que no sea un attiny, por ejemplo arduino, me compila y funciona correctamente, el problema está cuando selecciono attiny.
Por los cores de attiny tampoco es, abro el ejemplo de Blink y seleccionando la placa de attiny me compila perfectamente.

Gracias por la ayuda!
3  International / Software / Re: Problemas con Attiny85 y LCD I2C on: August 19, 2012, 12:07:19 pm
tengo la que pone en la página que hay que usar específicamente para el attiny, con la original sin modificar nada no he probado la verdad :S
4  International / Software / Problemas con Attiny85 y LCD I2C on: August 19, 2012, 11:06:24 am
Estoy intentando conectar un attiny85 y un LCD por i2c, estoy usando la librería del playground:
http://arduino.cc/playground/Code/USIi2c
Y al compilar en arduino023 me devuelve el siguiente error:

In file included from HelloWorld_Tiny.cpp:15:
/Users/santiagolopezpina/Documents/Arduino/libraries/LiquidCrystal_I2C/LiquidCrystal_I2C.h:92: error: conflicting return type specified for 'virtual void LiquidCrystal_I2C::write(uint8_t)'
/Users/santiagolopezpina/Documents/Arduino/hardware/tiny/cores/tiny/Print.h:73: error:   overriding 'virtual size_t Print::write(uint8_t)'

Alguién sabe por qué puede ser?
5  International / Español / Re: Sensor PING y librería Servo on: August 23, 2011, 06:07:22 pm
Prueba a alimentar los motores con una fuente externa que no sea el USB arduino, a mi me paso lo mismo y se soluciona alimentando los motores a parte.
aprovecho este post, ya que no encuentro otro, yo uso la libreria Ultrasonic.h para leer la medición del sensor de ultrasonido, con un arduino duamilanove me va perfecto pero con un arduino nano, no me funciona, me da lectura erronea, sabéis si esa libreria no es compatible con esta placa?
6  Using Arduino / Sensors / Re: Trouble with HC-SR04 Ultrasonic Sensor on: August 04, 2011, 12:52:38 pm
i just trying with a L7805, and the motors and the sensor it's ok, I dont know the caracteristics of the motor, it's from a toy smiley-sad
7  Using Arduino / Sensors / Re: Trouble with HC-SR04 Ultrasonic Sensor on: August 04, 2011, 12:45:00 pm
ok!! i'm going to use a 9V batery and a LM78L05 to supply the motors! Thank's you!
8  Using Arduino / Sensors / Re: Trouble with HC-SR04 Ultrasonic Sensor on: August 04, 2011, 12:39:56 pm
If you're supplying the motors with power from the Arduino's 5V output, then that may be part of the problem. Can you try using a separate power supply for the motors, with just the grounds connected together. That is, power the Arduino and sensor as you have it now, but disconnect the power to the motors. Then, use a second battery to supply the motor power. Remember to leave the grounds connected.
ok! it's for this! smiley-sad But, how can i supply the motor and arduino? at same time? with only one batery?
9  Using Arduino / Sensors / Re: Trouble with HC-SR04 Ultrasonic Sensor on: August 04, 2011, 12:25:54 pm
That does sound like a noise problem. It may be electrical noise conducted through the power supply, or it may be acoustic noise (sound) generated by the motor(s). This may be a difficult one to fix!  First of all, do you have any power supply decoupling capacitors? And are you using the same power supply (batteries, presumably) for both motors and the sensor/Arduino?


I supplying all circuit with the Arduino pin 5V, and i'm controling the motor's with a L298N Bridge. All ready, the motor's have a 100nf capacitor
10  Using Arduino / Sensors / Re: Trouble with HC-SR04 Ultrasonic Sensor on: August 04, 2011, 12:11:56 pm
Hi i'm working with this sensor, i'm making  a car. When i connect the sensor and the motor, the distance from the sensor is not correct, i think the wheels make a lot of noise, maybe it's a problem? Because, if i disconnect the wheels, the distance is correct.
11  International / Español / Re: Libreria de máquina de estados arduino on: June 24, 2011, 03:06:11 am
Hola bodhi, eso es en el caso que ponen en el ejemplo, que es bastante sencillo, ya que como indicas, el cambio de estado se hace cuando se pulsa un botón y es secuencial, pero por ejemplo si el cambio de estado se hace cuando un sensor de temperatura llegue a un cierto valor, o con otro tipo de acción que no se tenga controlado, cómo se puede saber?
En la documentación ponen:
Quote
State& getCurrentState()

Returns the current state

Que imagino que hace lo que quiere, pero no sé cómo usarla, no sé qué significa que esa variable State tenga el & al final...
12  International / Español / Libreria de máquina de estados arduino on: June 23, 2011, 12:14:51 pm
Alguien ha trabajado alguna vez con la librería de FSM (http://www.arduino.cc/playground/Code/FiniteStateMachine) estoy intentando usarla, pero hay algunas cosas que no sé como se usan. Por ejemplo me gustaría asignar a una variable el estado actual en el que se encuentra el programa, pero no soy capaz, alguien podría ayudarme?
13  International / Español / Re: Cambio de sentido motor pap on: April 04, 2011, 01:09:34 pm
Santiago.lopez a mi tambien me paso la primera vez q lo probe, luego como con lo 5v de arduino funcionaba no le di mas importancia, postealo en el hilo de txapuzas y seguro q te dan. una respuesta.

Es curioso, pero si alimento el L239 con los 5v de arduino, pero el motor paso a paso con la fuente de alimentación externa, funcioa correctamente, no sé por que será, igual la Fuente no me da suficiente intensidad.. pero me extraña...
14  International / Español / Re: Cambio de sentido motor pap on: April 01, 2011, 09:29:04 am
yo en mi caso personal, para hacer funcionar un paso a paso he seguido este pequeño manual, he montado el circuito en una protoboard y va de muerte, http://txapuzas.blogspot.com/2009/12/paperstepperl298n-driver-de-potencia.html
Además para la libreria de stepper para el cambio de giro con poner el símbolo negativo funciona,
Mi problema viene, en que, si uso los 5v que suministra arduino el motor funciona correctamente, pero si lo alimento con una fuente de alimentación que tengo, que también da 5v, el motor no va ni para atrás, y se me calienta, Decir que la fuente funciona correctamente con otros circuitos, puede ser que haya un corto en el motor???
15  International / Español / Re: Maquetación en LaTeX de ArduinoNotebook on: March 26, 2011, 03:21:49 pm
Inizul, muchas gracias, como dije yo hice la maquetación y las erratas de texto están en el propio wiki, me apunto todo para irlo corrigiendo en el documento, muchas gracias! sabéis cómo puedo pasar el enlace a los ¿administradores? del wiki para que lo publiquen?
Pages: [1] 2