Show Posts
Pages: [1] 2 3
1  International / Deutsch / Re: ULN2803a on: October 31, 2013, 12:44:12 pm
Pumpe wird immer nur eine gleichzeitig laufen, das hatte ich schon bedacht.

Anlaufstrom der peristaltikpumpen hab ich mit 400mA gemessen (alle 4 einzeln gemessen, jeweils 10 mal. höher kamen sie nicht).
Wenn sie läuft sinds 180-200mA (bissel abweichung zwischen den pumpen).

Ich wollte erst Relais nehmen (hatte ich auch schon drin), aber das wäre dann doch zuviel geworden. Jede Pumpe läuft einmal pro stunde für 2 Minuten.

Hat auch erst an eine transistorschaltung gedacht, aber der uln erschien mit in diesem fall die schönste wahl.

Da ich nen sockel verlötet habe kann ich den aber noch austauschen ohne großen akt.
2  International / Deutsch / Re: ULN2803a on: October 31, 2013, 07:44:54 am
Boah ich liebe dieses Forum =)

Rennt... deswegen waren wohl auch high und low verstauscht. Ist das erste mal das ich den ULN einsetze...

GANZ HERZLICHEN DANK WILLIE!!!!
3  International / Deutsch / Re: ULN2803a on: October 31, 2013, 07:35:39 am
Ah? Ok...  teste ich mal...
4  International / Deutsch / Re: ULN2803a on: October 31, 2013, 07:29:26 am
Ach vertan....

Hier ein Bild:


Ich habe an 9 Masse vom 12V und an 10 natürlich Spannung vom 12V.

Habe jetzt auch mal ohne Spannung an 10 probiert... gleiches Phänomen.


5  International / Deutsch / Re: ULN2803a on: October 31, 2013, 07:08:48 am
Achso... rein von der Logik her würde ich sagen 12V, allerdings rennen dann immer alle Pumpen wenn ich auch nur einen Pin auf high setze...
6  International / Deutsch / ULN2803a on: October 31, 2013, 07:07:46 am
Mahlzeit =)

Ich habe hier ein kleines Problem mit dem ULN2803a.

Ich versuche damit (wie in einem anderen Thread schon beschrieben) 4 Pumpen laufen zu lassen.
Den ULN steuere ich mit einem 74HC595 an.

Ich habe also 2 Stromkreise.
1x 5V für den YUN / 74HC595 / RTC
1x 12V für die Pumpen

Am ULN sind ja "links" die Eingänge und "rechts" die Ausgänge.
Die Pumpen hängen an +12V und die Masse geht zum ULN.

An Pin 9 muss ja Masse und an Pin 18 Spannung

Welche nehme ich da? 5V oder 12V?
7  International / Deutsch / Re: Peristaltik / Dosierpumpe 6V on: October 14, 2013, 08:40:23 am
Das ist schon klar smiley

Ich überlege nur wie ich das programmiertechnisch löse...
8  International / Deutsch / Re: Peristaltik / Dosierpumpe 6V on: October 14, 2013, 07:17:47 am
Nein. Ich habe eine Pumpe wohl mit 7,5V einfach nur zertört smiley
Habe jetzt vor beiden einen Step-Down gesetzt. Jetzt funktionierts gut.

Aber mal was anderes zu dem Ding...

Ich habe das ganze mal komplett zusammengesteckt und wie das so ist, es wurde dann doch mehr smiley

Also habe ich jetzt:
- 1x ULN2803a
- 3x 75HC595 (1x Pumpen (ULN), 1x Status LEDs (Rot + Grün), 1x LCD
- 1x RTC (muss ja, wenn die die Pumpen vernünftig zeitgesteuert laufen lassen will) am I2C

Die Frage die ich mir gerade stelle: Kann ich wohl die 3 74hc595 in Reihe laufen lassen? Ich zerbreche mir gerade den Kopf wie ich das am schlausten umsetze. Ich würde gerne möglichst viele PINs "sparen", da später noch mehrere Temperatursensoren und diverse Sonden / Sensoren dran sollen (PH, Leitwert, Feuchte etc).

So siehts gerade aus:
9  International / Deutsch / Re: Peristaltik / Dosierpumpe 6V on: October 13, 2013, 06:39:43 am
So.... ich hab nen anderen PIN versucht - keinen Erfolg.

YUN durch UNO getauscht - keinen Erfolg

ULN getauscht: keinen Erfolg

Pumpe getauscht: rennt.


Was eigentlich komisch ist. Schließe ich die Pumpe direkt an 6V an rennt sie auch....
10  International / Deutsch / Re: Peristaltik / Dosierpumpe 6V on: October 13, 2013, 06:10:24 am
Naja, die Anzahl der Bauteile war bei dem Test ja recht übersichtlich =)

Arduino YUN - neu
ULN2803a - neu
Pumpe - neu

Mehr isses ja dann nicht gewesen smiley
Ich teste mal.
11  International / Deutsch / Re: Peristaltik / Dosierpumpe 6V on: October 13, 2013, 05:22:13 am


Ich habe +7,5V an PIN 10 und Masse an PIN 9 gehabt. So sollte das ja auch sein, oder nicht...
12  International / Deutsch / Re: Peristaltik / Dosierpumpe 6V on: October 12, 2013, 04:12:11 pm
Hm... nun hab ich doch noch einmal ne Frage...

Ich hab das ganze eben mal auf dem breadboard zusammengesteckt und dabei festgestellt, das nach jedem lauf weniger spannung anliegt...

dafür habe ich diesen sketch genommen:
Code:
#define delaytime 5000

void setup()  {
  pinMode(0, OUTPUT);
  pinMode(1, OUTPUT);
  pinMode(2, OUTPUT);
  pinMode(3, OUTPUT);
  pinMode(4, OUTPUT);
 
  digitalWrite(0,LOW);
  digitalWrite(1,LOW);
  digitalWrite(2,LOW);
  digitalWrite(3,LOW);
  digitalWrite(4,LOW);
  delay(250);
}

void loop()  {
  digitalWrite(3,HIGH);
  delay(delaytime);
  digitalWrite(3,LOW);
  delay(delaytime);
  }       

also nix aussergewöhmliches.

Ich hatte eine Pumpe an Pin 3 zum testen. Der Arduino lief noch über usb. Also gingen nur die Kabel der Pins zum Array.
Bei 2,5V wollte die Pumpe dann nicht mehr.
Das ganze lief auf 7,5V.

Die Pumpe ansich läuft noch, also hab ich wohl irgendwie das array geschrottet... aber wie??? Das kann doch bis 30V ab, oder nicht?
13  International / Deutsch / Re: Peristaltik / Dosierpumpe 6V on: October 11, 2013, 08:47:11 am
Ah, ok.

Naja, letzten Endes mache ich eh immer eine "Masseschiene" auf die Platine. D.h. das wäre "in Echt" dann da gewesen. Aber danke für den Hinweis!
14  International / Deutsch / Re: Peristaltik / Dosierpumpe 6V on: October 11, 2013, 07:03:02 am
Hm... das hatte ich doch auf der ersten Abbildung....

Daraufhin:
Quote from: Eisebaer
GND nicht so wie auf Deinem bild, daß "über den arduino" gegangen wird.

Oder verstehe ich was falsch?
15  International / Deutsch / Re: Peristaltik / Dosierpumpe 6V on: October 09, 2013, 12:58:46 pm
Auf ein neues smiley

Rot = +
Schwarz = -
Motor Gelb = -
Motor Grün = +
smiley-wink

Pages: [1] 2 3