Show Posts
Pages: [1] 2
1  Using Arduino / Networking, Protocols, and Devices / RN42 Status LEDs on: September 22, 2013, 04:02:22 pm
I have an RN42 Bluetooth module.  Per datasheet, the PI02 status pin goes high when the module connects, otherwise low.  The PI05 status pin blinks while waiting to connect, then goes low when the module connects.

Can both pins be attached to same LED?  I'd expect the LED to blink while waiting to connect then glow steady when a connection is made. 

Connecting the pins to separate LEDs act this way.

Don't want to fry the module trying both pins on one LED, thought I'd ask first if someone's tried and knows.

Thanks
2  Using Arduino / General Electronics / De-Soldering RN42 on: August 26, 2013, 08:42:37 am
I have a couple rather pricey RN-42 Bluetooth modules I'd like to salvage from bad boards.  Anyone ever manage to de-solder them?  How?  Don't have a hot-air station, hope that's not the only way.
3  Using Arduino / Microcontrollers / Re: Real slow atmega328p on: August 07, 2013, 12:38:56 pm
The 28kHz was copy/pasted from the Arduino IDE messages.

I'm confused about what's going on.  I was playing with a LilyPad bootloader and that may possible what's on the 328p. But why Arduino IDE loads sketches with the UNO board selected in this case is strange.

Hope to get to the bottom of this once I can get the fuses read and bootloader identified.

4  Using Arduino / Microcontrollers / Re: Real slow atmega328p on: August 07, 2013, 10:32:49 am
No errors uploading sketches, but found this in the verbose messages...

The slow 328p:
        Vtarget         : 0.3 V
         Varef           : 0.3 V
         Oscillator      : 28.800 kHz
         SCK period      : 3.3 us

A regular 328p:
         Vtarget         : 0.0 V
         Varef           : 0.0 V
         Oscillator      : Off
         SCK period      : 0.1 us

I got the above by uploading a little sketch to the slow and to a regular 328p and comparing the messages.

I'm guessing my fuses are set wrong on the slow 328p or the 16Mhz resonator isn't soldered well(?).

I'll try to wire up the MISO/MOSI pins and try to check the fuses for sure that way.

Sure would be nice if AVRDude would message out the fuse settings when uploading sketches.

 
5  Using Arduino / Microcontrollers / Re: Real slow atmega328p on: August 05, 2013, 01:52:22 pm
Thanks Crossroads.  I think I can tack on some wires and check fuses that way, but was hoping to avoid that.

Is it odd that the Arduino IDE programs without complaint if the fuses may not be right?

6  Using Arduino / Microcontrollers / Real slow atmega328p on: August 05, 2013, 12:49:45 pm
I soldered up a prototype board (my first attempt with SMD parts and a hotplate) with an atmega328p-au with a 16mhz resonator and some sensors.  I'm pretty sure I pre-loaded an UNO Optiboot bootloader to the 328p.  The Arduino IDE seems fine when programming the 328p with the UNO board selected.

Unfortunately I no longer have access to the miso/mosi pins, just rx/tx, etc for loading sketches via FTDI. 

Anyways, the sketches I run are responding VERY slowly, about 1 mhz apposed to 100 mhz with a breadboarded prototype.

Is there a way to determine what speed the processor is running at?  I'm thinking I may have a fuse problem and the internal clock/divide 8 may be occuring.  Anything else may be causing the large slow-down? 
7  Using Arduino / General Electronics / Wiring capacitors on: June 07, 2013, 12:53:28 pm
Is there a difference by wiring the capacitors before or after the unit you're powering?

8  Using Arduino / General Electronics / Re: Land Pattern doesn't match chip? on: May 18, 2013, 04:00:27 pm
Thanks for the recommendation.

However, I'm still curious....

The chip has pads 0.6, 0.4 and 0.6 wide, spaced 0.95 apart.
The pattern has all three pads 0.3 wide, spaced 0.08 apart.

Doesn't seem to fit very well.  Or is this OK?
9  Using Arduino / General Electronics / Land Pattern doesn't match chip? on: May 18, 2013, 02:07:07 pm
I'm trying to setup a PCB footprint for a 16mHz Ceramic resonator.

I was looking at this CSTCE_V part in this Murata datasheet...

http://www.murata.com/products/catalog/pdf/p16e.pdf

The CSTCE_V chip dimensions on page 23 don't seem to match the recommended land pattern on page 25, the chip pads are wider than the PCB pads.

Is this a problem?

Am I not reading this right?

I'm working on my first PCB layout.

10  Using Arduino / General Electronics / Re: What diode to use? on: April 28, 2013, 10:00:21 pm
I noticed some coin cell battery holders (with a metal clip on one side) that won't contact the + and - ends of the battery if it's installed backwards.  Low-tech reverse polarity protection - clever design.
11  Using Arduino / General Electronics / Re: What diode to use? on: April 24, 2013, 11:21:20 am
A couple voltage regulators I looked at are:


http://www.micrel.com/_PDF/mic5205.pdf
http://www.micrel.com/_PDF/mic5203.pdf

All the sheets have is a bullet point about a reverse polarity protection feature.

12  Using Arduino / General Electronics / Re: What diode to use? on: April 23, 2013, 09:39:11 pm
I noticed on the data sheets of a couple voltage regulators I was considering for my project that they have reverse polarity protection.  The sheets don't explain, maybe it's too obvious.  Can this take the place of the diode?
13  Using Arduino / General Electronics / Re: What diode to use? on: April 20, 2013, 08:36:19 pm
Trying to read some data sheets (for instance a SOD-123 20V Vr Schottky diode) the lowest Vf I've found is about 400mV.  Does this mean with a 3.7v battery I'd be getting 3.3V through the diode (losing about 10%)? 

Obviously I'm no electronics engineer, just trying to learn.

Thanks   
14  Using Arduino / General Electronics / What diode to use? on: April 20, 2013, 01:47:40 pm
Newbie here...

What kind of surface mount diode should I use?  My project will be powered with a 3.7v coin cell battery or 5v USB.  I want to protect again the power being connected backwards, but waste as little power as possible with the diode.

Any suggestions?
15  Using Arduino / Project Guidance / Re: Accelerometer offset correction on: April 18, 2013, 06:07:47 pm
Accelerometer alone won't do it, you'll also need a gyroscope sensor.  The gyroscope will sense the tilt (rotation) and combined with the accelerometer you can determine the 'gravity compensated' acceleration, and from that the velocity it's moving at and from that the distance moved.  The math and the 'fusion' of the two sensors gets real bizarre.  Look up 6/9 DOF IMU's and check the Arduino sensors forum.  If you really want to do this you're in for a long journey.  But it can be done. 
Pages: [1] 2