Show Posts
Pages: [1] 2 3
1  Using Arduino / Audio / Re: New library for PWM playback from SD cards: SimpleSDAudio on: March 08, 2013, 10:40:14 am
Hi,

I got it finally working.

But not with that FAKEduino.
I made my own board.

Sadly, outputting an audio is just a part of the project. The whole project isn't working yet.

Question: Are there pins affected when using this library? For example, some digital pins won't work...something like that?
2  Using Arduino / Audio / Re: New library for PWM playback from SD cards: SimpleSDAudio on: February 27, 2013, 05:15:27 pm
Quote
remove the SS (D10)..

Does it mean that the voltage divider: D10-----4k7----.----10k-----gnd    will be removed?

3  Using Arduino / Audio / Re: New library for PWM playback from SD cards: SimpleSDAudio on: February 27, 2013, 11:32:52 am
I misunderstood the hardware set-up.

Is this correct already? (check image)
4  Using Arduino / Audio / Re: New library for PWM playback from SD cards: SimpleSDAudio on: February 27, 2013, 10:40:03 am
Hi

I think I followed exactly the schematic you posted.
There are 3 voltage dividers connected to MOSI, SCK, and CS.

PLUS: The testing for the BAREMINIMUMWITHDEBUG says that CS pin of SD card goes to digital pin 4 of crapduino.

What part did I not follow sir? I really need the audio ASAP. It's for a school project.
5  Using Arduino / Audio / Re: New library for PWM playback from SD cards: SimpleSDAudio on: February 27, 2013, 04:49:29 am
Kindly let me know what it means by the error codes so I know what to check.

Thank you.

When I upload, I sometimes get this error:

avrdude: stk500_getsync(): not in sync: resp=0x00

I'm using an Aduino 1.0.3 IDE.
6  Using Arduino / Audio / Re: New library for PWM playback from SD cards: SimpleSDAudio on: February 27, 2013, 03:59:38 am
Hi again.

I'm almost losing hope.
But before I turn into incredible hulk and destroy everything, I'll try my best to do it. smiley-grin

I am attaching an image of my connection to the crapduino and to the sd card.

Question: What brand of SD cards are working for this application?

SD card CS goes to pin 4?
Please check the attached image...
7  Using Arduino / Audio / Re: New library for PWM playback from SD cards: SimpleSDAudio on: February 26, 2013, 06:49:23 am
When I run the BareMinimumWithDebug, the error code is 3.

Can anyone answer post number 145? Thank you.

Kindly check the schematic. I always connect my CS pin on pin 4 which is T0 (PD4) of the ATMEGA328P.
8  Using Arduino / Audio / Re: New library for PWM playback from SD cards: SimpleSDAudio on: February 24, 2013, 03:42:17 pm
yes, I'm using a level shifter.
I followed the second circuit. Resistor values are 4k7 and 10k.
If I supply my level shifter with 5 volts, the drop across 10k with respect to ground is around 3.37 to 3.4 volts.
This means that my level shifter is OK.

If I turn on my crapduino, what voltage should I read from the SPI pins?
9  Using Arduino / Audio / Re: New library for PWM playback from SD cards: SimpleSDAudio on: February 24, 2013, 02:10:24 pm
Unfortunately, it still doesn't work
This is my connection.
CS---------D4
MOSI------D11
SCK-------D13
MISO------D12

If I turn on the crapduino and upload absolute minimum, what readings should I get from this pins: D4, D11, D12 and D13 provided that I have not made any connection yet.

Because I am getting:
D4: 0.1 volt
D11: 5volts
D12: 0.1 volt
D13: 0 volt


10  Using Arduino / Audio / Re: New library for PWM playback from SD cards: SimpleSDAudio on: February 22, 2013, 04:25:00 pm
I have the CRAPduino that appears on this site #?!! site.. http://www.e-gizmo.com/KIT/Gizduino.html

Only 4.7k and 10k resistors are available with me now.

The 3.3 volts pin on my crapduino outputs about 3.3 volts so it's correct.

In my voltage divider with 4.7k and 10k, i get a 3.3 to 3.4 volts accross 10k.

I use 1.0.3 IDE. Board: Gizduino (mini) with atmega 328. Programmer: AVR ISPmkII.

11  Using Arduino / Audio / Re: New library for PWM playback from SD cards: SimpleSDAudio on: February 22, 2013, 03:43:12 pm
+5V------4.7k-----(x)-----10k------gnd

this will be for mosi, sck, and cs

MISO does not need a level shifter.

is this already correct?

12  Using Arduino / Audio / Re: New library for PWM playback from SD cards: SimpleSDAudio on: February 22, 2013, 03:26:28 pm
The SD card is still working.
It still contains the DING, DONG, and EXAMPLE.

I will then construct the "DIODE" from this site.
http://www.sparkfun.com/tutorials/65
13  Using Arduino / Audio / Re: New library for PWM playback from SD cards: SimpleSDAudio on: February 22, 2013, 02:55:05 pm
Hi,

Thanks for the replies.
I had a little experiment that may help you help me.
I measured SCK of SD car to gnd: 0V
MOSI = 4.4V
MISO = 5V
CS = 5V

Added later: I guess this already shows the error on interfacing.
Do you think this http://www.sparkfun.com/tutorials/65 can already correct the error?
14  Using Arduino / Audio / Re: New library for PWM playback from SD cards: SimpleSDAudio on: February 22, 2013, 02:15:30 pm
My board has a 5V and 3.3 V.

I directly connected the MOSI, MISO, and SCK of the SD card to the MOSI, MISO, and SCK of my arduino.
I also directly connected the VCC pin of my SD card to the 3.3V of the arduino.
After connecting everything, I checked the voltage at the 3.3V pin of my arduino.
I used a fluke to measure the voltage. I got a reading of 4.3 volts.

I'll try the 100uF. It might work.
Also, I'll try connecting the audio out to pin 9.
15  Using Arduino / Audio / Re: New library for PWM playback from SD cards: SimpleSDAudio on: February 22, 2013, 01:52:18 pm
After connecting the SPI pins on corresponding pins, CS to pin 4, 100 ohm resistor to pin 10 and then the speaker, I tried measuring the 3.3 volt supply from the board and it went up to 4.3 volt. I think it's not normal. What might be the cause?
Pages: [1] 2 3