Show Posts
Pages: [1]
1  Using Arduino / Project Guidance / Re: Help with RTC on: April 03, 2013, 02:30:37 pm
I got my hands on an other RTC module which is the same type, but it was working! So my problem was at all time that the original RTC was broken smiley-sad
Crap. But I don't know what could gone wrong in it? The eeprom or the IC maybe, but nothin other stuff.
2  Using Arduino / Displays / Re: 1.8 SPI TFT from ebay - problems on: February 27, 2013, 03:42:52 pm
By the 1kohm resistors you mean the PCB has them? I know it.

And a dumb question: Ho can I wire paralell the miso/mosi/sck in a prototype board?

Thanks!
3  Using Arduino / Project Guidance / Re: Help with RTC on: February 27, 2013, 06:09:30 am
Hi,

Yes, it is a snippet from my code, and most of it is from the example. I've just only posted the setup() and loop() parts of it.

I need to use the library from adafruit, since I will need to store the unix time (I mean the number of elapsed seconds from 1970 jan 1.).

Thanks
4  Using Arduino / Sensors / Re: multiple sensors on one pin on: February 27, 2013, 05:39:27 am
Hi,

I have been searching through the forums, before I got here with my question. I really don't have any electronics / engineering knowledge, I'm just a programmer whom can google for things and make the wiring from the tutorials, so please don't take my question as a dumb or silly thing.

So I have my own project, where there are some sensors and electronic modules (TFT LCD) that need to use the same hardware pins like SPI hardware (pins 50-53) and TWI hardware (pins 20-21).
So based on my googleing, and this forum, I see it is possible, but how?
Should I only use a simple wiring, where all wires of these sensors go to the same pins (so like all SDA requirements goes to pin 20), and do I just have to adjust a code for this behaviour?

Like I read a sensor, write a low voltage to the pin, and then read from the other sensor? Or do I need anything else? Do you have a sample scratch, or a tutorial, where I could start with?

Thank You!
5  Using Arduino / Project Guidance / Re: Help with RTC on: February 27, 2013, 05:16:08 am
Hi,

I also have this RTC module. I have wired it to an arduina mega adk r3. The wiring is correct, and I'm trying to use the library from the adafruit tutorials.

I have managed to set the time on the RTC, but I have some problem with it now.

Here is my code:
Code:
void loop () {
    DateTime now = RTC.now();

    Serial.print(now.year(), DEC);
    Serial.print('/');
    Serial.print(now.month(), DEC);
    Serial.print('/');
    Serial.print(now.day(), DEC);
    Serial.print(' ');
    Serial.print(now.hour(), DEC);
    Serial.print(':');
    Serial.print(now.minute(), DEC);
    Serial.print(':');
    Serial.print(now.second(), DEC);
    Serial.println();

    Serial.print(" since 1970 = ");
    Serial.print(now.unixtime());
    Serial.print("s = ");
    Serial.print(now.unixtime() / 86400L);
    Serial.println("d");
    delay(3000);
}

My problem is that the RTC seems like it has stopped ticking, here is the output from it:
Code:
2013/2/23 21:48:58
since 1970 = 1361656138s = 15759d
2013/2/23 21:48:58
since 1970 = 1361656138s = 15759d
2013/2/23 21:48:58
since 1970 = 1361656138s = 15759d
2013/2/23 21:48:58
since 1970 = 1361656138s = 15759d
2013/2/23 21:48:58
since 1970 = 1361656138s = 15759d
2013/2/23 21:48:58

Do you have any idea, what could be my problem?

Thank You!
6  Using Arduino / Displays / Re: 1.8 SPI TFT from ebay - problems on: February 26, 2013, 04:18:04 pm
Hi,

Thanks for your reply, it works rewired!
Here is my wiring with arduino mega:
Mega pin     Arduino pin     TFT  module Pin
8                   8 rst              6  rst
9                   9 dc               7 A0
10                 10 cs             10 cs
51                 11 mosi          8  SDA
52                 13 sclk           9 SCK

But I have another question: how will my SD card work with this wiring? Since he sd card has a different set of pins (it works with it):
TFT            Mega
11 SCK        51 SCK
12 Miso       50 miso
13 Mosi       52 mosi
14 CS          53 SS

So my problem here, is that
- TFT pins 8 (SDA) and 13 (Mosi) should be connected both to mega pin 52.
- TFT pins 9 (SCK) and 11 (SCK) should be connected both to mega pin 51

So what to do with this? Should I wire it like this? Or how?

And another thing: should I use the standard SD fat32 library with this TFT? Or any other?

Thanks for your help!
7  Using Arduino / Displays / Re: 1.8 SPI TFT from ebay - problems on: February 26, 2013, 05:36:11 am
Hi,

I have a 1.8 SPI TFT also from ebay, but my problem is that I have a 16pin pcb.
Like this:
http://www.ebay.co.uk/itm/1-8-Serial-128X160-SPI-TFT-LCD-Module-Display-PCB-Adapter-with-SD-Socket-/200764741074?pt=LH_DefaultDomain_0&hash=item2ebe82d5d2&_uhb=1

I have found its datasheet:
http://www.egochina.net.cn/eBay/Download/JD-T1800_PCB.rar

Has anyone encountered & used this kind of TFT before?
My problem is that I have tried to follow the instructions from the adafruit tutorial, but I just have more pins that I could figure out on howto connect. Also, I need to use both the TFT display & SD cards, so I have the MISO-MOSI-SCK-SS pins (50-53) reserved. Oh, and I'm using an arduino mega adk r3.

Can anyone help me with the wiring?

Thank You!
8  Using Arduino / Programming Questions / Re: sd module in Mega "Card failed, or not present" What I doing wrong? on: February 26, 2013, 05:21:23 am
OK, got my SD socket to work smiley

Just for anyone else, having the same problems, always think of:
1. start from a scratch, don't be afraid to clear all wiring
2. a bigger prototype board (830 pins, or more), has 2*2 power lines (the two side power lines divide to two other lines!! - I was missing this point)
9  Using Arduino / Programming Questions / Re: sd module in Mega "Card failed, or not present" What I doing wrong? on: February 20, 2013, 01:09:16 pm
Before the post is closed, can you post your code & wiring here that worked?

THANK YOU!  smiley
10  Using Arduino / Programming Questions / Re: sd module in Mega "Card failed, or not present" What I doing wrong? on: February 19, 2013, 07:20:18 am
Thank you, thank you. I'm re-wired the connections

50 MISO
51 MOSI
52 SCK
53 CS

in the sketch

...
const int chipSelect = 53;
...
pinMode(53, OUTPUT);
...

and just foward to the next step. Card is found, but can't open the file. This is the result: "Initializing SD card...card initialized.error opening datalog.txt". The Sd-card is an 4Gb card and formated as Fat16.

Thanks in advance


I have already tried it, it isn't working. I have read taht for a 4GB card you have to use FAT32. Use FAT16 to a 1GB card, or smaller.
11  Using Arduino / Programming Questions / Re: sd module in Mega "Card failed, or not present" What I doing wrong? on: February 18, 2013, 03:35:44 pm
Hi,

I'm having the same problems. I have the attached a photo of the SD card adapter. I'm trying to wire it to an Arduino Mega ADK R3.
I'm using a 8gb micro SD card through an adapter, formatted to fat32.

I have tried connecting SCK to pin 52, Miso to 50, Mosi to 51 and CS to SS (pin 53). Also, I have tried it with a 1.8 SPI TFT-SD card combo.

I have modified the code, to wire chipselect to 53, also tried it with pin 10 (changed the wiring). I have seen it in an other topic that someone added a
Code:
digitalWrite(53, HIGH);
right after the
Code:
pinMode(53, OUTPUT);
line. I have tried my arduino with the CardInfo sample (just modified the sample code to fit the pin 53).

Can anyone help me Please?

Thank You!
Pages: [1]