Show Posts
Pages: 1 [2]
16  Using Arduino / LEDs and Multiplexing / TLC5940 and dot correction on: March 27, 2013, 07:22:34 pm
Hi,

I have an Arduino mega 2560, and one (later man) TLC5940 to control RGB LEDs.
It works all great.

I want to use the dot correction in order to get better color (yellow, is more green etc...).

So, I connect the pin 27 of the TLC to the pin 50 of my arduino, and enable VPRG in the config file.

Thats my code: (from the TLC5940 library http://alex.kathack.com/codes/tlc5940arduino/html_r014/group__ReqVPRG__ENABLED.html)

Code:
#include "Tlc5940.h"
#include "tlc_progmem_utils.h"


prog_uint8_t dcArray1[NUM_TLCS * 12] = {
DC_QUARTET(32, 63, 32, 63), DC_QUARTET(32, 63, 32, 63),
DC_QUARTET(32, 63, 63, 63), DC_QUARTET(32, 63, 32, 63),
};
// treid with differents values  for the dot correction

void setup(void)
{
Tlc.init();

tlc_setDCfromProgmem(dcArray1);

while (Tlc.update()); // tried with and without this line
}

void loop(void)
{
Tlc.clear();

// set red color to all rgb lights

Tlc.update();

}

The RGB light are no more red but more cyan/white.

I don't really understand how it should work.
Did somebody already get dot correction working on an arduino mega?

Thanks for your help!
17  Development / Other Software Development / Re: Arduino on Xcode Project — Official Thread on: March 13, 2013, 06:52:16 pm
Hey Avenue33,

thanx for your very quick answer !

Unfortunately the change of the makefile didn't help me. When I build I get the same error as when I tried to change the sketchbook libraries folder to Libraries (in the finder).  smiley-sad

In my first post, I wrote that about the case insentive stuff because you asked eduardorcosta if he uses a case sensitive file format.
18  Development / Other Software Development / Re: Arduino on Xcode Project — Official Thread on: March 13, 2013, 05:52:40 pm
Hi,

I've exactly the same problem as eduardorcosta.

I've Arduino IDE 1.5 on Mountain Lion (case-insensitive system). It automatically create a folder "libraries" (with a lower L).

I installed embedxcode exactly like in the documentation. I can build and upload to my Arduino board.
But when I need a local library, it didn't work. When I build I become the following errors:

error: ble.h: No such file or directory
error: 'ble_begin' was not declared in this scope


To add libraries, I follow the guide at § 3.2.3.
If I try to change the Sketchbook libraries folder to "Libraries" (with upper L), the Arduino IDE doesn't compile anymore, and under xcode I become the following errors when compiling:

(all error for the app.cpp file,a file from the BLE library)

/Documents/Arduino/Libraries/BLE/app.cpp:17:22: Services.h: No such file or directory
/Documents/Arduino/Libraries/BLE/app.cpp:18:21: error: lib_aci.h: No such file or directory
/Documents/Arduino/Libraries/BLE/app.cpp:46: error: 'lib_aci_device_wakeup' was not declared in this scope
/Documents/Arduino/Libraries/BLE/app.cpp:56: 'lib_aci_send_setup_msg' was not declared in this scope
and 11 more errors…

It would be really great if somebody knows a solution for this problem.

Thanks a lot!
Kass
Pages: 1 [2]