Show Posts
Pages: [1] 2
1  Development / Other Software Development / Re: Arduino on Xcode Project — Official Thread on: February 20, 2014, 07:20:18 am
I've found it in the user manual. It's greatly improved.
I'll review it before posting next time~~
Thank you all the same~~
2  Development / Other Software Development / Re: Arduino on Xcode Project — Official Thread on: February 19, 2014, 10:51:56 pm
Hi,
I'm using the embedXcode+ • Feb 10, 2014 release 132 with the "embedXcode+ Example" template
Xcode 5.0.2
Mac OSX 10.9.1

If the user library is updated in Xcode, the "Fast" Scheme seems not compile the changed library?

3  Development / Other Software Development / Re: Arduino on Xcode Project — Official Thread on: November 13, 2013, 04:49:21 am
I resolved it by uninstalling it using the app under the document.

PS:
Perhaps you lost an 's' in the "document" folder. A new folder named "Document" is in my home folder after installation.
4  Development / Other Software Development / Re: Arduino on Xcode Project — Official Thread on: November 13, 2013, 04:30:54 am
I've dealt with this problem by moving the incompatible user library before. However at this time, whatever user library I put into the library folder, the project will be lost.
Since there is no such problem in ver.110 ,I can maintain use this version. But can you figure out the reason why?
5  Development / Other Software Development / Re: Arduino on Xcode Project — Official Thread on: November 12, 2013, 10:25:34 pm
Hi,
I've just updated to embedXcode+113 in Mavericks. However when I try to create a new project ,set the USER_LIBS_LIST = 0, and build it. After successfully compile the project, all the files in the left project navigator disappear except the project file. If I click this project file ,an error diagram pops up "The file couldn't be opened".
If I remove all the user library away, this problem will no longer exist. However if there is any library in the library folder, this problem remains.
I turn back to the ver.110. There is no such problem in it.
6  Development / Other Software Development / Re: Arduino on Xcode Project — Official Thread on: October 26, 2013, 06:27:14 am
Hi~~
A good news that after re-installing the mavericks everything goes well. However I don't know the reason why?
7  Development / Other Software Development / Re: Arduino on Xcode Project — Official Thread on: October 25, 2013, 04:54:59 am
I've updated to 5.0.1. However it doesn't work either. I even create a new account, but no help...
Tonight I'll install a new mavericks to test whether the problem exists again~~
I'll give you the feedback tomorrow~~

Thank you~~
8  Development / Other Software Development / Re: Arduino on Xcode Project — Official Thread on: October 25, 2013, 01:27:38 am
Hi,

Does the code sense work well on your Mavericks ? Upgrading to Ver.110 did no help for me...

9  Development / Other Software Development / Re: Arduino on Xcode Project — Official Thread on: October 14, 2013, 12:36:45 am
Hi~~

I've tried my best to find the solution. However there aren't any issues about it. 
I also ask my colleague with 3 years IOS development about this problem, but he is not familiar with external environment configuration.

I'm Sorry...
10  Development / Other Software Development / Re: Arduino on Xcode Project — Official Thread on: October 11, 2013, 02:36:54 am
Arduino IDE works fine in Mavericks, as it is based on Java~~
11  Development / Other Software Development / Re: Arduino on Xcode Project — Official Thread on: October 10, 2013, 10:59:53 pm
Hi~~

Have you upgrade to Mavericks? I use Mavericks GM and Xcode 5, but  code hinting seems not working.
If I change the #include"Arduino.h" to
#include"/Applications/Arduino.app/Contents/Resources/Java/hardware/arduino/avr/cores/arduino/Arduino.h"
The code hinting works for the function. However Registers like "UBRRH" seem not defined so variables like "Serial" doesn't have code hinting either.

Do you have this problem? Thank you ~~
12  Development / Other Software Development / Re: Arduino on Xcode Project — Official Thread on: July 29, 2013, 01:01:13 am
Hi,
Does the "Fast" Scheme disappear?
My macbook is not powerful enough. Thus where can I find it?
Thank you~~
13  Development / Other Software Development / Re: Arduino on Xcode Project — Official Thread on: July 11, 2013, 03:24:52 am
Problem solved with the latest version~~

Thank you!
14  Development / Other Software Development / Re: Arduino on Xcode Project — Official Thread on: July 10, 2013, 01:11:55 am
Hi avenue33,
There is something wrong when preparing the project with ver.57. The "External Build Tool Configuration" seems to be unchanged after the first preparation.
15  Development / Other Software Development / Re: Arduino on Xcode Project — Official Thread on: April 26, 2013, 03:10:18 am
I have tested it, but it didn't work either. the HardwareSerial.cpp is the core of arduino instead of the library.
Pages: [1] 2