Show Posts
Pages: [1]
1  Using Arduino / Storage / Re: Read image from SD and display on UTFT on: March 07, 2013, 02:45:41 pm
A good start for you as inspiration can be from here

http://www.henningkarlsen.com/electronics/library.php?id=51

2  Forum 2005-2010 (read only) / Syntax & Programs / Re: Reseting Arduino from Software on: January 10, 2010, 09:04:01 am
I'm back with news ! I used a 555 monostable and now I can reset arduino using one digital output from software . It works fine !  smiley

3  Forum 2005-2010 (read only) / Syntax & Programs / Re: Reseting Arduino from Software on: December 16, 2009, 09:07:10 am
Thanks!  smiley
4  Forum 2005-2010 (read only) / Syntax & Programs / Re: Reseting Arduino from Software on: December 15, 2009, 02:33:03 pm
I believe ( after finding some posts with google ) that WDT is not the best option . So I will try 555 timer . I'll keep you informed !
5  Forum 2005-2010 (read only) / Syntax & Programs / Re: Reseting Arduino from Software on: December 15, 2009, 02:11:07 pm
I'm back ! I did try to use watchdog timer from controler to reset it .
Something like a new function :

Code:
void ResetArduino()
      wdt_enable(WDTO_1S);

The code is good but Arduino doesn't start again until a power off  smiley-sad . Not good for me because he is just restarting and restarting .

I did try to disable watchdog like that .

Code:
void setup(){

wdt_reset();
wdt_disable();

...

}

But still no luck ! Any ideea ? What is it wrong ?
6  Forum 2005-2010 (read only) / Syntax & Programs / Re: Reseting Arduino from Software on: December 14, 2009, 03:02:05 pm
I believe that the Shield is the problem because after power on , I'm trying a ping test . I have no response ! After manual restart , I have replies from ethernet shield !
7  Forum 2005-2010 (read only) / Syntax & Programs / Re: Reseting Arduino from Software on: December 14, 2009, 02:56:54 pm
I have a code that upload some data to a pachube feed .

http://www.pachube.com/feeds/3924

 When it is powered on the code is not working . I believe the problem is the ethernet shield . After a manual reset everything is ok and working !

So I want to use software reset to do everything automaticaly . Is it any way ??
8  Forum 2005-2010 (read only) / Syntax & Programs / Reseting Arduino from Software on: December 14, 2009, 02:46:18 pm
Hi everyone ! Can you help me please with some ideas ! Is it any way I can reset Arduino using software and not hardware ( by pressing a reset button ) ?

I need something like a procedure to used in a code to reset Arduino .

Thank's in advance and I look forward for your reply's !
9  Forum 2005-2010 (read only) / Interfacing / Re: Using the I2C PCF8563 Real Time Clock on: April 03, 2010, 08:43:12 am
Thank's a lot Jonen ! Now my clock is working !  smiley
10  Forum 2005-2010 (read only) / Exhibition / Re: Logic Analyzer for Arduino based on IKALOGIC on: June 08, 2010, 01:15:54 am

But ...
"As my life is getting more and more busy lately, i decided to give up the source codes for the scanalogic solutions, with one and only condition : "any modified version should be hosted only on ikalogic forum". "
http://www.ikalogic.com/phpBB3/viewtopic.php?f=16&t=178&st=0&sk=t&sd=a&start=90#p2363

11  Forum 2005-2010 (read only) / Exhibition / Logic Analyzer for Arduino based on IKALOGIC on: June 08, 2010, 12:50:24 am
Hello everyone !
I was trying last days to find a logic analyzer for Arduino to debug a weather transmiter . After a lot of searches on the net I did find something but not for ATMEGA328 . It was a code writed for ATMEGA16 and with a software useful for reverse engineering protocols .
The original software use a serial communication 9600 bps and 4 digital inputs that can be recorded .

I was trying to modify the original software for ATMEGA328 - 16 MHZ and at this point , this is what I could do .

http://www.ikalogic.com/phpBB3/viewtopic.php?f=16&t=178&p=5145#p5125

The big problem is that only one channel is working . I did not had time to find why . Maybe if anyone in here is interested and have time could take a look and try to figure out what is the problem .

Bye !  smiley
12  Forum 2005-2010 (read only) / Exhibition / Re: 2 LM35´s with a ethernet shield posting to pachube on: December 07, 2009, 12:40:37 pm
finally ! I did it ! Now I do  upload data with floating point .

see it here !

http://www.pachube.com/feeds/3747

smiley
13  Forum 2005-2010 (read only) / Exhibition / Re: 2 LM35´s with a ethernet shield posting to pachube on: December 07, 2009, 04:26:09 am
I still have some questions !

I don't understand how to upload floating data . In my arduino temp is 26.52 C . But i have to uplod 26 C because of the sprintf .

One way is to upload 26.52 * 100 = 2652 and in pachube to divide the value by 100 . Is it possible ?
14  Forum 2005-2010 (read only) / Exhibition / Re: 2 LM35´s with a ethernet shield posting to pachube on: December 06, 2009, 05:45:04 pm
Here is my data .
http://www.pachube.com/feeds/3742
15  Forum 2005-2010 (read only) / Exhibition / Re: 2 LM35´s with a ethernet shield posting to pachube on: December 06, 2009, 04:58:42 pm
Great job ! I'm trying to do the same thing but I don't understand how to upload floating data . In your code you upload decimal data
Code:
sprintf(data,"%d,%d,%d,%d,%d,%d,%d,%d",val1,val2,val4,val2/1000,val3,val3/1000, successes + 1, failures);

but on the pachube I see you have floating numbers . HOW can I do the same ???

Pages: [1]