Show Posts
Pages: [1]
1  International / Software / Retardos con delayMicroseconds() on: April 02, 2013, 11:08:51 pm
Hola, estoy realizando un proyecto para la universidad para lo cual en la primera parte necesito generar 3 señales digitales (RGB), para la señal del azul por ejemplo necesito una señal  de periodo 14,16uS con ciclo util 50%. Estoy usando un arduino UNO para lo cual pongo un pin en nivel alto hago un retardo delayMicroseconds(7) luego pongo el pin en nivel bajo y nuevamente el retardo, con eso deberia salir la señal, cuando mido la señal de salida da un periodo como de 40uS.

Es posible lograr obtener esos tiempos o parecidos? supongo que eso se debe a los tiempo de ejecucion de las instrucciones.
2  International / Hardware / Re: Problema con Arduino UNO on: March 26, 2013, 12:13:16 am
Jajaja! Gracias curro92, efectivamente era eso, me he dado cuenta por pura casualidad que solo debo darle en Archivo/cargar (ctrl+u) y listo. pero ahora entiendo el porque, cuando daba en compilar solo creaba el .hex su palabra lo dice solo compilaba, faltaba cargarlo  smiley-grin

Mi primer contacto arduino y con el foro para olvidar smiley-cool, pero bueno ahi se va aprendiendo.
3  International / Hardware / Re: Problema con Arduino UNO on: March 25, 2013, 06:01:01 pm
Hola, no se si lo este haciendo bien, explico. Instale programa (esta en español), drivers, seleccione la placa UNO, el puerto serial, luego abro Archivo/ejemplos/AnalogsInputs,  luego le doy en Sketcht/verificar-compilar, luego sale comilando sketcht y al finalizar pone "compilacion terminada" Tamaño binario del Sketch: 1.188 bytes (de un máximo de 32.256 bytes); y asi con otros ejemplos que compilo, el led del pin13 nunca se apaga.
4  International / Hardware / Re: Problema con Arduino UNO on: March 25, 2013, 09:28:09 am
Gracias por tu respuesta masteron. Ya he probado con varios de los ejemplos que hay en el software y cuando lo compilo no sale ningun error pone  "complilacion terminada" y el tamaño binario del Sketch, y el led sigue parpadeando
5  International / Hardware / Problema con Arduino UNO on: March 24, 2013, 09:18:40 pm
Hola,  soy Carlos vivo en Colombia soy estudiante de ingenieria y queriendo explorar y aprender mas sobre Arduino.

El dia de hoy tuve mi primer contacto con Arduino me llego la placa UNO, luego un rato pude instalar los driver, pero no to una falla creo no es normal, cuando conecte la placa por USB a mi portatil instantaneamente el led del pin 13 empieza a parpadear, crei que era normal pero cuando intente compilar algunos ejemplos siempre la el led del pin13 parpadea. Genere un codigo simpre para intentar a pagar ese led pero sigue igual

void setup() {
  pinMode (13,OUTPUT); //Configura el pin 13 como salida
}
void loop() {
  digitalWrite (13,LOW); //Asigna un estado 0 lógico al pin 13

}

Estuve leyendo un poco y posiblemente es una falla de alimentación, pero ya probé con otro ordenador de mesa y pasa lo mismo, probé un un cargador de 5v de una tablet y sigue parpadeando el Led, no se cual puede ser la falla.
Pages: [1]