Show Posts
Pages: [1]
1  Topics / Device Hacking / Re: Not enough voltage to trip digital HIGH pin on: May 06, 2013, 11:37:34 am
Right!?  It should be able to trigger the high.  Right now I'm only use a very basic program to serial read the pin:

int sens1;
int sens2 = 2;

void setup(){
  pinMode (sens2, INPUT);
  Serial.begin(9600);
}

void loop(){
  int read1 = analogRead(0);
  int read2 = digitalRead(sens2);
  Serial.print(read1);
  Serial.print(",  ");
  Serial.println(read2);
  delay(10);
}


I've tested the pins with a button and a potentiometer and they give normal readings.  However when reading from the chip the analog input reads either 600-700 (with the LED plugged in) or 1020-1022 (with no LED), and the digital only reads 0 (all this is reversed with the hex inverter of course).
2  Topics / Device Hacking / Re: Not enough voltage to trip digital HIGH pin on: May 05, 2013, 06:45:41 pm
This is the 18 pin chip (though I have the 20 pin chips as well).  I am wiring the 4 digital pins--the data sheet calls these Q1-Q4, and the StD pin as well--however none of these pins are able to trip arudino's digital High (though I can seen a signal change on the analog pins).  TOE is pulled to high (tied to the Vdd.

I'm attaching my circuit diagram drawing:
3  Topics / Device Hacking / Re: Not enough voltage to trip digital HIGH pin on: May 05, 2013, 02:36:45 am
Yea I tied the Arduino to the ground for the chip.  Internal pull up resistors seem to get me a tiny bit more juice but not enough.
4  Topics / Device Hacking / Not enough voltage to trip digital HIGH pin on: May 04, 2013, 06:33:51 pm
Hello I'm a bit new to Arduino and electronics.  I'm using an Arduino Uno to hack some telephones to use DTMF to communicate between two arduinos across phone lines (much like the cellphone controlled robots).  I am using a MT8870DE DTMF tone decoder right now (though I have some MT8888's).  It generates a binary code on four output pins.  Everything is working fine--the chip generates binary code when I send a tone from the phone--but the arduino can't read it.

I am getting just enough power to turn on an LED but apparently not enough for the digital pin to see it. 

Here are the things that I have tried:

-Having the chip send binary to LED lights
--Works--the lights turn on

-Having the chip send binary to arduino analog pin
--low reads 0-40, high reads 1020-1022 (only about 700 if the LED is plugged in)

-Send the signal to a HEX Inverter (DM74LS04)
--Works on an LED but gives the same (though opposite) values to the analog pin--and still does not trip HIGH for digital

-Send the signal to a transister (PN2222 and TIP120)
--not enough power to trip the transistor

Running out of ideas--I'm getting ready to just read this thing from analog (messy code) or do an optic coupler (just stupid)!  It seems like it should be so simple!

thanks

john
Pages: [1]