Show Posts
Pages: [1] 2
1  Forum 2005-2010 (read only) / Development / Re: Sound FX Library/Code Snippets on: April 26, 2007, 01:54:42 am
Good stuff. Sine waves would be a good challenge!
2  Forum 2005-2010 (read only) / Development / Sound FX Library/Code Snippets on: April 19, 2007, 03:14:13 am
Does anyone know of a PWM Sound FX library or code snippets? (Sorry if this is the wrong forum!)
3  Forum 2005-2010 (read only) / Troubleshooting / Re: ATmega168 clock speed? on: April 20, 2007, 06:37:54 am
Thanks for the details. We're using the 8/168 for some heavily timing dependent applications like stepper motors and servos (and also RS-232), so it sounds like the internal oscillator is quite out of contention.

Can anyone suggest a part number for a crystal with the caps built in that's worked well for them? Our projects are reaching the point where space is becoming an issue.

Thanks!
4  Forum 2005-2010 (read only) / Troubleshooting / Re: ATmega168 clock speed? on: April 19, 2007, 03:16:43 am
Could someone confirm that the 168 MUST be used with an external 16mhz crystal for Arduino to run 100% correctly? (i.e. there is no way to get it to run totally properly with the internal oscillator.)

Thanks!
5  Forum 2005-2010 (read only) / Development / Re: Turn Arduino into an ISP programmer on: April 12, 2007, 01:28:22 am
Quote
the instructions are not super simple yet, i'm working on writing a better tutorial.

Any progress on this? smiley

It's probably an obvious oversight on my part, but what should one change the port to in "load.command" for a PC COM port? Also, can one burn the regular Arduino firmware back to the chip after programming others?

Thanks!
6  Forum 2005-2010 (read only) / Development / Re: Arduino "Standalone" Serial Issues on: April 05, 2007, 07:58:21 pm
Thanks much!
7  Forum 2005-2010 (read only) / Development / Re: Arduino "Standalone" Serial Issues on: April 05, 2007, 07:33:23 pm
I did catch the mistake on the transposed pins, but everything you've said confirms exactly what my helper said as well. I found this schematic:



Does this look about right?

Thanks!
8  Forum 2005-2010 (read only) / Development / Arduino "Standalone" Serial Issues on: April 05, 2007, 06:38:20 am
I built the "Standalone" version at:
http://www.arduino.cc/en/Main/StandaloneAssembly

I've been unable to get serial comms working at all. I took it to an experienced engineer and he said that the 7404N chip was inappropriate and that something like a MAX232N should work instead.

1) Should I dump the 7404 in favor of the MAX232N?
2) If not, any thoughts on what I might be doing wrong? I've triple checked pinouts, connections, etc.
3) If I should swap, what might the new schematic look like? He said I'd need several capacitors for the 232 but I'm not sure just where they'd go.

Thanks!
9  Forum 2005-2010 (read only) / Development / Re: Crystal for Arduino Standalone on: February 22, 2007, 05:19:15 pm
Thanks!
10  Forum 2005-2010 (read only) / Development / Crystal for Arduino Standalone on: February 22, 2007, 05:45:05 am
On the parts list for the Arduino Standalone, the following part is listed:
Q1      16MHz      CRYSTAL 16.000 MHZ HC49/US      300-6034-ND

Unfortunately, Digi-Key no longer seems to stock it. What would be a good part to use instead? Could I just substitute any with the same package, clock speed, and capacitance?

Thanks!
11  Forum 2005-2010 (read only) / Development / Re: ATMega168 on Serial Arudino Board on: February 16, 2007, 12:07:00 am
Brilliant - thanks!
12  Forum 2005-2010 (read only) / Development / ATMega168 on Serial Arudino Board on: February 15, 2007, 04:01:39 am
What modifications (if any) would need to be made to run the ATMega168 on the serial board described here?:
http://www.arduino.cc/en/Main/ArduinoBoardSerial

(I do have access to a programmer, so that end is covered.)

Thanks!
13  Forum 2005-2010 (read only) / Interfacing / Re: Midi direct via USB? on: March 10, 2007, 10:34:10 pm
Thanks. I don't know if it would be the same for all XP installations, but I made a .reg file people could use. Just paste this into a file, name it "foo.reg" (or whatever) and double-click it to merge it into the registry. (USE AT OWN RISK! REG HACKS CAN KILL YOUR INSTALLATION!!!! BACKUP YOUR REGISTRY FIRST!!!!)

---paste below---

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\FTDIBUS\VID_0403+PID_6001+A4001drJA\0000\Device Parameters]
"PortName"="COM4"
"PollingPeriod"=dword:00000000
"ConfigData"=hex:11,00,3f,3f,10,27,00,00,88,13,00,00,c4,09,00,00,e2,04,00,00,\
  71,02,00,00,38,41,00,00,9c,80,00,00,60,00,00,00,34,00,00,00,1a,00,00,00,0d,\
  00,00,00,06,40,00,00,03,80,00,00,00,00,00,00,d0,80,00,00
"MinReadTimeout"=dword:00000000
"MinWriteTimeout"=dword:00000000
"LatencyTimer"=dword:00000010

---paste above---
14  Forum 2005-2010 (read only) / Interfacing / Re: Midi direct via USB? on: February 28, 2007, 08:30:47 pm
I can't get Windows to use the Arduino version of ftdiport.inf that I've changed; it insists on using the XP version in oem5.inf.

Any tips to force Windows to use my version? Is there a place in the registry I can just add the MIDI baud rate?

Thanks!
15  Forum 2005-2010 (read only) / Interfacing / Re: Guitar Pickup on: March 10, 2007, 10:36:03 pm
Excellent - thanks. Will any diodes or bridge rectifier do? I'm not sure that I have those particular diodes around, but I'm pretty sure I can salvage something.
Pages: [1] 2