Show Posts
Pages: [1] 2
1  Forum 2005-2010 (read only) / Español / Re: Multiplexores en cascada on: March 06, 2009, 03:45:43 pm
Perdón se me olvidó poner la pagina del multiplexor

http://www.e-merchan.com/pub/cd4067.pdf
2  Forum 2005-2010 (read only) / Español / Re: Multiplexores en cascada on: March 06, 2009, 03:44:38 pm
¿Se puede utilizar este multiplexor analógico como el del ejemplo que hay en la pagina de arduino?
Tiene 16 entradas/salidas es analógico y tiene A,B,C,D para meterle binarios hasta 15, claro, aunque estaría en el mismo dilema si quisiera montar con dos de estos multiplexores y uno de dos entradas un total de 32 entradas / salidas en la arduino.

Mi principal problema es que no tengo ni idea de como colocar los multiplexores en cascada. :'(
3  Forum 2005-2010 (read only) / Español / Re: Multiplexores en cascada on: March 06, 2009, 07:41:36 am
Muchas gracias por vuestras respuestas!

Gracias Outl4w estoy leyendo por internet sobre los multiplexores ya que estoy bastante verde en este sentido, voy a ver si elijo uno que me pueda venir bien y si me puedes guiar para conectarlos me sería de gran ayuda.
He visto algunos ejemplos que utilizan uno de cuatro entradas para conectar 4 de 8 entradas para tener 32 entradas / salidas.
http://essocra.blogspot.com/2008/02/electronica-digital.html

Gracias aclai le estoy echando un vistazo a la página, esto se podría hacer tambien con el 74hc4051 no?
4  Forum 2005-2010 (read only) / Español / Multiplexores en cascada on: February 23, 2009, 02:22:31 pm
Alguien tiene idea de como conectar el multiplexor 74hc4051 en cascada para lograr tener mas entradas y salidas analógicas???


Saludos!!
5  Forum 2005-2010 (read only) / Español / Re: Arduino PWM (salida analógicas) on: January 30, 2009, 11:04:13 am
Hola complubot,
me funciona bien como lo tengo, el problema es como si fuera de conexión, cuando quiero encender el led 5 (pwm) no se enciende totalmente sino que se queda a medias, sin embargo los demás si encienden en su totalidad.
Se iluminan todos totalmente menos el pin 5 y el pin 6.

__________________________________________________-


Efectivamente como dice complubot no hace falta declarar el pin que utilices como salida al utilizar analogWrite, Outl4w


Saludos!
6  Forum 2005-2010 (read only) / Español / Arduino PWM (salida analógicas) on: January 28, 2009, 09:26:18 am
Hola a todos, tengo un problema con las salidas analógicas de arduino Diecimila, y es que cada vez que intento encender un led progresivamente o no se enciende del todo, o ni siquiera enciende, o se encienden 2 o 3 leds a la vez.
Aquí un ejemplo del código que me hice para Arduino:

int PinUno = 3;    // Pin 3 de la tarjeta
int PinDos = 5;    // Pin 5 de la tarjeta
int PinTres = 6;   // Pin 5 de la tarjeta
int PinCuatro = 9; //Pin 5 de la tarjeta        
int valor = 0;     //valor para los pines    
int EstadoEntrada= 0;  // Dato de entrada desde el serial.

void setup() {
  Serial.begin(9600);
}

void loop() {
  if(Serial.available()>0){ //Si serial esta disponible...
      EstadoEntrada = Serial.read();
       if(EstadoEntrada ==  0){ //Si lo que llega desde el serial es un 0
           if(valor<256){       // Si valor es menor que 256
               analogWrite(PinUno,valor);
               valor++;  
               }
         analogWrite(PinDos,0);
         analogWrite(PinTres,0);  
         analogWrite(PinCuatro,0);
        
         }
        
      if(EstadoEntrada == 1){
          if (valor < 256){
             valor++;
               analogWrite(PinDos,valor);
               }
         analogWrite(PinUno,0);
         analogWrite(PinTres,0);  
         analogWrite(PinCuatro,0);
         valor = 0;
         }
        
         if(EstadoEntrada == 2){
           if(valor < 256){
             valor++;
               analogWrite(PinTres,valor);
               }
         analogWrite(PinUno,0);
         analogWrite(PinDos,0);  
         analogWrite(PinCuatro,0);
         valor = 0;
         }
        
         if(EstadoEntrada == 3){
           if(valor < 256){
             valor++;
               analogWrite(PinCuatro,valor);
               }
         analogWrite(PinUno,0);
         analogWrite(PinDos,0);  
         analogWrite(PinCuatro,0);
         valor = 0;
         }
    }


Desde Puredata le mando al objeto comport 1, 2 o 3 por diferentes mensajes:

[1]     [2]     [3]

[comport 3 9600]


¿Que puede ser?, ¿Son las conexiones internas de la arduino?
Porque estoy tambien ocurre con el Arduino-test.pd de Hans-Christoph Steiner

Gracias y Saludos a todos!!
7  Forum 2005-2010 (read only) / Español / Re: Arduino diecimila on: October 24, 2007, 03:11:26 pm
Ok David gracias por tu respuesta, en estos dias la cuelgo.....
8  Forum 2005-2010 (read only) / Español / Arduino diecimila on: October 17, 2007, 09:51:40 am
Hola amigos:

Hace poco tiempo adquirí una arduino diecimila cuando la conecto a puredata 0.39 con el pduino 0.3.1 y arduino 0009 la placa parece que responde a la carga desde arduino 009 alpha y cuando la conecto a pd la placa parece que recibe porq TX  RX parpadean como si recibiera el led pero el led 13 (que lo conecto sin resistencia) no hace nada.
cuando reseteo si se enciende y cuando abro la aplicacion arduino 0009 alpha tambien.

¿Aqué se puede deber?...

Saludos!! smiley-wink
9  Forum 2005-2010 (read only) / Español / Nueva Arduino NG on: August 11, 2007, 07:28:27 am
Hola a todos, hace tiempo adquirí una arduino  NG y todo me fué genial, hasta que el otro día experimentando hice saltar los fusibles  mientras la tenía conectada al pc y ahora no me sube nada a la placa, y el chip atmega168 se calienta muchisimo (esto es lo que pasa cuando estudias bellas artes y no ingeniería informática... smiley-razz)
¿¿¿Sabeis si puedo adquirir otra placa en España???, ya que esta la pedí a Italia...

Saludos a todos!!
10  Forum 2005-2010 (read only) / Español / Re: Electrónica-Arduino on: March 27, 2007, 03:56:50 pm
Muchas gracias Pavlete con tu explicación y lo que habia colgado David en uno de los post anteriores haber si lo consigo....
11  Forum 2005-2010 (read only) / Español / Electrónica-Arduino on: March 26, 2007, 08:07:22 pm
Hola a todos:

Necesito activar una bombilla desde arduino ¿alguien sabe los materiales que me hacen falta
tipo de relé, transistor, etc.....??

Vi el post en el que David hablaba de ello y más o menos me hago una idea, pero, ¿que tipo de relé debo comprar y transistor?haría falta algo más???
¿valen todos los tipos de relés?

¿Podría con este esquema que se comenta en el foro activar mas cosas que van conectadas a 220v?

Gracias y saludos.
12  Forum 2005-2010 (read only) / Español / Re: Arduino y Puredata on: March 21, 2007, 07:19:14 pm
Hola David.

Me ha dado mucha alegria leer tu post.

Si, podria conseguir a esas 14 personas....incluso podría comentarlo a los compañeros que seguro les gustaria hechar una mano para organizar y montar algo por aquí....Buscar un espacio, etc....





Un abrazo.

13  Forum 2005-2010 (read only) / Español / Re: Arduino y Puredata on: March 13, 2007, 09:49:10 am
En realidad ahora no vivo en ningún sitio David. Acabo de terminar mi carrera en Bilbao y he vuelto unos meses a Cádiz ha arreglar unas cosillas que tenía pendientes.
Un lugar paradisiaco Cádiz, pero poco propenso a realizar talleres relacionados con una temática tan interesante como esta. Así que no me queda más que esperar y buscar un hueco para poder volver a subir y asistir en Barcelona, Madrid, y ahora por lo que he leido últimamente, Zaragoza, (sin quitarle importancia a Cuenca, Valencia o Bilbao) que parece que son los lugares más propensos a realizar este tipo de actos tan interesantes y necesarios.

Aunque si alguna vez bajas por el sur a realizar algún taller (Sevilla no estaría mal) postealo en el foro que nos dará mucha alegría que se vayan haciendo estas cosas por aquí más asiduamente como por allí, que falta nos hace....

Un saludo y un abrazo!!
14  Forum 2005-2010 (read only) / Español / Re: Arduino y Puredata on: March 12, 2007, 08:00:39 am
Hola David.

Nada, soy un desastre. :-[

-Descarge la versión de PureData 0.38-4 extended

-Bajé el Java 2 Platform, Standard Edition, v 1.4.2 (J2SE), lo instalé.

-Descargué la version 0007 de Arduino.

-Descargué el Pduino-0.3 (la última versión)

-Abrí 0007 Arduino y carge el Pdfimware de Pduino-0.3, una vez habia puesto el puerto y el chip correspondiente (Atmega 168) antes.

-Abrí Puredata 0.38-4

-abrí el Arduino-test que viene en la carpeta de Pduino-0.3 y nada, y ahora para colmo el mensaje [open 1] ahora me aparece como [0 0], aunque coloque OPEN 4 (4 = puerto 5) para abrir mi puerto la placa no responde, cosa que si hace con la version 5.Pduino, aunque esta versión ahora también se me carga con el mensaje OPEN como 0 0, cosa que antes no hacía. Antes aunque con errores continuos si podia utilizarla ahora ni eso.....
Me da siempre este error:

arduino.pd 16 1 11 0 (comport->canvas) connection failed
[arduino]: version_0.3
error: $1: argument number out of range
error: $2: argument number out of range
WriteFile failed, but isn't delayed on serialdevice
Write error, maybe TX-OVERRUNS on serial line

Ya no tengo ni idea de que hacer, asi que tendré que esperar algún taller que se organice y pueda asistir...

Saludos David!
15  Forum 2005-2010 (read only) / Español / Re: Arduino y Puredata on: March 09, 2007, 09:12:54 am
Hola David.

He seguido tus instrucciones, me baje de la web la version que me dijiste y la he instalado en el equipo, también me baje la version Pduino-0.3 (antes tenía Pduino y Pduino-0.2) he cargado el Pd_firmware en la interfaz 005 de arduino, he abierto Puredata y he intentado cargar Arduino-test pero me sigue dando el error, ahora no me conecta nada, y el mensaje OPEN ahora me sale como 0.0  le pongo OPEN 4 para que me carge el puerto 5 pero nada...error, creo que voy a desistir de trabajar con Arduino y puredata :'( hasta que tenga tiempo de asistir a algún workshop en el que participes una vez finalice marzo. Estaré atento al foro por si posteas las fechas.

Un abrazo David y muchas gracias por tu atención.
Pages: [1] 2