Show Posts
Pages: [1]
1  Forum 2005-2010 (read only) / Development / Re: add new function to wiring_digital.c on: January 22, 2011, 03:22:36 pm
thank you
2  Forum 2005-2010 (read only) / Development / Re: add new function to wiring_digital.c on: January 22, 2011, 03:08:10 pm
i want to do it like this

Code:
     
out = portOutputRegister(port);
if (val == LOW) *out &= ~bit;
      else *out |= bit;
that is why i need to add new function
3  Forum 2005-2010 (read only) / Development / Re: add new function to wiring_digital.c on: January 22, 2011, 03:04:01 pm
Yes but i found nothing
How i can do it? there is special function?
4  Forum 2005-2010 (read only) / Development / Re: add new function to wiring_digital.c on: January 22, 2011, 02:50:59 pm
i only need add new function to \arduino-0017\hardware\cores\arduinowiring_digital.c
5  Forum 2005-2010 (read only) / Development / Re: add new function to wiring_digital.c on: January 22, 2011, 02:48:02 pm
No. i want create new to switch on or off massive of pins
i cant use like this
Code:
for(int i=0;i<10;i++)
{
digitalWrite(i,HIGH);
}
because it spend a lot of time
6  Forum 2005-2010 (read only) / Development / Re: add new function to wiring_digital.c on: January 22, 2011, 02:22:01 pm
there is one reason
standart digitalwrite spends a lot of time to switch on or switch of massive of pins
i think i can do it, if i modify standart digitalWrite
7  Forum 2005-2010 (read only) / Development / add new function to wiring_digital.c on: January 22, 2011, 01:08:04 pm
Hello!
I am trying to add new function "MydigitalWrite" to wiring_digital.c () (\arduino-0017\hardware\cores\arduino)

When I try to compile:
In function 'void loop()':
error: 'MydigitalWrite' was not declared in this scope

How to win this problem?



8  Forum 2005-2010 (read only) / Troubleshooting / Re: Can't upload sketch! on: March 05, 2010, 03:33:58 pm
I have similar problem: I cant upload to ArduinoBT my sketch  
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51
What wrong? Please help me
9  Forum 2005-2010 (read only) / Troubleshooting / Problem with installing FTDI driver on: March 01, 2010, 04:00:02 am
I have a serious problem with the Arduino, I can't install FTDI driver on Windows Embedded CE 6.0 R3!  :'( Installation just fails on CE :'(
Please, help!  
Pages: [1]