Show Posts
Pages: 1 ... 33 34 [35] 36 37 ... 66
511  Using Arduino / Programming Questions / Re: Baud rates and resistors. on: August 11, 2012, 05:19:54 am
Open Drain - I tend to use 2K, 8.7K(Because I have about 10,000 on 2 reels) or 10K - I start with the 8.7 and change if unstable.
512  Using Arduino / Programming Questions / Re: Baud rates and resistors. on: August 11, 2012, 04:44:54 am
Ive used 9600 to 115200 with no pullups!
513  Using Arduino / Installation & Troubleshooting / Re: Arduino is not responding at uploads on: August 08, 2012, 10:24:01 am
Hi Michael, Welcome to the wonderfull world of Arduino. There are a few things to check :

Is the power led on?
Have you performed the loopback test? If not, I recommend you do.
If it is, can you check for the com ports by unplugging the arduino, then plugging it back in, taking note of what port (if any) appears.
When you press upload, wait for the Binäre Sketchgröße: to show, quickly tap reset. (it may help)
Do you see any other LEDs flash or flicker when you try to upload?

Failing this, you MAY have to arrange for a replacment. (but with a few checks we may be able to narrow down the fault)
514  Using Arduino / Microcontrollers / Re: Bootloader for Tiny chips? on: July 30, 2012, 08:56:07 am
The attinys don't tend to have/suppot UART so I think it may not be possible.
515  Using Arduino / Installation & Troubleshooting / Re: Second time loading sketch sync error on: July 26, 2012, 05:32:03 pm
Check the fuses - The settings are in the boards.txt file. Mainly the Lock bit (0f locked - 3f ULOCKED)
516  Using Arduino / Installation & Troubleshooting / Re: not in sync: resp=0x33 on: July 26, 2012, 01:40:48 pm
Hi - just a few things :
Jumper Rx to Tx and try the loopback test
Try a different USB lead.
Connect direct to the PC (If you use a hub, it will not always work.)
Uninstall the driver / Reinstall it again,
517  Community / Products and Services / Re: My Mini Ardiuno as ISP Shield & its big brother on: July 18, 2012, 06:31:46 pm
I'm putting up 2 of these to swap. Leave an offer here or PM me, I'm not after anything specific, does not even have to be arduino related, But preferred.

I've Built & Tested the shields with :

atmega 328
atmega 168
atmega 8
(All set to internal clock & Oscillator)
tiny 13,45,85 all on internal Osc.

I'll post to world wide (With a few restrictions).
518  Community / Products and Services / Re: My Mini Ardiuno as ISP Shield & its big brother on: July 18, 2012, 10:27:18 am
I agree, But I tend to hold the chip in place, rather than insert the chip fully, so wear is minimal. Also ZIF sockets are quite expensive compared to the standard DIP sockets.
519  Community / Products and Services / My Mini Ardiuno as ISP Shield & its big brother on: July 17, 2012, 06:34:02 pm
Hi - After browsing through this forum, and others, I came to the conclusion that LOTS of people have issues uploading the bootloader / programs to there blank atmega/attiny chips. So I have made the following 2 boards :

Arduino as ISP Mini board, Fits onto the ICSP header (With a lead going to pin 10 for reset).
and
Arduino as ISP Shield, Complete with the Heartbeat, Error and Working LEDs.

Just upload the ArduinoISP sketch, fit the Mini or Shield, then disable the reset on you Arduino (The shield has a jumper to do this)
pop you chip onto the relevant socket, Choose the correct chip from the tools menu, Select Arduino as ISP in the tools menu.
Then upload the bootloader or (if using the up to date IDE) upload the program with programmer.

See the attached images.

They are for sale if any-one wants one (or both).
520  Using Arduino / Microcontrollers / Re: ATtiny85 - 6 output/input pins? on: July 12, 2012, 09:22:27 am
Hi - Yes & No - You can use PIN1 as either RESET or I/O but not both, this is set with the fuses. Once the pin is set as I/O it can only be reset using HVP (High Voltage Programming) Hope this help clear things up.
521  Using Arduino / Microcontrollers / Re: Help! Where can I buy ATmega328p? on: July 11, 2012, 04:59:32 pm
Hi - I program QFP-32s here, never thought there would be a demand for bootloaded QFP 328's. I think i've got 2 left (I'll check the workshop tomorrow) and a few 8s as well, I'm going to order a few more tomorrow. Any-one who needs them, or wants me to bootload them just PM me.
522  Using Arduino / Microcontrollers / Re: Arduino Tiny on: June 13, 2012, 12:30:55 pm
((reading / 1024) * 5);

reading is 0 ->1024
therefor reading/1024 will be 1 or less (Probably rounded to 1) * 5 = 5,
what value range are you trying to get?
523  Using Arduino / Microcontrollers / Re: bootloading a ATMEGA 2560 on: June 13, 2012, 09:52:21 am
Found the picture - there is no pull up on reset - this may be the issue? - the rest looks OK
524  Using Arduino / Microcontrollers / Re: bootloading a ATMEGA 2560 on: June 13, 2012, 09:49:50 am
No Picture smiley-sad -

Confirm the following conections :

ISP HEADER      2560

1   MISO   (D12)        PIN22
2   5V              PIN11,31,61,90 & 100
3   SCK(D13)           PIN20
4   MOSI   (D11)        PIN21
5   RESET(D10)   30(WITH 10K PULLUP TO 5V)
6   GND              PIN11,32,62,91 & 99

I don't have a 2560 at hand, so cant set up a test circuit just now. But I just tested programming a 328 with my arduino,
using a wire jumper from reset to 5V (Only while programming) - maybe try that if the wiring looks good.
525  Using Arduino / Microcontrollers / Re: bootloading a ATMEGA 2560 on: June 13, 2012, 09:12:41 am
Can you post the diagram of your board, and how you have connected up the arduino (including model & how you disabled the autoreset)

If you dont have a diagram, a discription of what you have connected to each pin e.g. crystal -> pin #

Most of the time in these situations, its down to a small error in wiring, or a bad connection.

With this info (and any other you can think of) we should be able to get you up and running
Pages: 1 ... 33 34 [35] 36 37 ... 66