Show Posts
Pages: 1 2 [3] 4 5 ... 7
31  International / Deutsch / Re: Sharp Sensor Probleme mit Transistor an Platine on: January 29, 2013, 05:49:32 am
Hallo sth77, hast du Lötfett oder etwas ähnliches benutzt?
Die Kathode der IR-Led lässt sich sehr schwer verlöten ist mir aufgefallen.
Gruß
32  International / Deutsch / Re: Sharp Sensor Probleme mit Transistor an Platine on: December 22, 2012, 02:59:01 pm
Hallo Uwe,
es stimmt ich habe für die Ir Led kein Vorwiderstand, diese ist allerdings nicht der Übeltäter hab die Platine mit einem 10 Ohm verlötet und die Schaltung hat leider trotzdem nicht funktioniert.

Der Arduino wird über Usb Spannung versorgt.
Die Power Led bleibt an.

Gruß
33  International / Deutsch / Re: Aus Zeitmangel: Arduino und reichhaltiges Elektroniksortiment abzugeben on: December 22, 2012, 06:55:42 am
Hallo,
hätte Interesse an der kompletten Box Widerstände, Elkos ,dem
selbstgebautes Belichtungsgerät und der Ätzanlage kannst mir ein Angebot machen? Einzeln und komplett.
Gruß
34  International / Deutsch / Re: Sharp Sensor Probleme mit Transistor an Platine on: December 22, 2012, 05:57:38 am
Hallo Uwe,

ja ich habe verschiedene IR- LEDs benutzt jeweils auf Steckbrett und Platine den IR 271 und den 274 beides funktionierte auf dem Steckbrett sehr gut auf der Platine jedoch nicht.

Da ich ich alle Teile mehrfach gekauft habe, habe ich die Schaltung komplett auf dem Steckbrett nachgebaut mit den selben Teilen, die auf der Platine sind.
Dabei habe ich auch versucht zu gucken, ob nicht der Tansistor kaputt ist und 3 verschiede benutzt einmal den 2n3096 den BC327-25 und den    BC327-40 alle zeigten die gleichen Symptome auf dem Steckbrett funktioniert die Schaltung sehr gut und der Sensor schaltet auch nach 30 minuten wunderbar auf low und wieder zurück auf high ohne das der Transistor heiß wird.

Habe es auch mit einem anderem Potentiometer probiert, was allerdings auch nicht zu einem erfolg geführt hat.

Auf der Platine heizt sich der Transistor innerhalb weniger Sekunden auf eine bedenkliche Temperatur hoch und auch die Schaltung funktioniert dann nicht mehr.

Darf ich dir was vorschlagen?
Ich würde dir gerne meine verlötete Platine zusenden und das Steckbrett mit der funktionierenden Schaltung. Zudem würde ich dir eine leere Platine mit allen benötigten Teilen senden, damit du die Schaltung auch einmal nachlöten kannst, um auzuschließen das ich vielleicht schlecht gelötet habe und dadurch kalte Lötstellen oder ähnliches aufgetreten sind. Zusätzlich könnte ich dir noch die kompletten Teile für die Schaltung als reserve senden, falls ein Teil kaputt sein sollte.

Würdest du das machen? Ich bin mittlerweile echt verzweifelt wie viel Geld ich schon in den Sand gesetzt habe und will ungern noch 10 weitere Platinen in den Müll schmeißen auch weil ich überhaupt keine Ahnung habe woran es liegt.

Gruß David
35  International / Deutsch / Re: Sharp Sensor Probleme mit Transistor an Platine on: December 20, 2012, 05:33:28 pm
Leider habe ich das Problem immer noch nicht finden können zudem habe ich im Internet jemanden gefunden mit dem exakt selben Problem!

Woran könnte es liegen das die Schaltung auf einem Steckbrett funktioniert und auf einer Platine nicht? Hat jemand noch eine gute idee?

Mittlerweile habe ich schon ca 20. Platinen die den selben Fehler aufweisen immer wird der Transistor warm. Auch wenn ich einen anderen Transistor benutze wird er warm und wie immer nur auf der Platine  auf dem Steckbrett funktioniert alles einwandfrei.

Hier mal der Link von einem mitleidenden:
http://www.roboternetz.de/community/threads/19741-IS471F-funktioniert-auf-Steckbrett-aber-nicht-auf-Platine
36  International / Deutsch / Re: Sharp Sensor Probleme mit Transistor an Platine on: December 05, 2012, 04:59:53 pm
Hab jetzt noch eine Schaltung gefunden:

http://www.roboternetz.de/sensoren.html

Macht das ein Unterschied ob ich IR-LED an Collector oder Emitter anschließe?

Gruß
37  International / Deutsch / Re: Sharp Sensor Probleme mit Transistor an Platine on: December 04, 2012, 03:01:03 am
Hallo die Widerstände von den ich sprach (330 ohm und 20 ohm) sind zwischen Pin 4 des Sharps und der Base vom Transistor. In der Schaltung von kreatives chaos sind Widerstände in Reihe bis insgesamt 6000 Ohm. Ich erreiche bei 3000 Ohm nur eine Reichweite von ca 1 cm.
38  International / Deutsch / Re: Sharp Sensor Probleme mit Transistor an Platine on: December 03, 2012, 07:13:37 pm
Hallo,
ich habe jetzt mal alles durchgemessen:
Auf dem Breadbord hab ich die Spannung und den Stromfluss gemessen:

V(Emitter-Collector) = 3,96V
V(Emitter-Base) = 0,32V
V(Base-Collector) = 3,23V

Strom an Base 0,6 mA und am Collector 13,3mA

Bei und jetzt kommts 330 Ohm das sind doch ziemlich wenig Strom an der Base??
Und weil das wirklich fast nichts ist habe ich den WIderstand auf 20 Ohm reduziert und nochmal nachgemessen:

V(Emitter-Collector) = 3,92V
V(Emitter-Base) = 0,3V
V(Base-Collector) = 3,15V

Strom an Base 3,15 mA und am Collector 19,2 mA

Wozu dann noch der Transistor wenn ich nur 19,2 mA bekomme?

Habe den 2n3096 dann nochmal standalone ausprobiert bei 330 Ohm erhalte ich an der Base 10,9mA und am Collector mehr als 200mA!!! Also schon am Limit da liegen Welten zwischen 19,2 mA und >200mA.

Ich nehme mal aufgrund der geringen Stromstärke am Breadbord ist der Transistor nicht warm geworden?
Was sagt ihr zu meinen Messergebnissen und Vermutungen?
39  International / Deutsch / Re: Sharp Sensor Probleme mit Transistor an Platine on: December 02, 2012, 05:30:29 pm
Hallo Uwe ,
war ein Fehler von mir hab mich verschrieben das weiße Kabel ist natürlich mit der Kathode der IR LED verbunden und nicht mit der Anode.
 Ein Bild der Platine habe ich beigefügt.

Viele Grüße
David
40  International / Deutsch / Re: Sharp Sensor Probleme mit Transistor an Platine on: December 02, 2012, 04:44:14 pm
Hallo Uwe tut mir leid ich bin/war ein bisschen in rage weil ich Angst habe meine Platinen in den Müll schmeißen zu müssen.

Wie auch immer ich hab die Widerstandsmessung durchgeführt und sie als Bild angehängt ich hoffe das hilft mir/dir/uns weiter.

Bild 1. Messung des Potentiometers am Breadbord ergab 1639 Ohm
Bild 2. Messung des Potentiometers + Widerstand in Reihe ergab 2,63 kOhm

Bild 3. Messung des Potentiometers an der Platine ergab 1623 Ohm
Bild 4. Messung des Potentiometers + Widerstand in Reihe ergab 2,6 kOhm

Was genau meinst du mit Stellung? Ich versteh den Satz nicht genau:
"...daß die Verlustleistung das Transistors von der Stellung des Potentiometers abhängt "
41  International / Deutsch / Re: Sharp Sensor Probleme mit Transistor an Platine on: December 02, 2012, 01:10:24 pm
Bei den anderen verlöteten Platinen ist genau das selbe Problem -> Transistor wird heiß . Es muss also irgendwas auf der Platine nicht stimmen.
42  International / Deutsch / Re: Sharp Sensor Probleme mit Transistor an Platine on: December 02, 2012, 10:35:22 am
Ich habe den 560 Ohm Widerstand jetzt gegen ein 1000Ohm Widerstand am Breadbord und den Potentiometer wie auf der Platine auf 1600 Ohm gestellt. Zusätzlich habe ich den Elko gegen den selben getauscht den ich auch auf dem Platine verbaut habe getauscht (war ein anderes Fabrikat). Jetzt sind genau die gleichen Bauteile auf der Platine wie auf dem Breadbord.

Funktionstest am Breadbord ca 20 Minuten alles funktioniert einwandfrei der Transistor und alle anderen Bauteile werden auch nicht im Ansatz warm.

Das gleiche auf der Platine: Schaltung funktioniert allerdings geringere Reichweite und der Transistor wird sehr sehr heiß.

Kann ich überprüfen das vielleicht irgend wo ein Kurzschluss ist? Könnten ja entstehen durch winzige Zinnspritzer?!
Ich Habe mit einem Multimeter ein Stecker auf Plus und ein auf Minus gesteckt und es hat nichts gepiept das müsst doch heißen das alles ok ist oder?



Wie kann das sein, dass der 5 Ohm Widerstand in Reihe bei der Platine gebraucht wird und beim Breadbord nicht gebraucht wird?(dort wird er ja gar nicht warm und funktioniert gut ohne den 5 Ohm Widerstand)

Braucht ihr vielleicht noch ein paar Bilder zu der Platine ich könnte den Aufbau vielleicht auch zeichnen , weil es ein bisschen schwer ist sich reinzuversetzen in diese 2 seitigen Bilder (sollte eigentlich nur zeigen wie ich die Teile verbaut habe).

43  International / Deutsch / Re: Sharp Sensor Probleme mit Transistor an Platine on: December 02, 2012, 06:33:36 am
Was mir noch aufgefallen ist und das verwundert mich absolut:

http://www.ram-projects.de/robotik/is471f-ir-taster/
Hier wird die IR LED am Emitter angeschlossen es handelt sich bei dem BC 327-25 auch um einen PNP Transistor und die Pin Belegung ist auch gleich siehe:
http://www.produktinfo.conrad.com/datenblaetter/150000-174999/155747-da-01-en-TRANSISTOR_BC327_25_TO92.pdf

http://www.kreatives-chaos.com/images/102.png
Hier wird die IR LED am Collector angeschlossen

ABER WARUM?? Es muss doch eins Falsch sein oder versteh ich was falsch??
44  International / Deutsch / Re: Sharp Sensor Probleme mit Transistor an Platine on: December 02, 2012, 06:13:29 am
Doofe Frage, wie kann ich den verstärkenden Strom messen?
45  International / Deutsch / Re: Sharp Sensor Probleme mit Transistor an Platine on: December 02, 2012, 05:57:19 am
Es ist die Schaltung regelbar ohne die Led an Vout. Sobald ein Hindernis erkannt wird und auf "Low" schaltet gebe ich ein Befehl zu meinem Led Treiber dem Tlc5940 der die im unteren Bereich befindliche Smd Rgb LED der Platine anschaltet.

Auch sind die Anschlüsse des Transistor gleich.
Mit dem Handy hab ich auch geschaut die IR LED leuchtet nur der Transistor im Platinen Betrieb heiß und im Breadbord bereich nicht obwohl alles gleich ist.

Nochmal zum Bild (Breadbord):
Kabel gelb ganz links geht an +5v und ist an Pin 1 (Vcc) des Sensors angeschlossen
Kabel orange 1 hinter gelb igeht an ein Schieberegister der auswertet und ist mit Pin 2 (Vo) des Sensors verbunden
Kabel weiß ist am Sharp Pin 3 Gnd und mit der Anode der IR LED verbunden
Kabel orange 2 ist hinten und ist am Sensor Pin 1 und mit dem Emitter des Transistors verbunden
Pages: 1 2 [3] 4 5 ... 7