Show Posts
Pages: [1] 2 3 ... 19
1  Forum 2005-2010 (read only) / Forum / Re: Aggregate subforums? on: August 15, 2010, 11:35:09 am
Well, here's another idiot. I can see an "RSS" button at the bottom of the page when viewing a forum, but is seems to only "validate".
2  Forum 2005-2010 (read only) / Forum / Aggregate subforums? on: August 13, 2010, 05:57:27 am
Of all the subforums here there are, say, 4 that I regularly read.
I click them one by one and see if any interesting posts have appeared.

I would like to see a feature where, under a user's configuration,  there was a checkbox for each subforum. All the posts in the selected subforums would then appear under a new virtual subforum "My Aggregation"   :smiley
3  Forum 2005-2010 (read only) / Troubleshooting / Re: Multiple switch state coding help on: August 05, 2010, 01:28:45 am
Are there any timing considerations?  if output pins are set using digitalWrite() we can't change all 7 of them at once to react to input.
Will there be a problem if the outputs are wrong for, say, 10 microseconds while we are changing outputs?
4  Forum 2005-2010 (read only) / Troubleshooting / Re: Multiple switch state coding help on: August 04, 2010, 02:04:24 am
When more than two switches are high,  and you want to set the B-relays, does it matter which two B-relays go high?  (i.e. must they correspond to the first two switches to go high or could it be any two if their number corresponds to "high" switches?)
5  Forum 2005-2010 (read only) / Troubleshooting / Re: Multiple switch state coding help on: July 04, 2010, 04:27:46 pm
Well, digitalRead() gives 1 if pressed and zero otherwise, so simply read all the switches and add up the results.
Then light up LED 1 if that sum is >=1, LED 2 if the sum is >=2 etc.
If turning that into code is too difficult, begin with something simpler like light up a led whenever a particular switch goes high and move on from there.

(I'm not posting any actual code because this looks suspiciously like an assignment you ought to be solving yourself...  if that is not the case - what have you been trying and what were the problems?)
6  Forum 2005-2010 (read only) / Troubleshooting / Re: How do I impliment Differential Drive on: September 15, 2010, 03:54:36 pm
It is easier to find the problem if you post your code. Mark it with the # button.
7  Forum 2005-2010 (read only) / Troubleshooting / Re: How to make led matrix animation? on: September 08, 2010, 05:42:13 am
Start by hooking up the matrix to the Arduino and get it to display a static image.
8  Forum 2005-2010 (read only) / Troubleshooting / Re: Latch Pin on: September 07, 2010, 03:30:53 pm
A latch pin lets you lock the current outputs of some circuit so it doesn't change while you are sending new data to it.
Then, when the latch is flipped again, the new data will be applied all at once.
9  Forum 2005-2010 (read only) / Troubleshooting / Re: Text Scrolls to Fast on: September 07, 2010, 01:37:31 pm
At the beginning or end of loop()
10  Forum 2005-2010 (read only) / Troubleshooting / Re: Text Scrolls to Fast on: September 07, 2010, 02:37:15 am
Quote
I do not want to pause it I want to slow down the speed.

So use a short delay. They are expressed in milliseconds (and even microseconds if that suits you better).
11  Forum 2005-2010 (read only) / Troubleshooting / Re: Text Scrolls to Fast on: September 07, 2010, 12:49:46 am
http://arduino.cc/en/Reference/Delay
12  Forum 2005-2010 (read only) / Troubleshooting / Re: enlarge range of potentiometer on: September 07, 2010, 05:44:15 am
Quick & dirty:

Code:
xpos = serialInArray[0][glow] * 8[/glow];
?
13  Forum 2005-2010 (read only) / Troubleshooting / Re: Shift register update code malfunction on: September 06, 2010, 02:51:53 am
Code:
currBuffer |= (1[glow]L[/glow]<<isr_loopCount+(isr_ledNumber*3));

The value you "or" with is probably clipped to int size = 16 bits before being applied to currBuffer. Try adding an L.
14  Forum 2005-2010 (read only) / Troubleshooting / Re: error: expected unqualified-id before 'volatile' on: September 03, 2010, 08:34:00 am
and as deSilva already said: on which line do you get the compile error?
15  Forum 2005-2010 (read only) / Troubleshooting / Re: error: expected unqualified-id before 'volatile' on: September 03, 2010, 01:46:24 am
There may be a semicolon missing at the end of the line before the reported error.
Pages: [1] 2 3 ... 19