Show Posts
Pages: 1 [2] 3 4 ... 48
16  International / Hardware / Re: Dubbi xbee - tcp/ip on: April 10, 2013, 06:46:22 am
Gli XBee della 2a Serie possono fare una rete MESH (dove ognuno ripete il segnale trasmesso e in questo modo possono comunicare dei XBee tra di loro che dato la loro distanza non sarebbero coperti dal loro raggio d' azione).

Secondo me un XBee é molto meno impegnativo dal punto di vista della programmazione e peso di calcolo  rispetto a una rete WLAN perché gli XBee estendono la seriale di Arduino via radio tra di loro. Una rete WLAN ha bisogno di punti di accesso dedicati (schede WLAN) e un estensione di portata devi realizzarlo via Router (ripetitori o collegati via cavo rete.

Ciao Uwe

Infatti premevo molto sulla rete MESH che ti leva da parecchi casini, ma una piccolare te tcp/ip probabilmente ti costa meno... erro?
17  International / Hardware / Re: Amplificare segnale <1v on: April 10, 2013, 06:45:28 am
Oggi ho portato l'anemometro in un lab all'università

Ma soprattutto, per essere passati 45 giorni dall'ultimo messaggio.... quanto è lontano questo laboratorio?  smiley-mr-green

Perchè non sapevo dell'esistenza di un laboratorio con attrezzature da laboratorio vecchio stile... troppi pc et simili oggigiorno smiley

ci rinuncio, forse è passato più di un anno da quando l'imploravo di non comprare più cag.... e spendere qualche euro per attrezzarsi nella decenza, ma sto guaglione tien'a capa tosta smiley-twist

Il discorso è un pò più ampio... un oscilloscopio è un oscilloscopio! ma senza un background di elettronica che me ne faccio? smiley
18  International / Hardware / Re: Amplificare segnale <1v on: April 09, 2013, 02:37:34 pm
Oggi ho portato l'anemometro in un lab all'università e lo abbiamo attaccato ad un oscilloscopio... funziona funziona!
Era il mio multimetro che non leggeva bene...

E' proprio vero: sono i giusti utensili che ti fanno capomastro!
19  International / Hardware / Dubbi xbee - tcp/ip on: April 09, 2013, 02:31:29 pm
Salve

In questi giorni si parlava di comunicazione wired/wireless in locale e di datalogging.
Dovendo fare del datalogging in locale, ma con piccole stazioni (arduino/raspberry) un pò sconnesse tra loro, cosa usereste?
Alcuni mi hanno consigliato xbee per: l'algoritmo del loro routing, per la portata del wireless e per i tempi di routing quasi istantanei.
Altri mi consigliano di usare switch/router per abbattere un pò i costi... nel mio caso d'uso già troverei uno switch.

Che... mi consigliate?
20  International / Hardware / Re: Batteria + ricarica dc on: March 19, 2013, 03:08:10 pm
hai controllato a che tensione esce la schedina con LM2596 ?

non e' che e' regolata ( ci dovrebbe essere un trimmer ) per una tensione piu' bassa ?

è regolata a puntino, garantito. ;(
21  International / Hardware / Re: Batteria + ricarica dc on: March 19, 2013, 02:41:05 pm
Il TP4056 e' studiato per gestire direttamente la batteria ( 3,7V litio ), non puoi collegare l'uscita del TP4056 sull'ingresso di un cellulare o un TomTom... loro hanno gia' un regolatore a bordo e gli servono almeno 5 V.

grazie per la risposta.

ho provato anche a collegare il tutto senza tp4056, direttamente dall'lm2596.... ma non carica. Si accende ma non carica la batteria (con il 7805 caricava!) . Idee?

saluti smiley
22  International / Hardware / Re: Batteria + ricarica dc on: March 19, 2013, 10:30:12 am
ci sono dei chip. tipo il TP4056, adatti a questo scopo

Si trovano anche delle schedine gia' fatte a prezzi irrisori

ho appena acquistato proprio una di queste schedine... ma non riesco a farla funzionare correttamente.

la mia configurazione è: batteria auto -> un drop down lm2596 settato a 5v in uscita -> schedina tp4056

appena do alimentazione, il led verde della schedina rimane sempre verde e ogni secondo (circa) blinka il rosso.
se vi collego un cellulare o un tomtom non carica nulla.... idee?
23  International / Generale / Re: Misuratore di campo DVB on: March 13, 2013, 10:22:15 am
Grazie AnTrea,
quei programmi li conosco e li uso ma non misurano il guadagno o la potenza del segnale. Indicano l'intensità del segnale su una scala da 1 a 100.


scusa! mia ignoranza! ;(
24  International / Generale / Re: Misuratore di campo DVB on: March 13, 2013, 07:45:25 am
fai prima ad acquistare un decoder usb, lo colleghi al pc, ed usi un pò di progrmamini gratuiti che misurano il guadagno.

un esempio:
25  International / Megatopic / Re: Nuovo IDE 1.0.4 on: March 12, 2013, 04:56:20 pm
Ma il tuo è un USBasp o un "clone"?
Hai messo l'ultimo firmware? Solo questo supporta la programmazione su micro con più di 128 kB.

ultimo firmware ma usbasp clone... devo debuggare l'hw? smiley
26  International / Megatopic / Re: Nuovo IDE 1.0.4 on: March 12, 2013, 04:36:03 pm
in pratica:
1. hai disattivato l'autoreset sul'arduino ISP?
2.
Quote
0x1e000 is exactly 120KB... so, I suppose that the problem should be related to the STK500 V2 protocol and the larger memory size.

Ci stiamo avvicinando.
Cosa intendi per autoreset sull'arduino isp?
Sto usando usbasp (http://www.fischl.de/usbasp/) e ho notato che la mia versione, non ha il reset dell'atmega8a collegato a +5v. Mentre lo schema elettrico ufficiale si.
Può essere questo il problema? smiley

qui dicono addirittura di ignorare tale problema: http://www.cbxdragbike.com/arduino/bootloaderdocs/index.html
27  International / Megatopic / Re: Nuovo IDE 1.0.4 on: March 12, 2013, 02:59:59 pm
Non hai una UNO/2009 per ritentare l'operazione usandola al posto del tuo accrocchio?

com'è bello parlare tra nerd.

si prof, ho appena eseguito il flashing icsp tramite bitbang da duemilanove a 2560: stesso errore smiley-sad

così ne ho approfittato anche per aggiornare la usbasp (tramite bitbang)

ho eseguito nuovamente l'aggiornamento del bootloader della 2560 con la usbasp appena aggiornata: non mi da errore smiley

NOTA: con questo bootloader, dopo il flashing, il led 13 blinka un pò strano (2 blink veloci - off lungo)... con e senza errore (di cui sopra), c'è sempre questo blinking strano; ERGO, seppur nel terminale mi compare quell'errore, il bootloader viene flashato ugualmente (credo).

C'è un modo per verificare che bootloader vi è flashato?

Sono bravo? smiley
28  International / Megatopic / Re: Nuovo IDE 1.0.4 on: March 12, 2013, 11:48:46 am
Secondo me non hai aggiornato un bel nulla. apri il file boards.txt e sostituisci nella board che hai usato il valore efuse (attuale ff) con "0d", quindi riprova a fare l'upload, che ovviamente stai facendo mediante collegamento ISP, spero....

Prof, ho scritto che ho usato la usbasp, quindi.... smiley
Ora provo a fare l'upload modificando il fuse. Grazie


Quant'è brutto quando non trovo le cose al posto loro:

l'estended fuse è settato a 0xFD, siamo sicuri che settandolo a 0d risolvo la questione?  smiley-lol

Code:
mega2560.name=Arduino Mega 2560 or Mega ADK

mega2560.upload.protocol=wiring
mega2560.upload.maximum_size=258048
mega2560.upload.speed=115200

mega2560.bootloader.low_fuses=0xFF
mega2560.bootloader.high_fuses=0xD8
mega2560.bootloader.extended_fuses=0xFD
mega2560.bootloader.path=stk500v2
mega2560.bootloader.file=stk500boot_v2_mega2560.hex
mega2560.bootloader.unlock_bits=0x3F
mega2560.bootloader.lock_bits=0x0F

mega2560.build.mcu=atmega2560
mega2560.build.f_cpu=16000000L
mega2560.build.core=arduino
mega2560.build.variant=mega
29  International / Megatopic / Re: Nuovo IDE 1.0.4 on: March 12, 2013, 11:42:22 am
perchè nessuno lo mantiene, evidentemente smiley

bellissimo...
Sono pacchetti di secondaria importanza e per essi generalmente nei repo Ubuntu mettono una versione stabile e poi la lasciano lì. Scaricati l'IDE dal sito e risolvi.
Oppure compila dai sorgenti.
Oppure ancora passa ad una distro che aggiorna molto più velocemente i pacchetti (come ad esempio Arch Linux).


Sto imparando (in modo serio) ad usare linux "solo" adesso...
Avrei pure scaricato la versione dal sito, però vorrei quelle cose a tipo bimbominkia: l'iconcina e la cartella di arduino nella cartella di sistema giusta (che non so dove dovrei mettere)
Se magari mi dai un suggerimento.... smiley-wink




Secondo me non hai aggiornato un bel nulla. apri il file boards.txt e sostituisci nella board che hai usato il valore efuse (attuale ff) con "0d", quindi riprova a fare l'upload, che ovviamente stai facendo mediante collegamento ISP, spero....

Prof, ho scritto che ho usato la usbasp, quindi.... smiley
Ora provo a fare l'upload modificando il fuse. Grazie
30  International / Megatopic / Re: Nuovo IDE 1.0.4 on: March 12, 2013, 07:26:25 am
comunque, giusto per la cronaca, ho aggiornato il bootloader della mia 2560, a fine processo di uploading mi da errori.

però compila e carica senza problemi sketch... boh

con usbasp:
Code:
avrdude: warning: cannot set sck period. please check for usbasp firmware update.
avrdude: verification error, first mismatch at byte 0x1e000
         0xff != 0x0d
avrdude: verification error; content mismatch
Pages: 1 [2] 3 4 ... 48