Show Posts
Pages: [1] 2 3 ... 40
1  Forum 2005-2010 (read only) / Troubleshooting / Re: LCD Help. on: November 29, 2007, 01:11:33 pm
Just pull the ATmega168 chip out of the Arduino and it will work fine. smiley
You'd be 'borrowing' the serial circuitry.

If you require the Arduino to process the information then use SoftwareSerial for the LCD.
2  Forum 2005-2010 (read only) / Troubleshooting / Re: Help with Arduino on a Breadboard on: October 31, 2007, 06:34:01 am
Quote
The problem was that as soon as I connected the stk-200 to the ICSP on the Arduino and powered up the Arduino (through external adapter or through USB from computer), the Arduino wouldn't power up. Removing the ICSP connector of the STK200, Arduino powered up again.
That sounds like a short circuit. Check with a multimeter.
3  Forum 2005-2010 (read only) / Troubleshooting / Re: How to use Textmate with Arduino on: September 28, 2007, 02:25:01 am
I just happened to notice this thread while I was reading yours: http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1187984620
4  Forum 2005-2010 (read only) / Troubleshooting / Re: Who did the Gentoo tutorial? on: September 21, 2007, 06:19:38 am
Changes have been made and I've informed Jonny Stutters about the change.

Now to play with my Arduino. smiley-grin
5  Forum 2005-2010 (read only) / Troubleshooting / Re: Who did the Gentoo tutorial? on: September 21, 2007, 01:20:26 am
Yay! I finally got my Arduino and now I might actually get the software installed properly. smiley-wink

Man its tiny. The photos make it look a lot bigger.
6  Forum 2005-2010 (read only) / Troubleshooting / Re: Who did the Gentoo tutorial? on: September 20, 2007, 06:25:51 pm
Yeah I'll clean it up when I'm done.

I'm just using this thread as a notepad and I'm curious who else uses Gentoo.
7  Forum 2005-2010 (read only) / Troubleshooting / Who did the Gentoo tutorial? on: September 20, 2007, 06:35:55 am
The Gentoo page in the wiki can be cleaned up a little.

For example:
Quote
A warning concerning the crossdev section: The current version of crossdev, 0.9.17 (binary is called crossdev-stable!) doesn't want to compile avr-g++ at all. I don't know why, but for avr, crossdev is set to always emerge to a stage without g++ which arduino needs. Comment out STAGE= in /usr/bin/crossdev-stable line 106 and you should hopefully be fine. YMMV.
Thats easily fixed without editing any files. Just run crossdev -t avr -s4 instead of crossdev -t avr smiley

Also the ln -s line doesnt specify what the current directory should be.
I'm trying to figure that bit out at the moment.

So who else here uses Gentoo? smiley-grin

I'll use this thread as a little notepad to keep track of things to improve on.
8  Forum 2005-2010 (read only) / Troubleshooting / Re: ROV motor on: September 17, 2007, 07:50:26 pm
Quote
because led's that are bright enough to illuminate stuff underwater are expencive.
1W leds are only about $3 each.

My 8x8 true colour display using 24 74HC595's will give a good indication of how well artificial PWM works.
I intend to do a tight loop switching them on and off as quickly as possible.

You could use multiple controllers.
The Arduino for controlling the robot and another one for doing PWM.

A better idea than relays is this.
A 8 channel IC for high load stuff. smiley
9  Forum 2005-2010 (read only) / Bugs & Suggestions / Re: software serial2 on: February 07, 2008, 02:06:05 am
Quote
er, no..."currently only for Diecimila (16mhz atmega168)"  smiley-wink
Isnt the Lillypad a 168? Not sure about the Bluetooth one.
10  Forum 2005-2010 (read only) / Bugs & Suggestions / Re: frame size on shiftout on: November 25, 2007, 10:45:58 am
Odd frame sizes is only a tiny edit to the code and is rare so I dont see any point to building it in.
Anyone requiring it can easily do it.
11  Forum 2005-2010 (read only) / Bugs & Suggestions / Re: Playground design requests... on: November 07, 2007, 05:55:40 pm
Gentoo-Wiki.com has a nice style for code.
12  Forum 2005-2010 (read only) / Bugs & Suggestions / Re: Arduino chews 100% cpu on: October 31, 2007, 05:39:14 am
Quote
One time Windows froze compleatly and one time the app.
Thats completely standard Windows behavior. ;D

This is more than likely a *nix specific bug.

I tried poking through the code a little and I couldnt find any relevant parts so a dev will have to look at this.
13  Forum 2005-2010 (read only) / Bugs & Suggestions / Arduino chews 100% cpu on: October 30, 2007, 05:02:42 pm
I've noticed that Arduino will chew 100% cpu occasionally.

I think I've narrowed it down to if you turn on Serial Monitor and then unplug the Arduino then it will chew 100% cpu.
It must enter a loop continually trying to access the serial port.
14  Forum 2005-2010 (read only) / Bugs & Suggestions / Re: IDE Keyboard Shortcuts on: September 22, 2007, 06:41:54 pm
I'm using Gentoo Linux with Sun JDK 1.6.0.02.

Although now that you mention it, my middle mouse button clipboard isn't working with the IDE.
Keyboard shortcuts are fine though.
15  Forum 2005-2010 (read only) / Bugs & Suggestions / Re: IDE Keyboard Shortcuts on: September 21, 2007, 11:55:26 pm
There is a Makefile which I believe can be used for console compiling.
Pages: [1] 2 3 ... 40