Show Posts
Pages: [1] 2
1  Using Arduino / Installation & Troubleshooting / Is it possible to measure the Arduino Power consumption !? HOW ??! on: February 17, 2011, 04:19:32 pm
hardware :

Arduino uno with temperature and accelerometer sensor attached.

i want to measure the power consumption of my hardware to know how long a battery will last on my device.


if its possible how ?!

thanks
2  Forum 2005-2010 (read only) / Interfacing / Real time plotting using Matlab on: January 05, 2011, 01:16:55 am
i have this project using Arduino uno and accelerometer, also a tempreture sensor that just print an output value " object hot" or "object cold"

example from the hyper terminal :"

example (hyper terminal values )

50
53
54
56
object is HOT
57
68
69
object is Cold
70
71
73

can the GUI plot the accelerometer values and print the message" object is cold" or object is HOT" on the corner of the graph ? i mean how the matlab can differentiate between the values and the message ?

my second question : is there an easy tutorial how to real time plotting using matlab ? im a noob when it comes to matlab ! i want to learn so anything to put me on the right track would be much appreciated !
3  Forum 2005-2010 (read only) / Interfacing / Re: decoded IR signal doesnt follow any known protocol on: November 23, 2010, 05:50:02 pm
are there easier way to do this .

like having an algorithm that calculates the on off periods and generate a unique code for that signal .

4  Forum 2005-2010 (read only) / Interfacing / Re: decoded IR signal doesnt follow any known protocol on: November 23, 2010, 05:45:52 pm
oh i see,

it actually works fine for regular remote control . i tested it with a stereo tv remote control .

how ever in my case, the room locater send the signal continuously every 30 seconds or so.  so its hard to store the learn the signal and test it .
i keep getting  mismatch key pressed, i think because the signal keep going, i cant control the time like pressing a key on a remote control .

5  Forum 2005-2010 (read only) / Interfacing / Re: decoded IR signal doesnt follow any known protocol on: November 23, 2010, 05:14:12 pm
im not sure , how this should work ...

the ir sensor connected to pin 2 , i uploaded the code as-is  , the hyperterminal shows :

Begin by pressing '0' to prepare the EEPROM to store encodings
Press a key:
              0: Erase/initialize EEPROM
                                          1: Learn a new encoding
                                                                   2: Test last
learned encoding
                  3: Save last learned encoding to EEPROM
                                                           M: Output stored enco
ding
      V: Verify stored encodings in EEPROM
                                            F: Print free EEPROM space
                                                                        H: Prin



--------------------------

is there extra hardware need to be attached . it says press a key !?





Oh ok , this code for your shield ,,,, i see .

i want to use just the IR sensor for decoding, i already have my own hardware, decoding the IR is an extra feature for my device, i cant use or add another hardware.  
6  Forum 2005-2010 (read only) / Interfacing / Re: decoded IR signal doesnt follow any known protocol on: November 23, 2010, 04:59:10 pm
thanks for the reply, i really appreciated .

im using Aurduino uno  whis is not listed in the code, what do i need to add that .

.....

i see many codes , im confused how to add them to the arduino ? should i make multiple files and upload them all at once ? please explain , or let me know if there is a tutorial out there ......

thanks
7  Forum 2005-2010 (read only) / Interfacing / decoded IR signal doesnt follow any known protocol on: November 23, 2010, 03:09:48 pm
im trying to decode an infrared signal from a room locator, the locator send an infrared signal to a receiver the receiver decode the signal and tell if its room 1 or 2 or 3 ..etc

so i want to decode the IR signal instead of that receiver , the room locater can be programmed from room 001 to room 777 .

i used this script to get my data and used gnuplot to plot them .
http://www.arduino.cc/playground/Code/InfraredReceivers

the plot below show the signals for rooms 1,2,3,4,5,6,7 and room 10

i just wanna make sense of these signals , i dont want to retransmit the signals , just identify them and print if the signal came from room 1 or 2 ..etc





it doesnt follow any known protocol like sont, NEC , JVC ... etc , can somebody make sense of these signals.  what can i do to recognise them if they dont follow a known protocol !

thanks
8  Forum 2005-2010 (read only) / Interfacing / Re: cant upload my code to Arduino BT ( going crazy) on: December 01, 2010, 01:49:31 pm
i tried all times. i still get protocol error or cant sync !

this is a poor design , is that the only way to load the code to the arduino without editing the programmer !
9  Forum 2005-2010 (read only) / Interfacing / Re: cant upload my code to Arduino BT ( going crazy) on: November 30, 2010, 04:14:05 pm
any help is appreciated !!
10  Forum 2005-2010 (read only) / Interfacing / cant upload my code to Arduino BT ( going crazy) on: November 24, 2010, 07:48:39 pm
I tried everything i read in this forum and other forums.

i can connec to the arduino .
i chose the right board and right port #

i tried to push rest before i hit upload / after i hit upload  ! i tried pushing the reset before powering the arduino BT and then release and upload

nothing work ..... please help me and tell me what to do !  :'(


11  Forum 2005-2010 (read only) / Interfacing / Re: "Hello world" with bluetooth and Arduino on: November 30, 2010, 03:52:06 pm
thanks for all the replies..

it worked by changing the serial baud rate !!!

Serial.begin(115200);  in code side

and in the hyper terminal , now i can receive from the bluetooth !

didnt expect the baud rate was the problem

12  Forum 2005-2010 (read only) / Interfacing / Re: "Hello world" with bluetooth and Arduino  ! on: November 29, 2010, 01:55:43 pm
the bluetooth blinks red light . once i connect to it it turns to solid green light.

so my problem is in the hardware? usually the software doesnt change if its usb serial or bluetooth connected?
13  Forum 2005-2010 (read only) / Interfacing / Re: "Hello world" with bluetooth and Arduino on: November 28, 2010, 04:58:12 pm
bluetoth dongle




i also have this "





both worked and i can see the bluetooth and connect to it  ( i use the toshiba bluetooth software)

14  Forum 2005-2010 (read only) / Interfacing / "Hello world" with bluetooth and Arduino  ! on: November 28, 2010, 04:20:44 pm
hardware:
Arduino uno , bluesmirf gold bluetooth ( spp profile)

computer connection :
i can see the bluetooth module , connect to it using the right port , but i cant see anything on the hyper terminal !


wiring :




code:
Code:
void setup()
{
  Serial.begin(9600);
}

void loop()
{

  Serial.println("Hello World");
  }





what im doing wrong ? thanks in advance for the help
15  Forum 2005-2010 (read only) / Interfacing / Re: Arduino Uno & bluesmirf gold bluetooth (noob Q ) on: November 27, 2010, 02:22:17 am
.
Pages: [1] 2