Show Posts
Pages: 1 [2] 3 4 ... 30
16  Forum 2005-2010 (read only) / Troubleshooting / Re: Uploading error on: January 13, 2008, 06:20:28 pm
Gabriel,

I'm using WinXP, and an Arduino self made serial board (with subd connector) and Atmega8. If not the same you're using, is similar.
I've used the bootloader with parallel programmer http://www.arduino.cc/en/Hacking/ParallelProgrammer.

With this hardware configuration, when you try to bootload with Arduino 0010, there's a bug that makes you wait more than 10 minutes without messages until complete bootload. Perhaps this is happening with you, that's why you're thinking it's impossible to bootload with Arduino IDE.

If you already has installed Giveio (I'm not sure you'll need, but to be faster than messages, if not installed: http://web.mit.edu/6.115/www/miscfiles/giveio.zip)
and installed XP_Stop_Polling http://www.melabs.com/downloads/XP_stop_polling.reg,

If you know DOS, I suggest you try this:
make a parallel programmer cable (it's easy);
open a DOS prompt window;
go to this directory ...\arduino-0010-win\arduino-0010\hardware\tools\avr\bin

execute this (set highlighted to match your correct directory):
avrdude -C[glow]C:\[/glow]arduino-0010\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -pm8 -cdapa -e -Ulock:w:0xFF:m -Uhfuse:w:0xca:m -Ulfuse:w:0xdf:m -F

and then this:
avrdude -C[glow]C:\[/glow]arduino-0010\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -pm8 -cdapa -e -Uflash:w:[glow]C:\[/glow]arduino-0010\hardware\bootloaders\atmega8\ATmegaBOOT.hex:i -Ulock:w:0xCF:m -F

Remove the cable, and press reset. If led on pin13 blinks once and fast, then open Arduino 0010 and try to upload some sketch (blink example, for example).

Or, if you think it's too complicated or not familiarized with DOS, try this:

Download Arduino 0007 http://www.arduino.cc/files/arduino-0007-win.zip
Run Arduino.exe or Run.bat;
Chosse correct IC and board;
Choose Comm Port;
Burn Bootloader with Parallel Port Programmer.

Good luck. And don't give up. You just had a bad day.
17  Forum 2005-2010 (read only) / Bugs & Suggestions / Re: Forum Categories on: January 08, 2009, 09:27:54 am
I agree with AlphaBeta. And I think it looks better this way, Mellis. Thanks.

BTW, I was thinking why not to put a link to the arduino.cc site, on the top of the forum pages? Is it possible? Isn't it usefull?
The arduino.cc site has a link to this forum, but here there is no way back.

What do you think?
18  Forum 2005-2010 (read only) / Bugs & Suggestions / Re: Single-sided Arduino corrections on: January 04, 2009, 08:22:19 pm
Bosco,

thanks for the corrections.
Fixed.
19  Forum 2005-2010 (read only) / Bugs & Suggestions / Re: how to avoid reset when starting serial monito on: January 22, 2008, 02:38:18 pm
If you discover how to do it with software, tell us.

Since I couldn't do it through software, I implemented a hardware solution on Arduino S3v3 Beta, that's only a jumper that disables auto reset for cases like your. Just remove the jumper, and Arduino will not reset automatically.
If the software solution doesn't exist, or if it get too complicated, at least a hardware simple solution already exists, and it is being tested sucessfully. Perhaps this could became a standard for newer Arduinos...
20  Forum 2005-2010 (read only) / Bugs & Suggestions / Re: how to avoid reset when starting serial monito on: January 21, 2008, 09:50:05 pm
Did you read this?
http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1198985398

And there's a non-temporarily hardware solution (to remove the cap labeled as R3 on schematics), but I don't recommend it, except if you soldering skill are good.
21  Forum 2005-2010 (read only) / Syntax & Programs / Re: Simultaneous Pulses w/ picture now on: November 03, 2008, 08:15:29 pm
I answered you in portuguese, but I´ll reply here too, just in case other ones (not portuguese speakers) need the same answer:
If you need timing precision on simultaneous but different output pins, you can use port manipulation:
http://www.arduino.cc/en/Reference/PortManipulation
22  Forum 2005-2010 (read only) / Syntax & Programs / Re: Simultaneous Pulses on: November 03, 2008, 08:18:51 pm
If you have a suggestion, I suggest you to answer on this post, to keep only one post/topic:
http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1225739204
23  Forum 2005-2010 (read only) / Syntax & Programs / Re: DC motors - Forward and backwards on: July 25, 2008, 05:41:00 pm
You can see here one example of the discreet components solution (H-Bridge), that Bens told us:
http://library.solarbotics.net/circuits/driver_4varHbridge.html
24  Forum 2005-2010 (read only) / Syntax & Programs / Re: Accessing registers in Arduino? on: April 30, 2008, 05:48:17 pm
I read your other post about TCNT1, and this one too.

I'm not an expert about this, but since nobody answered you, I'll tell you my opinion. I think you don't need to declare the registers; You can find many examples of the use of  registers inside a sketch. Search in www.arduino.cc search box (not in the forum search), and you'll find the examples.
25  Forum 2005-2010 (read only) / Interfacing / Re: Servo Datasheet on: March 05, 2008, 06:33:31 pm
This doc:

http://www.mil.ufl.edu/imdl/papers/IMDL_Report_Spring_03/dockendorf_karl/stalkerbot.pdf

Says this:

The MX-400 servo is distributed by Maxx Products, Inc. and resold through Acroname, Inc. (4894 Sterling Drive, Boulder CO, 80301-2350, phone: 720-564-0373) via their website (http://www.acroname.com)

the website has no info about the MX-400, but try to e-mail them too.
26  Forum 2005-2010 (read only) / Interfacing / Re: Servo Datasheet on: March 05, 2008, 03:38:54 pm
Did you try asking/contacting the manufacturer?
http://www.maxxprod.com/
27  Forum 2005-2010 (read only) / Development / Re: What is X3 4-pin header conneaction near USB f on: January 22, 2008, 09:33:16 pm
Please,

read this:
http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1184164578

and this:
http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1180915644/7
28  Forum 2005-2010 (read only) / Español / Re: páginas en español on: March 13, 2008, 05:29:55 pm
http://www.arduino.cc/en/Main/Buy
29  Forum 2005-2010 (read only) / Español / Re: hala..... problemas con el bootloader on: May 13, 2008, 12:47:12 pm
Parece que debe funcionar. No tengo certeza.

Lo "parallel port programmer" funciona bien y es muy fácil hacer:
http://www.arduino.cc/en/Hacking/ParallelProgrammer

Las fotos que usted ve aquí se deben publicar en un sitio de fotos (flickr, o otro), y aquí usted ponen solamente el link para ellos.

Disculpe por mi espanol.
30  Forum 2005-2010 (read only) / Español / Re: hala..... problemas con el bootloader on: March 11, 2008, 12:40:40 am
la versión 10 tiene un problema con windows xp/placa serie/Atmega8, un comando que causa la demora en bootloader de 10 minutos (comando -i800), y algunas veces no funciona (falta el comando -F). Una possible solucion es usar la version 7. O escribir el comando en el DOS.
Pages: 1 [2] 3 4 ... 30