Show Posts
Pages: [1]
1  International / Hardware / Quale hardware prendere per un robot? on: January 26, 2013, 04:19:41 am
Ciao a tutti,
premetto che di arduino non me intendo molto purtroppo. Tuttavia per la tesina vorrei portare un robot. Per farlo (credo) ho bisogno di un chassis che permetta al robot di muoversi precisamente e che possa ruotare su stesso (deve viaggiare in una specie di labirinto quindi deve ogni tanto deve poter girare di 90° o anche di 180° per tornare indietro) e di un sensore di colore per capire su che colore della mappa stia viaggiando.
Io posseggo giusto un arduino uno e lo starter kit della sparkfun (https://www.sparkfun.com/products/9284)
Per la parte software non ho problemi mentre per quella hardware si. Non ho la minima idea di dove trovare questi pezzi o di come costruirli. Quindi mi rivolgo a voi del foro per capire cosa dovrei comprare.

P.s.
Per farvi capire meglio descrivo brevemente il progetto:
su una mappa (pensavo stampata su carta) a scacchiera sono disposti due tipi di celle:
-nere: fanno perdere vita al robot
-bianche: ricaricano la vita del robot
il robot non può mai stare fermo e deve riuscire a trovare un percorso che gli permetta di sopravvivere.
(non è ammesso fare avanti e indietro da un cella nera a una bianca, deve almeno trovare un percorso composto da 6 celle)


2  Using Arduino / Project Guidance / Re: Floppy Music on: August 26, 2012, 12:50:07 pm
Thanks but i really want to make music with Floppy Drives.
I just discovered that the software part is ok. Now i have to understand what don't work in the hardware...
3  Using Arduino / Project Guidance / Floppy Music on: August 26, 2012, 10:30:51 am
Hello
i'm following this tutorial ( ) to make music with floppy drives.
I have attacched a video to show what i have done. I think the hardware part work correctly because if i try the test (also showed in the video) it works.
Also the software part work correctly(i think). It connects and sends commands to the Arduino but the floppy drive don't make music!
Maybe is a software error because when i try to compile MoppyDesk i get this 2 errors:

ago 26, 2012 4:34:53 PM org.jdesktop.application.LocalStorage getId
WARNING: unspecified resource Application.id using MoppyUI
ago 26, 2012 4:34:53 PM org.jdesktop.application.LocalStorage getId
WARNING: unspecified resource Application.vendorId using UnknownApplicationVendor

any suggestion? Thanks smiley

p.s. Sorry for my english

4  Using Arduino / Programming Questions / blinking LED on the serial command on: August 17, 2011, 01:28:21 pm
Hello everyone,
I need to figure out how to make blink a LED on a serial command.
In fact I would like something like this:

Code:

void setup() {               
  pinMode(13, OUTPUT);   
  Serial.begin(9600); 
}

void blink(){
  digitalWrite(13, HIGH);   // set the LED on
  delay(1000);                 // wait for a second
  digitalWrite(13, LOW);   // set the LED off
  delay(1000);
  blink();
}

void off(){
  digitalWrite(13, LOW);
}

void loop () {
  int r = Serial.read ();
  if (r == 100) blink ();
  if (r == 101) off ();
}

But it goes in an infinite loop when i start function "blink" beacuse the recursion call itself every time.

i need to use a thread to this thing?

thanks smiley

p.s. Sorry for my english
5  Forum 2005-2010 (read only) / Troubleshooting / Ubuntu IDE problem on: December 29, 2010, 05:52:57 am
Hi, when i try to compile that code:

void setup(){
  pinMode(9,OUTPUT);
}
void loop(){
  digitalWrite(9,LOW);
}

i recve this error:
java.lang.NullPointerException
      at processing.app.debug.Compiler.compile(Compiler.java:75)
      at processing.app.Sketch.build(Sketch.java:1412)
      at processing.app.Sketch.exportApplet(Sketch.java:1451)
      at processing.app.Sketch.exportApplet(Sketch.java:1420)
      at processing.app.Editor$46.run(Editor.java:2219)
      at java.lang.Thread.run(Thread.java:636)

I'm using UBUNTU 10.10 and i'm using the ide take from the ubuntu software center.
p.s. for java i'm using openJDK 6
6  Forum 2005-2010 (read only) / Troubleshooting / Serial problem on: December 29, 2010, 05:31:28 am
Hi,
i am a newbie. I write this program but don't work. Why?

void setup() {
  Serial.begin(9600);
  pinMode(9, OUTPUT);
}

void loop() {
  digitalWrite(9,HIGH);
  Serial.println("ON");
  delay(500);
  
  digitalWrite(9,LOW);
  Serial.println("OFF");
  delay(500);
}

The led blink but in the console ( is the console down to the ide? ) don't show anything...

In the board i have just a led and a 330 resistor.


if i try that code the led blink:

void setup() {
  pinMode(9, OUTPUT);
}

void loop() {
  digitalWrite(9,HIGH);
  delay(500);
  digitalWrite(9,LOW);
  delay(500);
}

so there isn't a led problem.
7  Forum 2005-2010 (read only) / Italiano / Display a 7 segmenti on: January 10, 2011, 11:16:55 am
Ciao,
oggi ho trovato un vecchio orologio digitale, l'ho aperto facendo attenzione a non rompere nulla e ho ricavato un display a 7 segmenti con 4 "lettere" ovvero che può mostrare senza problemi 88:88
Ho guardato un po' in giro e non ho trovato nessun display a 7 segmenti simili a questo. Infatti il mio non ha uscite! Nel senso che è totalmente ricoperto di vetro(sempre che lo sia). Però se lo metto contro luce vedo chiaramente circa(se ho contato bene) 15 contatti che però sembrano totalmente dentro al vetro. Ho guardato anche il circuito e l'unica cosa che era a contatto tra il display e il circuito era un gommino. Come è possibile?
In conclusione vorrei sapere come potrei riutilizzare questo display per divertirmi un po'...

grazie in anticipo

Link per l'immagine del mio display: http://img145.imageshack.us/img145/9652/display7seg.png
8  Forum 2005-2010 (read only) / Italiano / Re: Come ho fatto a bruciare il led? on: January 05, 2011, 04:37:16 am
Non so niente di elettronica, ma i resistori non servono ad abbassare gli amper? E poi io ho sempre alimentato i led con 5 volt e non se ne mai bruciato uno. Se provo a mettere la gamba lunga di un led nel pin digitale 13 e la gamba corta nel gnd, funziona benissimo. Perchè allora si è bruciato?
9  Forum 2005-2010 (read only) / Italiano / Come ho fatto a bruciare il led? on: January 04, 2011, 03:28:16 pm
Salve,
sto imparando un po di elettronica e oggi ho voluto provare i transistor. per farlo ho fatto il seguente circuito:
http://img524.imageshack.us/img524/3513/immaginehtk.png
appena faccio passare la corrente al mio arduino sento subito una puzza di bruciato tremendo e vedo che il led da accesso si spegne piano. Stacco subito e la usb e mi accorgo che arduino funziona ancora bene  ;D ma il led, purtroppo è morto. Meno male che ne ho altri 19 smiley

Non capisco cosa ho sbagliato! Se non faccio passare 5v nella gamba di mezzo del transistor non dovrebbe passare la corrente al led! Cosa ho sbagliato! Non voglio più bruciare led!
E poi come posso sapere se il transistor è rotto o no?

Grazie

p.s. scusate ma sono un nabbetto
10  Forum 2005-2010 (read only) / Italiano / Guida on: December 29, 2010, 04:15:12 pm
Salve,
mi è arrivato da poco il mio primo arduino (  smiley  ) e ho bisogno di una buona guida per imparare.
Premettendo che di programmazione me ne intendo abbastanza ( conosco bene c++/c java pascal delphi html css php mysql javascript e basic ) vorrei una guida principalmente per l'elettronica e il funzionamento di arduino.
Preferirei in italiano ma posso farne anche a meno.

P.S.
Uso Arduino UNO

P.S.
Già che ci sono faccio una piccola domanda: se alimento arduino con i suoi corretti 5volt dalla presa USB corro rischi di bruciare qualcosa o di rovinare il mio amato arduino?
11  Forum 2005-2010 (read only) / Troubleshooting / Sorry i didn't use the right section on: January 04, 2011, 03:22:34 pm
sorry, delete this
12  Forum 2005-2010 (read only) / Troubleshooting / Re: electric current to arduino on: December 28, 2010, 11:58:01 am
with a bit of fortune and time smiley-lol i test the output that was 5.05 volt. Perfect!
13  Forum 2005-2010 (read only) / Troubleshooting / Re: electric current to arduino on: December 28, 2010, 11:55:39 am
it work. I have a digital tester, but i can't use, the usb is too small for that. How i can test the voltage?
14  Forum 2005-2010 (read only) / Troubleshooting / Re: electric current to arduino on: December 28, 2010, 11:32:31 am
OUTPUT: 5V 1.0A(1.0A)MAX.LPS
it's ok?
15  Forum 2005-2010 (read only) / Troubleshooting / electric current to arduino on: December 28, 2010, 11:11:53 am
Hi,
i have a no-problem smiley-lol . Infact I just afraid to make a wrong thing.
In my arduino one there wasn't the current cable. But i have a converter from electrical outlet to USB.  Like this: http://www.usbgeek.it/public/15/31500.jpg
I can use that or i might BURN it ? smiley-lol
Sorry i am a newbie, i think that i know the answer but i don't want break my new arduino <3
Pages: [1]