Show Posts
Pages: [1] 2
1  International / Français / Arduino leonardo et les PWM on: May 05, 2013, 10:19:18 am
Salut a tous

voila, j'ai un arduino leonardo et je suis a la recherche d'une librairie pour gerer les PIN 0 a 13 en PWM.
Mon but est de mettre une LED par PIN et de les faire s'allumer progressivement.

J'ai regardé sur le net mais la seule librairie que j'ai trouvé ne fonctionne pas avec le léonardo smiley-sad

si quelqu'un avait cela ca serait top smiley  ( ou si vous avez d'autre idée je suis preneur mais les ports Analogiques sont deja pris )

D'avance merci  smiley
2  International / Français / Re: Server web, besoin d'aide [RESOLUE] on: February 24, 2013, 02:45:17 pm
merci a tous grave a vos remarques j'ai trouvé ce qui ne va pas
j'ai vaii un test sous mon pc WinXP et la ca marchait... (je fesais mes essais sur win7)
apres recherche, il avec une ip fixe que je lui avait mise...

du coup j'ai forcé l'IP de ma carte reseaux et la ... yahou ca marche!!!

je vous remercie une fois encore pour votre aide!
3  International / Français / Re: Server web, besoin d'aide on: February 23, 2013, 05:36:44 am
merci de l'info.
j'utiliserais toujours mon cable croiser a partir de maintenant, mais meme avec rien  smiley-sad-blue
4  International / Français / Re: Server web, besoin d'aide on: February 23, 2013, 04:51:58 am
merci de votre aide

alors infobarquee, l'ip 81 est en fait mon PC (ip du PC)  smiley-fat
chabot380, oui je l'ai configurer en routeur (mais comme une erreur est toujours possible, je fait a chaque les tests en direct avec une connexion pc / shiel ethernet et une autre via le router). De plus j'ai configurer la box pour que l'IP 177 soit prise en compte (dans le doute j'ai fait le test avec une IP a 70 et rien )

QUestion, si je branche en direct, normalement a devrait passer non? (je suis pas obliger de passer par le routeur de box? )

5  International / Français / Re: Server web, besoin d'aide on: February 22, 2013, 03:24:07 pm
Alors voici le ping :

C:\Users\Fana>PING 192.168.1.177

Envoi d'une requête 'Ping'  192.168.1.177 avec 32 octets de données :
Réponse de 192.168.1.81 : Impossible de joindre l'hôte de destination.
Réponse de 192.168.1.81 : Impossible de joindre l'hôte de destination.
Réponse de 192.168.1.81 : Impossible de joindre l'hôte de destination.
Réponse de 192.168.1.81 : Impossible de joindre l'hôte de destination.

Statistiques Ping pour 192.168.1.177:
    Paquets : envoyés = 4, reçus = 4, perdus = 0 (perte 0%),

Et toujours pas moyen de le faire marcher meme derrière ma box

J'ai toujours besoin d'aide ....je commence a deseperer  smiley-cry smiley-cry
6  International / Français / Re: Server web, besoin d'aide on: February 21, 2013, 06:07:56 am
A oui c'est vrai.. j'ai mis le mauvais ping hier soir   smiley-eek-blue...
(c'est ca de faire plein de test  smiley-twist)....
Je remet le rapport officiel ce soir (mais quand je ping en 177 il me repond sur le 81 de memoire. C'est pour cela que j'ai testé le 81)
7  International / Français / Re: Server web, besoin d'aide on: February 21, 2013, 12:06:40 am
bonjour
type de modem==> j'ai une sfr box (mais comme dit plus haut je suis en direct sur la carte reseau pour l'arduino)
c'est bien sur la bonne plage ip==> yes ( du coup ce soir je fais un essai en me mettant derriere la box)
peux tu pingger l'ip? non j'ai cela quand je ping:


Envoi d'une requête 'Ping'  192.168.1.81 avec 32 octets de données :
Réponse de 192.168.1.81 : octets=32 temps<1ms TTL=128
Réponse de 192.168.1.81 : octets=32 temps<1ms TTL=128
Réponse de 192.168.1.81 : octets=32 temps<1ms TTL=128
Réponse de 192.168.1.81 : octets=32 temps<1ms TTL=128

Statistiques Ping pour 192.168.1.81:
    Paquets : envoyés = 4, reçus = 4, perdus = 0 (perte 0%),
Durée approximative des boucles en millisecondes :
    Minimum = 0ms, Maximum = 0ms, Moyenne = 0ms

merci pour votre aide
8  International / Français / Re: Server web, besoin d'aide on: February 20, 2013, 04:04:00 pm
he... cable croisé mis et non pas mieux....
une idée?
9  International / Français / Re: Server web, besoin d'aide on: February 20, 2013, 03:55:00 pm
j'avais pas penser au cable croiser ... je vais faire un essai de suite
par contre je peux le mettre sur ma box ok mais je ne sais pas encore du tous comment la configurer...

je reviens vers vous pour le test du cable croiser
10  International / Français / Re: Server web, besoin d'aide on: February 20, 2013, 03:46:38 pm
Merci pour la reponse rapide
alors les serial print (dans la fentre pour espinner la com serie) j'ai : "server is at 192.168.1.177" et rien d'autre
si cela peux aider, j'ai relié mon arduino directement sur a mon pc sur l'ethernet (et j'ai aussi le wifi activer pour surfer mais meme non connecté ca marche pas..)
11  International / Français / Server web, besoin d'aide on: February 20, 2013, 03:34:59 pm
Bonjour
j'ai un probleme pour creer mon serveur web.
J'utilise une Arduino leonardo coupler avec un shield ethernet.
Ensuite je charge le code proposer dans le tuto : http://arduino.cc/en/Tutorial/WebServer
je compile, charge sans aucun  problème.
Ensuite dans mon navigateur web je tape l'adresse 192.168.1.177 et la ... rien....

j'ai loupé un truc? ou j'ai pas compris quelque chose?
mon but pour commencer et simple, afficher une page web simple dans un premier temps puis ensuite, pouvoir commander une led via la page web créé.

cela fait quelques jours que je tourne en rond et test du code a plus savoir qu'en faire...
si quelqu'un pouvait me dire ou je me suis planter.

d'avance merci pour votre aide
12  Forum 2005-2010 (read only) / Interfacing / Re: Arduino MEGA and Eclipse configuration on: January 09, 2011, 10:02:06 am
Yes you are wright.
Because i have mande many test, the last main used (and posted are not OK).
I have update the main as :

dint main(void) {

  /* Must call init for arduino to work properly */
  init();

  /****************************/
  /* Add your setup code here */
  /****************************/

  pinMode(13, 1);

  for (;smiley-wink
  {
        digitalWrite(13, 1);   // set the LED on
        delay(1000);              // wait for a second
        digitalWrite(13, 0);    // set the LED off
        delay(1000);              // wait for a second

      /****************************/
    /*** write main loop here ***/
    /****************************/
  } // end for

} // end main


Now the Led is always ON.... and never Off... :-/


13  Forum 2005-2010 (read only) / Interfacing / Re: Arduino MEGA and Eclipse configuration on: January 09, 2011, 09:44:01 am
Hello PaulS

Yes, the Led is still OFF and will never ON. (no blink mode..  :'()
and I don't understand why...
Have you some idea?

(It is not an hardware problem because the "blink" program exemple in arduino works with arduino software)

Thanks for you help Pauls
14  Forum 2005-2010 (read only) / Interfacing / Arduino MEGA and Eclipse configuration on: January 09, 2011, 09:30:20 am
Hello
I want programed the Arduino Mego on Eclipse software  (version 3.6.1)  but i don't manage it.
I have followed the "How to" (with compiling the librairie on the software) but it doesn't work.
I can build and load my software on arduino but nothing is done.
I have Copy/Paste the "blink" program exemple...

Someone have any idea or any valide configuration for eclipse (with a valid exemple)?


thanks fo your help

This is my main :
int main(void) {

 /* Must call init for arduino to work properly */
 init();

 /****************************/
 /* Add your setup code here */
 /****************************/

 pinMode(13, 1);

 for (;smiley-wink
 {
       digitalWrite(13, 0);   // set the LED on
       delay(1000);              // wait for a second
       digitalWrite(13, 0);    // set the LED off
       delay(1000);              // wait for a second  

     /****************************/
   /*** write main loop here ***/
   /****************************/
 } // end for

} // end main
15  Forum 2005-2010 (read only) / Français / Re: Arduino MEGA et Eclipse on: January 11, 2011, 02:27:47 pm
Non non, j'ai verifié le projet C et nivo config ca semble bon aussi...
(en meme temps comme j'ai pas trouver le probleme sur le project C je sais pas trop si c'est vraiment cela ou pas...)
 smiley-wink
Pages: [1] 2