Show Posts
Pages: [1]
1  Using Arduino / Installation & Troubleshooting / Re: avrdude: ser_open(): can't open device "\\.\COM3": Access is denied. on: February 08, 2011, 11:32:20 pm
WOW do I feel silly.  Somehow the board was changed from an Uno.  I changed it back to an Uno and it is working fine now.  I didn't even know this was an option, so I don't know how I did it.

thanks for your help.

Jordan
2  Using Arduino / Installation & Troubleshooting / Re: avrdude: ser_open(): can't open device "\\.\COM3": Access is denied. on: February 08, 2011, 10:38:05 pm
* bump *
3  Using Arduino / Installation & Troubleshooting / avrdude: ser_open(): can't open device "\\.\COM3": Access is denied. on: February 08, 2011, 12:33:38 am
HI all,
I am using the Arduino API (version 022?) with an Uno board.  It has been working fine for days...
I was playing with interrupt timers and have somehow gotten the board into a mode where I can't upload a new app.

I had an app that was blinking an LED every 6 seconds.
Now I want to upload a simple loop/sleep app and I get the following error:
Code:
avrdude: ser_open(): can't open device "\\.\COM3": Access is denied.

I have tried rebooting my PC.
I have tried pressing the reset button for various durations, during reboot of the board, while it is running and even with no power applied same thing:
the green light goes on
the amber (L) and (TX) lights flicker and the API and Uno appear to work fine.  But then the LED on the Uno starts to blink every 6 seconds.
the (TX) amber light stays on
When this happens, the API's upload button turns orange and I get the above error.  The only way to clear the error is to unplug/plug the Uno.

Here is my new code (compiles fine):
Code:

void setup() {
  pinMode(7, OUTPUT);
}

// Main loop : empty but we have to have one...
void loop() {
  digitalWrite(7, HIGH);
  delay(1000);
  digitalWrite(7, LOW);
  delay(1000);
}

Thanks in advance for any help you can offer.
Pages: [1]