Show Posts
Pages: [1] 2 3 ... 841
1  International / Hardware / Re: ATmega328 standalone on: August 31, 2014, 04:35:02 pm
No leo ero serio e Astro ha confermato. ... secondo me è il buon heisen che intendeva dire questo ma non è stato compreso
 Se vuoi conferma collega il tester su Aref e poi esegui analogReference (default) smiley-wink
2  International / Hardware / Re: ATmega328 standalone on: August 31, 2014, 01:01:43 pm
Mo vi faccio incazzare io  smiley-yell usando i 5v di alimentazione del micro noni risula sia necessario collegarli all'Aref visto che con l'opzione default il collegamento all'AVcc è garantito. Inveve il c serve sempre. smiley-grin
3  Community / Bar Sport / Re: [OT ITA] Lo spamm bar on: August 30, 2014, 06:11:37 pm
Ricordo un film ma mi sfugge il titolo in cui il furgone dei giornali lanciava i pacchi ogni mattina all'edicolante stendendolo a terra come un birillo. Voglio dire che la consegna può anche farla per lancio senza rischiare muri e fili hv smiley-mr-green
4  International / Software / Re: Porta USB on: August 30, 2014, 03:41:35 pm
Cyb, nei miei pc+nb win ho notato che una volta assegnata la com virtuale ad un dispositivo resta sempre quella; in lab ho disponibile una sola porta usb e poichè vi collego a turno almeno una decina di dispositivi, tra Arduini e convertitori, su ognuno di essi ho segnato la COM virtuale specifica e non sbaglio mai un colpo; quindi il suo caso si giustifica col fatto che ha qualcos'altro che tende a farsi assegnare la COM4 oppure ha problemi sul convertitore USB dell'Arduino; a me è capitato pochi giorni fa u difetto del quarzo del convertitore MCP2200 e un problema molto simile al suo ce l'ho con l'Arduino Duemilanove da molto tempo, in genere mi basta premere un paio di RESET oppure scollegare e ricollegare il cavo, anche se è una cosa che non mi piace non sono mai andato a fondo della questione.
5  International / Hardware / Re: attivazione uscita 8 di arduino uno rev on: August 30, 2014, 02:57:54 pm
ma nid che fine ha fatto? smiley-eek-blue
comunque mi sa che l'ha azzeccata Brunello
6  International / Hardware / Re: Arduino mega 20mhz overclock on: August 30, 2014, 02:56:07 pm
Assolutamente è la cosa migliore, anzi direi d'obbligo, altrimenti ogni volta che vuoi riprogrammare quel micro sei costretto a ricaricarla, visto che è una configurazione unica tanto vale aggiungerla e ti togli il pensiero, ricordati di modificare il valore della memory flash disponibile smiley-wink
7  International / Hardware / Re: Arduino mega 20mhz overclock on: August 30, 2014, 10:08:28 am
Giusto ma loro dicono che non funziona sotto dos/windows. Non lo leggi ciò che scrivono? Mica è cinese!
8  International / Hardware / Re: Metodo per programamare AVR Atmel di un circuito Standalone on: August 30, 2014, 10:05:49 am
Ma la prima volta ti servirà comunque un chip col bootloader.
9  International / Hardware / Re: Metodo per programamare AVR Atmel di un circuito Standalone on: August 30, 2014, 06:54:29 am
Pensavo intendessi creare un circuito stand-alone mantenendo l'Arduino integro, se invece (così ho capito ora) jai intenzione di usare il micro originale dell'Arduino ovviamente nessun problema, immagino che sia il primo e ultimo progetto che realizzerai, non vorrai certo comprare un Arduino per ogni nuovo circuito?
10  International / Software / Re: Porta USB on: August 30, 2014, 04:36:22 am
Che modello di Arduino è?
Quando lo stacchi e fai il riavvio verifica, prima di ricollegarlo, se la porta COM4 non risulta già assegnata a qualcos'altro.
11  International / Hardware / Re: Metodo per programamare AVR Atmel di un circuito Standalone on: August 30, 2014, 01:26:17 am
Montarlo su Arduino UNO per la programmaizone però ti obbliga ad usare micro col bootloader precaricato, se li compri già pronti ti costano molto più di quelli vergini, se li compri vergini devi caricargli il bootloader via ISP, a quel punto tanto vale rinunciare al bootloader e caricare via ISP direttamente lo sketch
12  International / Generale / Re: Problema con LM386 on: August 29, 2014, 06:38:03 pm
Grazie Michele, il tuo schema funziona perfettamente.
Ho notato un paio di cose:
1) quando ruoto al 80% il potenziometro sento il massimo volume ma quando arrivo al 100% si abbassa quasi al minimo. Se ruoto nell'altro senso ovviamente diminuisce normalmente
al 99% col tentativo col quale hai collegato il positivo al potenziometro, hai rovinato la sezione resistiva terminale, sostituiscilo e vedrai che tutto si rimetterà a posto.

Quote
2) Ho notato che l'iphone ha impostato il volume massimo dell'uscita jack al 70% se provo a forzare il cursore del display dell'iphone oltre mi lampeggia di giallo (mai visto prima) come ad indicarmi di più non vado
probabilmente è un problema di saturazione del segnale rispetto all'ingresso del 386

Quote
3) L'audio è un po' distorto forse perché 1W è davvero poco.
devi vedere se l'altoparlante sopporta la potenza di 1 watt, vedendolo al volo sembrerebbe piccolo

Quote
Adesso me lo studio benissimo il tuo schema e cerco di capire la differenza con gli altri e dove sbagliavo, per cui ti sono davvero grato, ma mi consiglieresti un altro amplificatore ma di qualità superiore dove il volume sia qualcosa un tantino di più spinto partendo da un chip economico e realizzabile su breadboard che un domani posso collegare ad aruino uno?
Grazie mille
Non hai molto da studiare, io ho soltanto messo su breadboard il secondo schema elettrico che hai postato tu, non mi sono inventato nulla; purtroppo non ho conoscenze tali da tirar fuori sigle per consigliarti, mi pare di ricordare il TDA2020 o TDA2030, che sono molto più "tosti", ma anche i circuiti  non sono di immediata realizzazione, le pinature di questi IC non sono propriamente da breadboard.... cerca su google "audio power amplifier" dovrebbe uscire un mare di roba, ti guardi le potenze e i formati e scegli quello che fa per te.
13  International / Generale / Re: Problema con LM386 on: August 29, 2014, 06:27:01 pm
sei un pazzo smiley-eek-blue ma non ce l'hai un qualsiasi mp3 o una radiolina, fattela vendere dal cinese, non puoi rischiare di fare così tanto danno per un giocattolo.
Altra cosa, i collegamenti al jack sono esattamente come nell'immagine che hai messo tu all'inizio, le due sezioni verso la punta sono left e right, mentre il corpo interno, che in genere è la parte più lunga, è il GND; la precisazione è perché tu parli di "centrale", il centrale di quelle tre sezioni è il right (o il left); al potenziometro devi applicare una delle due sezioni verso la punta, al GND la sezione più lunga interna.
14  International / Generale / Re: Problema con LM386 on: August 29, 2014, 05:27:45 pm
Sì, 9V sono compatibili con l'LM386, ma vado a memoria, controlla il data-sheet per scrupolo.
Ma dall'i-phone stai prelevando il segnale mediante un cavo jack-jack maschio-maschio?
15  International / Generale / Re: Problema con LM386 on: August 29, 2014, 04:18:25 pm
OK, vedo che abbiamo recuperato attenzione e concentrazione smiley-wink
Quando parlo di "schema" parlo di "schema elettrico", le tue prove non le sto guardando proprio; ti dò chiarimenti sul disegno:
1 - è basato sul secondo schema elettrico che hai postato
2 - i valori sono quelli che leggo sullo schema e il C di bypass(pin 7) penso vada bene da 100nF
3 - i due cavi rosso e nero a sinistra collegano in parallelo le linee di alimentazione, sono obbligatori per replicare lo schema
4 - dal jack o quello che è devi prelevare il left oppure il right (uno a scelta) e collegarlo come nel disegno, senza condensatori o resistenze aggiuntive
5 - il polo "sleeve" va direttamente sulla linea di massa (blu)
6 - i condensatori elettrolitici sono due, la linea laterale indica il polo negativo (che poi corrisponde al pin più corto del C)
7 - cerca di replicare ESATTAMENTE quanto vedi e poi posta una foto, non fare scorciatoie o salti che sbagli e rendi nullo il mio lavoro

Ti avrò chiesto tre volte di verificare se l'uscita dell'i-phone funziona con un auricolare, l'hai fatta la prova? Devi avere certezza che al 386 arrivi qualcosa altrimenti ovvio che non ottieni niente. una volta collegato tutto applica 5V alla breadboard e ruota il potenziometro in entrambe le direzioni e vedi cosa succede. Se non funziona, dando per scontato che quello schema sia esatto, o non arriva segnale dall'i-phone o è guasto il 386.
Pages: [1] 2 3 ... 841