Show Posts
Pages: [1] 2 3
1  International / Generale / Re: Pilotare motore 3 Vdc / 300mA con driver L298N on: November 09, 2011, 01:44:02 pm
Uhm nono il pin 9 è alimentato 5v da arduino, ho appena controllato.
Ehmboh la settimana prossima lo ordino da futurashop senza la breakout tanto allargo i pin e lo inserisco nella breadboard.
Appena ho news ti faccio sapere, per ora grazie di cuore!
ciau
2  International / Generale / Re: Pilotare motore 3 Vdc / 300mA con driver L298N on: November 09, 2011, 01:01:43 pm
Ahahah almeno oggi la butto sul ridere e non ci resto più male smiley-kitty Mauro, è vero che sto avendo problemi con questo 298 però non mi dimentico di inserire la usb o di fare l'upload dello sketch senza errori smiley sono ad un passo più avanti dai primi esperimenti di accensione led, potenziometri etcetc però sono sempre agli inizi ovviamente.
Questa dritta sulla saldatura mi sarà tantissimoooo d'aiutooo, grazi davvero per questo e per il tempo che mi dedichi...quando stai partendo?mauhauha
Non funge nè col giro dx che col giro sx(ovviamente sono sicura che il motorino funziona, testato con la pila 9v)
Mi sà che devo prendere un'altro 298 peròòòò qui di riserva a riposo ho un l292 ma non trovo nulla a riguardo che mi possa ritornare utile.
3  International / Generale / Re: Pilotare motore 3 Vdc / 300mA con driver L298N on: November 09, 2011, 12:13:23 pm
Ciao MauroTec,
mmm lato arduino i collegamenti sono 7,6,5 ed ho solo questi collegati esclusi quelli dell'alimentazione di arduino.
arduino  -> l298n
Digital 5 -> Input1 (pin 7)
Digital 7 -> Input2 (pin 8 )
Digital 6 -> EnableA (pin3)
mmm questa foto è uscita bene allora, ci vedi molto chiaro smiley-kitty all'inizio del thread, che non ho aperto io, ho parlato della breakout  e del 298.
Le saldature le ho fatte io, e dopo ho buttato il saldatore cinese di 40w che non mi scaldava più la punta e cmq mi sa che ho fatto un pò di casini, però ho guardato con la lente e non vedo problemi, sono solo brutte da vedere ehehe!Ora ho una pistola saldante di 100w ma avevo già saldato pff pfff.
4  International / Generale / Re: Pilotare motore 3 Vdc / 300mA con driver L298N on: November 09, 2011, 09:18:16 am
Ecco una foto, forse qualcosina si capisce cmq ho inserito il testo sui cavi come info.
Ricapitolando
arduino  -> l298n
Digital 5 -> Input1 (pin 7)
Digital 7 -> Input2 (pin 8 )
Digital 6 -> EnableA (pin3)
5v         -> vls (pin9)
5v         -> vs (pin2)
gnd       -> gnd (pin 4)
gnd       -> csa(pin 5)
output1 e 2 sul motorino
Non sto facendo confusione con i pin è solo che ho l298n sulla break board
Tnx
5  International / Generale / Re: Pilotare motore 3 Vdc / 300mA con driver L298N on: November 08, 2011, 10:10:12 am
Niente ho collegato tutto come da vostre indicazioni ma il motorino non si muove, ho provato con lo sketch mio originale e quello corretto, ma nulla!
pfff pfff l298n ... un incubo ihihi!
Cosa posso testare per vedere se funge???
TnX4ALL
6  International / Generale / Re: Pilotare motore 3 Vdc / 300mA con driver L298N on: November 08, 2011, 07:57:49 am
Uhm vediamo un pò se ho capito bene, ora le foto dovrebbe essere più chiare riguardano solo i collegamenti dei diodi e di 5v e gnd di arduino.
I fili verde e giallo sono le uscite che vanno su l'output 1 e 2 dell' l298n
Tnx
7  International / Generale / Re: Configurare shield ethernet Arduino uno on: November 07, 2011, 06:24:21 pm
vabbhè il pirello è un pò stupido, prova a riavviarlo
8  International / Generale / Re: Configurare shield ethernet Arduino uno on: November 07, 2011, 06:18:23 pm
ma vedi nella sezione lan vero?
9  International / Generale / Re: Configurare shield ethernet Arduino uno on: November 07, 2011, 06:05:05 pm
nella cartella di arduino libraries ethernet
10  International / Generale / Re: Configurare shield ethernet Arduino uno on: November 07, 2011, 05:50:28 pm
Ehssi è come dice pitusso, http://www.nuelectronics.com/estore/?p=12 documentati qui e carico lo sketch che ti fa rispondere lo shield al ping
dai su che entro la mezzanotte deve rispondere al ping eheheh
11  International / Generale / Re: Configurare shield ethernet Arduino uno on: November 07, 2011, 05:44:54 pm
In effetti non c'è nessun adesivo con su scritto il mac address...mmm mi lascia un pò perplessa questa cosa, molto strano.
Cmq giusto per prova anche se non credo dipenda da questo, ma io nel mio sketch c'è l'ho scritto così, metti il byte ip scritto così senza lo spazio:
byte ip[] = { 192,168,1,5 };
correggilo senza lasciare lo spazio.
Poi vai in dos(cmd) e prova a pingare l'indirizzo ip dello shield cmq dimmi se linka
12  International / Generale / Re: Configurare shield ethernet Arduino uno on: November 07, 2011, 05:26:01 pm
Posta le foto di questo shield va di sopra e di sotto, è molto strana questa cosa...ma almeno ti linka?I led link sono accesi?
13  International / Generale / Re: Configurare shield ethernet Arduino uno on: November 07, 2011, 05:19:44 pm
un altra info...tu arduino lo hai collegato direttamente al pc o alle porte del router alice?
Perchè se lo colleghi direttamente al pc, hai bisogno di un cavo cross altrimenti non ti funge!
Al pirelli della alice lo puoi collegare con un cavo cat5 / cat6
14  International / Generale / Re: Configurare shield ethernet Arduino uno on: November 07, 2011, 05:10:54 pm
eheheh te lho già detto, stacca lo shield da arduino e guardaci sotto, dovrebbe esserci un adesivo con su scritto il mac address smiley
15  International / Generale / Re: Configurare shield ethernet Arduino uno on: November 07, 2011, 05:02:57 pm
Ehnnò se vedi le righe commentate ti dicono di toglierlo e metterci il tuo smiley
Quindi stacca lo shield segnati il mac address e poi ricopialo nel byte mac lasciando sempre lo 0x
vai prova che devo fungere smiley-wink
Pages: [1] 2 3