Show Posts
Pages: 1 2 [3] 4 5 6
31  International / Generale / Re: Problema con Ethernet shield e il MAC su Vodafone station on: January 30, 2012, 12:39:35 pm
Anche io lavoro con la vodafone station e non mi da nessun problema
L'unica cosa che ho fatto è stato settare l'indirizzo ip come statico.

Poi ricordo di aver avuto un problema all'inizio perchè avevo messo un indirizzo ip fuori dal range...so che è una cosa banale ma magari controlla anche tu.

Fammi sapere...magari passami lo sketch che lo provo anche io per vedere se ho gli stessi problemi..
32  International / Generale / Re: gestione luci con relè on: January 15, 2012, 07:59:38 am
Devi collegare assieme il neutro (filo blu) della lampadina e della spina e poi devi collegare le due fasi ai morsetti del contatto normalmente aperto del relè che nel tuo caso mi sembra che siano il centrale e quello in basso...Uno dei due contatti del relè (quello normalmente chiuso) rimane inutilizzato...
33  International / Generale / Re: Hardware debounce... necessito controllo. on: January 10, 2012, 11:47:10 am
Credo che sia normale che leggi sempre HIGH
A pulsante non premuto leggi la tensione ai capi del condensatore che si sara caricato a 5V.
Quando premi il pulsante invece colleghi l'input a massa e q quel punto leggi 0V.
L'unica cosa che mi lascia perplesso è che premendo il pulsante imponi che la tensione sulla capacita passi da 5V a 0V molto rapidamente e questo dovrebbe produrre un picco nella corrente di scarica...nn so se puo dare problemi...
34  International / Generale / Re: Fermare un ciclo For in uno Switch Case on: January 06, 2012, 09:17:59 am
ti rispondo un attimo di corsa ma purtroppo devo uscire...purtroppo nn conosco bene la libreria UDP ma a livello di logica potresti fare :

Code:
switch(var){
....
    case 'Q' : for(){
                    fai tutte le tue operazioni
                    if(è arrivato un nuovo pacchetto == true) break;
                 }
....
}

in serata poi rileggo il post per vedere come è andata...
35  International / Generale / Re: Ethernet shield classe Client on: December 28, 2011, 10:50:56 am
Di niente!!!
Felice di essere d'aiuto...se hai bisogno di altro chiedi pure...ho avuto a che fare anche io con un progettino di domotica...
Imbocca al lupo per la maturità...
36  International / Generale / Re: Ethernet shield classe Client on: December 28, 2011, 05:26:57 am
Ciao...nella 1.0 la classe Client nn si chiama piu Client ma EthernetClient...Cosi come tutte le altre classi legate al networking hanno cambiato nome...mi ci sono ritrovato anche io...Se vuoi la verifica vai in Sketch -> Import Library -> Ethernet....vedrai che le classi che importa si chiamano cosi...Se vuoi un consiglio scarica la v023 dell'IDE e vedrai che funziona tutto tranquillamente...Altrimenti nello sketch deve rinominare tutto con i nome corretti...
37  International / Hardware / Re: Alimentatore 12V on: December 26, 2011, 01:40:50 pm
ho fatto un po di misure, ho cambiato un po di prese e alla fine nn succede piu...è un po clamoroso perchè ora nn lo fa nemmeno piu nella presa iniziale (la maledetta smiley-razz)...il problema era quindi palesemente legato alle terre...Ora mi piacerebbe capire il perchè di questa cosa...C'è qualcuno che riesce a chiarirmi il perchè fisico di questa cosa???(studio elettronica e sono curioso) grazie
38  International / Hardware / Re: Alimentatore 12V on: December 26, 2011, 08:55:08 am
quindi devo controllare che la terra nelle prese sia correttamente collegata???Ma per quale motivo succede una cosa del genere???qualcuno me lo sa spiegare???
39  International / Hardware / Re: Alimentatore 12V on: December 26, 2011, 06:46:23 am
Quote
Dovresti provare a misuare la differeza di potenziale tra gnd del PC e alimentatore 12Volts, per avere scossettina dovrebbe essere sopra i 60 volts.

Gia fatto...misuro 115V alternati...
Gli alimentatori hanno entrambi una spina tripolare (sia quello da 12V che quello del mio portatile)...e entrambe le prese dovrebbero avere il filo di terra cmq controllo dopo pranzo...Dici che puo succedere???PErò anche collegando i pin di arduino vedo uno scintillio...LA cosa nn mi tranquillizza molto...Nel caso in cui io alimenti arduino e la scheda con lo stesso alimentatore nn dovrebbe piu succedere???

Quote
@ paolo: forse dovresti postare lo schema elettrico delle connessioni che hai effettuato, ciò che racconti indica chiaramente degli errori, non insistere perché ci rimetti l'Arduino.

Lo schema per il controllo dei rele è il piu semplice possibile : un transistor NPN con la base collegata al pin di arduino attraverso un partitore di tensione con una R da 220 e una da 1K...l'avvolgimento del relè è collegato al collettore del transistor con un diodo in antiparallelo...il transistor è un classico BC337 che regge fino a 800mA come corrente di collettore...Da datasheet l'avvolgimento del rele assorbe 20mA circa..come ultima cosa l'emettitore del transistor è a massa
40  International / Hardware / Re: Alimentatore 12V on: December 26, 2011, 05:27:14 am
Grazie ragazzi...io problemi che ho sono un po particolari e difficili da spiegare...in pratica volevo usare l'alimentatore a 12V per alimentare una schedina con dei rele e l'arduino...(ho fatto un po di conti sulle correnti e 2.5A sono sufficienti)...

La situazione è questa... collego l'alimentatore alla schedina rele e nel momento in cui vado a collegare la massa di arduino con quella della schedina si prende una scossettina...tento di spigarmi meglio...Schedina rele alimentata con l'alimentatore,arduino collegato con l'usb al pc e quindi alimentato da li, in questo caso andando a toccare la massa della schedina e la massa di arduino si sente corrente(in alternata tra l'altro)...quello che mi chiedo io è come sia possibile che toccando la massa di due circuiti indipendenti l'uno dall'altro si possa sentire una scossa...

Questo è il problema principale...dopo di che (secondo me per questo problema qui) è saltato in aria un transistor...
41  International / Hardware / Re: Alimentatore 12V on: December 25, 2011, 06:42:49 am
Se riesci a passarmele volentieri...Grazie
42  International / Hardware / Alimentatore 12V on: December 25, 2011, 06:29:58 am
Ragazzi ho trovato un alimentatore in casa e ho provato ad usarlo per alimentare arduino...mi da qualche problema e allora sono andato a cercare le caratteristiche su internet e ho trovato questo...

http://docs-europe.electrocomponents.com/webdocs/0f60/0900766b80f602f8.pdf

Ora quello che ho io da in uscita 12V 2,5A ma ha un ripple di 120mV che a me sembra una enormità possibile che sia quella la fonte di problemi???
43  International / Generale / Re: Buon Natale e Felice Anno Nuovo! on: December 24, 2011, 07:25:48 am
Auguri a tutti!!!
44  International / Generale / Re: Domanda sul C on: December 23, 2011, 12:06:08 pm
va bene in serata provo e poi ti so dire qualcosa...
Intanto che ci sono ti ringrazio anche...vedo che sei sempre molto disponibile e paziente smiley-razz...
45  International / Generale / Re: Domanda sul C on: December 23, 2011, 11:03:36 am
no allora...la Display7segment è nella cartella delle librerie mentre la DoubleDisplay si trova nella cartella degli sketch (Sketchbook)...dici che è quello il problema???Non penso che ci siano problemi...la tenevo nella cartella degli sketch perchè ancora nn è finita...
Pages: 1 2 [3] 4 5 6