Show Posts
Pages: [1] 2 3 ... 34
1  International / Hardware / Re: Motore stepper fuso? on: April 17, 2014, 02:58:13 am
Non credo avrò mai a che fare con così tante ore per adesso!! smiley-lol smiley-lol Comuqnue oggi provo con una batterie e vi so dire! Grazie di tutto fin'ora smiley-grin
2  International / Hardware / Re: Motore stepper fuso? on: April 15, 2014, 09:00:48 am
Sì, hai ragione, ma ha sempre funzionato anche senza smiley-lol infatti ora uso il 293D smiley-wink
3  International / Hardware / Re: Motore stepper fuso? on: April 14, 2014, 02:24:40 pm
Grazie per la risposta Uwe! Eh sì, in effetti sembra strano smiley-sweat Comunque, motore Nema 17, tensione 12V, circuito di pilotaggio quello di cui avevo allegato lo schema prima  smiley-wink
4  International / Hardware / Re: Motore stepper fuso? on: April 12, 2014, 08:40:50 am
Ho misurato, la reistenza degli avvolgimenti, è 2 ohm per uno e 2.2 per l'altro, tra avvolgimenti e cassa non c'è conduzione e niente puzza di plastica bruciata. A questo punto può essere un problema di alimentazione? Visto che gli stepper lavorano sulla corrente, e a 1A e 6v lavora bene, non si può alimentare a 1A a 12V? Grazie ancora per l'aiuto!  smiley-grin
5  International / Generale / Re: Alimentatore da laboratorio on: April 10, 2014, 07:12:47 am
Ok! e se l'alimentatore si sbagliasse e desse meno corrente? Per esempio con un motore passo passo, mentre un alimentatore non regolabile mi dà 0.8 A questo me ne da 0.5, e la differenza si sente eccome!
6  International / Generale / Re: Alimentatore da laboratorio on: April 09, 2014, 02:44:40 pm
Grazie per la risposta, ma quindi non c'è modo di regolare entarmabe?
7  International / Generale / Alimentatore da laboratorio on: April 09, 2014, 01:30:17 pm
Salve a tutti! Volevo delucidazioni riguardo l'utilizzo dell'alimentatore da laboratorio PS-305D. Me l'hanno regalato e mi sembrava buono, visto che avevo visto potenziometri sia per la tensione sia per la corrente, ma girando quelli della corrente i valori non variano minimamente... Su internet ho visto che per cambiare la corrente bisogna prima mandarlo in corto, è normale questo? Conoscete questo tipo di alimentatori?
Grazie, come sempre, dell'aiuto smiley-wink
P.s. Un'ultima cosa, il - e il gnd sono collegati da una palcchetta di ferro, perchè? è normale?
8  International / Generale / Re: filo gnd on: April 09, 2014, 01:27:04 pm
I fili di terra, i ground, vanno sempre collegati. E' la tensione di riferimento e deve essere "unificata. E' strano che funzioni senza! smiley-wink
9  International / Hardware / Re: Motore stepper fuso? on: April 09, 2014, 12:51:33 pm
No, non era molto caldo. Proverò quanto prima con una batteria, probabilmente il mio alimentatore non dà abbastanza corrente.
10  International / Hardware / Re: Motore stepper fuso? on: April 08, 2014, 12:14:08 am
Quello che pero non capisco è come mai prima funzionasse bene anche senza controllo di corrente. Se può in essere utile per aumentare la velocità sarei interessato al controllo della corrente. Sapete come farlo? Grazie  smiley-wink
11  International / Hardware / Re: Motore stepper fuso? on: April 06, 2014, 11:23:29 am
Ma perchè prima funzionava bene? Proverò quanto prima con una batteria o con un altro alimentatore.
12  International / Hardware / Re: Motore stepper fuso? on: April 06, 2014, 10:25:47 am
L'l297 era proprio per quello smiley-wink Provo con un full step e ti so dire.
EDIT: Provato anche in full step dual phase on ma niente... l'accoppiata alto voltaggio e tanti giri min non funziona per niente. Mi sembra inoltre di vedere una grossa perdita di coppia... smiley-fat
13  International / Hardware / Re: Motore stepper fuso? on: April 06, 2014, 10:22:02 am
Grazie per la risposta. Scusa per l297, un errore di digitazione, è un l293. Tengo comunque a precisare che prima con lo stesso circuito funzionava egregiamente e riposto un circuito più professionale fatto con eagle. Ho sbagliato qualche contatto?
14  International / Hardware / Re: Motore stepper fuso? on: April 06, 2014, 08:54:44 am
Schema quello classico dell'L293 (postatto sotto), scketch questo:
Code:
int motorPin1 = 10;
int motorPin2 = 11;
int motorPin3 = 12;
int motorPin4 = 13;
int delayTime = 5;

void setup() {
  pinMode(motorPin1, OUTPUT);
  pinMode(motorPin2, OUTPUT);
  pinMode(motorPin3, OUTPUT);
  pinMode(motorPin4, OUTPUT);
}

void loop() {
  digitalWrite(motorPin1, HIGH);
  digitalWrite(motorPin2, LOW);
  digitalWrite(motorPin3, LOW);
  digitalWrite(motorPin4, LOW);
  delay(delayTime);
  digitalWrite(motorPin1, LOW);
  digitalWrite(motorPin2, HIGH);
  digitalWrite(motorPin3, LOW);
  digitalWrite(motorPin4, LOW);
  delay(delayTime);
  digitalWrite(motorPin1, LOW);
  digitalWrite(motorPin2, LOW);
  digitalWrite(motorPin3, HIGH);
  digitalWrite(motorPin4, LOW);
  delay(delayTime);
  digitalWrite(motorPin1, LOW);
  digitalWrite(motorPin2, LOW);
  digitalWrite(motorPin3, LOW);
  digitalWrite(motorPin4, HIGH);
  delay(delayTime);
}

AGGIORNAMENTO: Ho cambiato l'integrato e sembra andare, ma quando salgo sopra i 9 V comincia a fare un sacco di rumore e verso i 13 va in stallo. Come mai succede visto che prima non mi aveva dato nessun problema??
15  International / Hardware / Re: Motore stepper fuso? on: April 05, 2014, 02:15:30 pm
Nono, comprato. Spero sia l'integrato e non il motore a questo punto..
Pages: [1] 2 3 ... 34