Show Posts
Pages: 1 ... 12 13 [14] 15 16 ... 35
196  Using Arduino / Sensors / Re: mpu6050 problem on: January 22, 2013, 02:49:08 pm
Ok. I've connected the pin 2 to the pin int of my board, but it doesn't change. smiley-roll-blue Howerever, now I want to try the "teapot" sketch, but I don't find the toxi libraries. Have you a dowload link for it?
Code:
import toxi.geom.*;
import toxi.processing.*;
197  Using Arduino / Sensors / Re: mpu6050 problem on: January 22, 2013, 01:17:23 pm
Ok. I've modified the source and now Arduino can find my board, but it does the same value that the first sketch did... How is this possible?
Code:
Initializing I2C devices...
Testing device connections...
MPU6050 connection successful
a/g: -4488 244 17336 236 -134 -76
a/g: -4476 252 17184 259 -146 -78
a/g: -4436 368 17380 254 -162 -84
a/g: -4496 336 17364 250 -173 -62
a/g: -4544 200 17308 261 -189 -68
198  Using Arduino / Sensors / Re: mpu6050 problem on: January 22, 2013, 12:44:58 pm
Thank you so much for this reply. Also I have emailed to jeff, but he did't replie me yet. ok. let's try smiley-lol
199  Using Arduino / Sensors / Re: mpu6050 problem on: January 22, 2013, 10:45:25 am
Ok thank you. But how can I change the i2c address in 0x69?
200  International / Hardware / Re: mpu 6050 on: January 21, 2013, 08:51:21 am
Esatto. io vorrei dare come "0" la posizione in cui è sulla mia scrivania... Per me va settato in qualche modo, anche se non ho idea di quale sia il modo...
201  Using Arduino / Sensors / Re: mpu6050 problem on: January 21, 2013, 08:50:38 am
Hi everyone! I've just solved my problem! I've ran the i2c scanner and I have found like i2c address 0x69. Now I' m reading on the serial monitor this
Code:
MPU-6050
Read accel, temp and gyro, error = 0
accel x,y,z: -2120, 108, 17856
temperature: 20.224 degrees Celsius
gyro x,y,z : 236, -164, -98,
I don't understand what this values mean... The acceleration on the z axis should't be 1? And also the other values are strange... Maybe I need to calibrate the sensor. How can I do this?
202  International / Hardware / mpu 6050 on: January 20, 2013, 08:23:25 am
Ciao a tutti! Mi è arrivato da poco il sensore della invertsense mpu 6050 comprendente un accelerometro un giroscopio e un termometro. Sono riuscito a collegarlo con arduino leggendo i valori raw e stampandoli a seriale. Ora ricevo questo:
Code:
MPU-6050
Read accel, temp and gyro, error = 0
accel x,y,z: -2120, 108, 17856
temperature: 20.224 degrees Celsius
gyro x,y,z : 236, -164, -98,
quando è orizzontale sul tavolo.
Mi potete cortesemente spiegare questi valori? Allora, la temperatura credo di sapere cosè smiley-yell, ma, per esempio, l'accelerazione da è fermo non dovrebbe essere pari a 0? e nel gyro il -98 non dovrebbe essere 0 o 180? Magari bisogna calibrare il sensore...
203  Using Arduino / Sensors / Re: current measurement on: January 15, 2013, 06:48:20 am
Hello. There are a chip made by allegro that measure current and has an analog signal like output. But there is another cheaper method: you use a 1 ohm resistor and next you read the voltage. 1=y/x y is the voltage and x the current. With this you use the ohm law. Bye
204  Using Arduino / Sensors / Re: mpu6050 problem on: January 15, 2013, 06:44:02 am
Also with this code the problem is the same: the arduino doesn't recognize the board... I'm start thinking that the board is broken... smiley-roll  Maybe I fused it when I soldered the pin header on the board. Is possible that I heat up too much the mpu? Or maybe that I touched one of the resistor whit the welding and I broke it? Later I' ll do the i2c scanner.
205  Using Arduino / Sensors / Re: mpu6050 problem on: January 14, 2013, 04:02:56 pm
Ok, now I've understood, thank you. I'll run the i2c tester as fast asse I can.  smiley
206  Using Arduino / Sensors / Re: mpu6050 problem on: January 14, 2013, 11:41:28 am
So I must solder the resistor on the board? I can't pur them on the breadboard?
207  Using Arduino / Sensors / Re: mpu6050 problem on: January 14, 2013, 08:26:38 am
Mmmmh... What does " on the component side" mean? Do i connect the resistors on the breadboard?
208  Using Arduino / Sensors / Re: mpu6050 problem on: January 13, 2013, 01:44:54 pm
Thank you for this so fast replay. I found a back image of the sensor Board. I don't see any resistor and you?
209  Using Arduino / Sensors / mpu6050 problem on: January 13, 2013, 11:50:02 am
hi everyone! I have a problem with the gyroscope-accelerometer MPU6050. I've just bought it from ebay: http://www.ebay.it/itm/280791436843?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1439.l2649#ht_1890wt_1037 it's the drotech brekout board. When it arrived i soldered 6 pin headers on the board and next i put it on a bread board. I've connected +5v and the gnd pin to arduino, the SDA pin to A4 arduino's pin and the SCL to A5 arduino's pin. I've also uploated this sketch on the board http://playground.arduino.cc/Main/MPU-6050 but it send on the serial monitor only this
Code:
MPU-6050
Read accel, temp and gyro, error = 2
accel x,y,z: 747, 512, 12545
temperature: 24.459 degrees Celsius
gyro x,y,z : 520, 4557, 396,

MPU-6050
Read accel, temp and gyro, error = 2
accel x,y,z: -5374, 2, 305
temperature: 37.212 degrees Celsius
gyro x,y,z : 2050, -13039, -29695,

I hope you can understand the problem and help me to solve it! smiley-sad-blue
210  International / Generale / Re: fiera MODENA MAKERS 19-20 gennaio on: January 13, 2013, 06:59:57 am
Ci sarò di sicuro visto che sono di Modena! La expo di modena è un ritrovo fisso invernale per me smiley-lol
Pages: 1 ... 12 13 [14] 15 16 ... 35