Show Posts
Pages: [1] 2
1  International / Français / Re: Mesure de fréquence avec Arduino (timers ?) on: September 19, 2013, 11:11:32 am
Merci pour votre aide, je vais regarder tout cela !
2  International / Français / Mesure de fréquence avec Arduino (timers ?) on: September 18, 2013, 07:49:42 am
Bonjour à tous,

Je voudrais mesurer avec un module Arduino la fréquence des impulsions d'un signal TTL.
Cette fréquence correspond à la vitesse de rotation d'un moteur.
La fréquence à mesurer est < à 300 Hz.
Comment mesurer une fréquence avec Arduino ?
j'ai déjà fait un compteur de vitesse de vélo qui marchait en interruption, à chaque IT , j'incrémentais un compteur mais la fréquence était nettement plus basse.
Ici je pensais plutôt utiliser les timers du microcontrôleur si c'est possible, genre lire l'état du timer toutes les secondes.

Quelqu'un a déjà pratiqué ?
Des idées ? Des astuces? Des tuyaux?
Faites-moi savoir, merci.

Louis
3  International / Français / Re: Problème avec le shield arduino si4735 Recepteur am/fm on: July 09, 2013, 12:42:32 am
Bienvenue sur le forum Arnaud !
...et bonne suite dans tes projets.
Louis
4  International / Français / Re: suiveur solaire on: February 06, 2013, 05:19:02 pm
Salut,

J'avais moi aussi réfléchi à ce pb en utilisant le panneau comme capteur :  la tension fournie par le panneau est fonction de l'éclairement du panneau !
C'est la solution la plus économique !
Comme on l'a dit précedement, le soleil se lève  tous les matins à l'est et se couche à l'ouest. Il va toujours dans le même sens !
Voilà à quel algo j'étais arrivé :
Toutes les 20 minutes :
Tourner le panneau d'Est en Ouest jusqu'à ce que la tension soit décroissante.
S’arrêter
Recommencer
La nuit (tension inférieure à un certain seuil) retourner à la position initiale (à fond à l'est).

Ainsi, si la tension est décroissante, cela indique que tu as dépassé le soleil. Inutile de revenir en arrière, il te rattrapera de toute façon !
Ca devrait marcher même en cas de nuage si le nuage est plus lent que ton mouvement de ton panneau
Il faut prévoir des butées logicielles : éviter des trop grosses courses du panneau.
Bon courage !
5  International / Français / Re: Aduino Ethernet Qt application on: January 24, 2013, 11:54:10 am
Bonjour,

Je ne vois pas trop l’intérêt de passer par une appli C++.
L'idéal pour les systèmes équipés d'interface webserver c'est de les piloter simplement à partir d'un navigateur ! Non ?

P.S : je crois qu'on se connait ;-)
6  International / Français / Re: DCF77 ? Quelqu'un utilise ? on: January 11, 2013, 01:11:10 am
Bonjour à tous,

J'ai réussi à trouver du temps pour retravailler sur ce projet. J'ai réussi à faire marcher le DCF77 avec le pack logiciel dont je vous ait parlé : http://playground.arduino.cc/Code/DCF77

L'orientation de l'antenne est tres important. Pour l'orienter, il faut chercher le bon signal au scope ou à l'aide du fichier DCFPulseLength fourni.

Le signal DCF77 en sortie du module est normalement comme cela :
___I'''''''''''''''''I_________________I''''''''''''''''''''''''I______________

Entre 2 fronts montants : 1s
Durée Etat haut : 100 ou 200 ms (0 ou 1).

J'ai donc tourné mon antenne jusqu'à ce que DCFPulseLength me fournisse des infos corrects :
Cycle = 1000 et Pulse=100 ou 200
La led 13 doit clignoter à chaque seconde !

Comme indiqué dans l'en-tête de DCFPulseLength, j'ai modifié la variable DCFSplitTime et je l'ait réglé à 150 (la moyenne entre 100 et 200).
Une fois que ces paramètres sont corrects, sans bouger l'antenne, j'ai essayé d'autres programmes comme InternalClockSync : Ca se synchronise en 2 ou 3 minutes !

J'étais super content quand j'ai vu le truc se mettre à l'heure tout seul !
Encore merci pour vos conseils !

Louis
7  International / Français / Re: DCF77 ? Quelqu'un utilise ? on: December 17, 2012, 05:53:51 am
Merci pour tous vos conseils.
je vais essayer de mettre en place l'oscillo avec processing.
Je vous tiens au courant.
Merci encore pour votre rapidité.
Louis
8  International / Français / DCF77 ? Quelqu'un utilise ? on: December 16, 2012, 04:52:38 pm
Bonjour à tous,

J'essaye de faire fonctionner un module DCF77 de Conrad avec un Arduino uno.
Je suis géographiquement un peu loin de Francfort. je suis dans le sud ouest à Brive-la-gaillarde.
J'ai essayé les programmes disponibles ici :
http://playground.arduino.cc/Code/DCF77

Impossible d'avoir l'heure ! En utilisant les exemples, j'ai l'impression que le signal est complètement faux !
De plus mon scope est HS et seul le moniteur série me permet de déboguer !
Est-ce que quelqu'un a déjà fait tourner ce hard (module conrad) et ces softs ?
Si oui, merci de me donner des astuces !

merci d'avance.

9  International / Français / Re: Arduino uno R3 on: November 06, 2012, 04:47:37 am
Bonjour,

Je ne sais pas si c'est la cause de ton pb, mais personnellement, j'ai souvent rencontré des pb avec Arduino R3. je ne sais pas quelle version d'Arduino tu utilise mais pour le R3, il faut impérativement installer les drivers de la version 0.23 ou 1.X. Souvent galéré avec version 0.22 et arduino R.3. Remarque : rien ne t'empêche d'utiliser les drivers de 1.0 et de travailler et d'uploader avec 0.22. ça marche, je bosse comme ça.
10  International / Français / Re: Minibloq qui pratique ? on: October 14, 2012, 12:56:45 pm
Bonjour à tous,

je me permets de réagir à ce post.
J'ai téléchargé minibloq pour voir ce que ca fait.
Ca m'a l'air pas mal mais je me demande si c'est très efficace pour faire des choses un peu complexes.
Y a t'il beaucoup de gens qui l'utilisent ?
Quel est votre avis ?
Merci de vos réponses.
11  Using Arduino / Networking, Protocols, and Devices / Re: Xbee talk only after downloading arduino on: June 16, 2012, 05:38:06 pm
Hello,

I found a good solution, not the best solution but a good solution.
In the setup part, before and after initialising the UART, I add a delay of 1.5s.
like this :

delay(1500);
Serial.begin(9600);
delay(1500);

It take 3s to initialize the system, but it works everytimes ! Xbee transmit data from arduino !And the data on XCTU on the computer are OK !

Thanks

If someone has another solution, say to me !

Louis !
12  International / Français / Re: Bug curieux (démarrage) avec arduino uno + Shield Xbee on: June 16, 2012, 05:32:48 pm
Bonjour à tous,

J'ai fini par trouver une solution. c'est pas la meilleure mais elle semble marcher à tous les coups.
Dans le setup, au niveau de l'initialisation de la liaison série, je fait :

delay(1500);
Serial.begin(9600);
delay(1500);

Ca fonctionne mais ça fait 3 secondes pour démarrer mon Arduino.
Ca ira pour mes exigences, mais c'est pas le top !
Je garde cette solution.
Si quelqu'un à mieux comme solution, je suis preneur.
J'ai essayé de diminuer un peu les temps mais ça bugue si je descend en dessous (1s et 1s).
j'ai pas vraiment réussi à trouver mieux !
a+

Louis
13  Using Arduino / Networking, Protocols, and Devices / Re: Xbee talk only after downloading arduino on: June 16, 2012, 10:33:08 am
Hello,

I foundnd an other way to solve the problem : I start the Arduino and the Xbee Shield without the Tx jumper, and 2 or 3s, I place it. and it's OK.
But it's not a definitive solution !
Someone can help me ?
Thanks 
14  International / Français / Re: Bug curieux (démarrage) avec arduino uno + Shield Xbee on: June 16, 2012, 09:42:17 am
Bonjour,

Je n'ai avec moi qu'un vieux scope analogique, je vois passer à la mise sous tension un plateau transitoire autour de 2V qui dure environ 1 s. Et je pense que c'est ça qui plante le Xbee (cette tension est divisée car le xbee est alimenté en 3V). Mais en effet, je viens de le vérifier, si le Xbee n'est pas connecté ce phénomène n'existe pas ! bizarre !
Pb d'interface électrique ?
15  Using Arduino / Networking, Protocols, and Devices / Re: Xbee talk only after downloading arduino on: June 16, 2012, 06:36:51 am
Hi,

I'm still working on this bug and I think it's because Arduino signal on Tx line is bad during power up of arduino. this cause the xbee to go in a weird mode and it can't transmit !
Someone know this problem !
What can i do to solve it ?

thanks
Pages: [1] 2