Show Posts
Pages: [1] 2 3 ... 6
1  Using Arduino / Networking, Protocols, and Devices / Re: Firefox shows HTML Code for the webpage and not the actual page on: June 08, 2014, 05:39:12 am
By comparing the problem code I had copied from example in chapter 17 of "Beginning Arduino 2nd edition by McRoberts"
to the Arduino Example in "Examples\Ethernet\WebServer" I discovered the following:   

//client.println("HTTP/1.1 200 OK\n"); // Standard HTTP response // no good with Firefox
client.println("HTTP/1.1 200 OK"); // Standard HTTP response

Nope this is useful for others doing a web search on the topic.

Regards  smiley smiley smiley
2  Using Arduino / Networking, Protocols, and Devices / Firefox shows HTML Code for the webpage and not the actual page on: June 08, 2014, 04:38:13 am
Have a Uno connected to a Ethernet shield and two temperature sensors which connect to my home router. The Arduino is hosting a basic web page.
Using Internet Explorer or Chrome shows the web page as expected BUT with Firefox Browser (latest version 30.0) it just shows the html code.
Is there any special setup required in the arduino code or in Firefox to overcome this problem ?
 
3  Community / Exhibition / Gallery / Re: My arduino projects on: May 26, 2014, 06:53:30 am
I've looked at a couple of your youtubes & are impressed but can't see any link to the code or are you expecting members to try & read of screen as it flicks past.
Regards
4  Topics / Home Automation and Networked Objects / Re: arduino - android communication on: April 06, 2014, 02:29:21 am
drmpf
Can I use my own bluetooth module on a protoboard & connect that to UNO? Can't see any mention of a wiring schematic. Obviously I don't want to need to use your specified bluetooth shield if I have my own existing bluetooth components.
Regards
5  Using Arduino / Networking, Protocols, and Devices / Re: Arduino Web Server Code Publication on: March 23, 2014, 06:16:18 am
Excellent example - now to study your code .....
Thanks
6  Using Arduino / Project Guidance / Does Pro Micro work with I2C ? on: March 17, 2014, 07:04:12 am
Does the Pro Micro board work with I2C because unlike the UNO it does not have A4 & A5 for SDA and SCL lines.
Thanks for any guidance
7  Development / Other Software Development / IDE Upgrade ??? Maybe use Notepad++ but How on: March 10, 2014, 02:50:46 am
is there any intention to upgrade the existing arduino IDE. Has anybody seen a tutorial on adapting Notepad++ as the IDE & are there any Notepad++plugins to manage the uploading, control panel etc.
Regards
8  Using Arduino / Installation & Troubleshooting / SOLVED Re: IDE now slow to load & respond on: February 05, 2014, 10:21:43 pm
This morning with a clear mind I thought that I would back track on some of my earlier diagnosis of last night.

I've reinstalled Blue Terminal (Bluetooth terminal program - free version available at http://esdn.com.au/Products/Blue%20Terminal.html   ) and then discovered that I can "bring on the fault / clear the fault" just by plugging & removing my USB Bluetooth dongle as recommended by spycatcher2k.

Cheers
9  Using Arduino / Installation & Troubleshooting / SOLVED Re: IDE now slow to load & respond on: February 05, 2014, 09:26:29 am
Followed advice from posts:
- Clearing out JAVA apps made no difference but is something to look at whenever there is problems.
- Looked for Bluetooth posibilities - remember a week ago installed an app Blue Terminal but this did nothing BUT then I tried removing a BlueTooth dongle that has been plugged into a spare USB port for a long time & PRESTO ..... I can now run the IDE with correct / expected response times.

I'm in Australia & was impressed to get a response from Sweden within 7 minutes then another promptly from Scotland..... Thanks guys
10  Using Arduino / Installation & Troubleshooting / IDE now slow to load & respond on: February 05, 2014, 07:14:22 am
For the last week I'm finding the IDE (1.0.5) very slow to load up and even slower to have clicks on the toolbar responding.
I'm running Win 7.
I have started PC in Windows Safe Mode to prevent other programs loading & the problems goes away. Obviously there is another startup program causing the problem.

Question - Has any one else experienced this problem & if so have you found the cause?

Thanks
 
11  Community / Exhibition / Gallery / Re: ThingSpeak Live Chart, multi channel, second axis, historical data, csv export on: January 27, 2014, 04:11:11 am
At the risk of asking too much it would be of great assistance to a lot of readers of this post if you could briefly describe in list form the steps to be mastered to produce graphs like your excellent example. Perhaps something that would show how to plot data from say two analog inputs, for the enlightenment of all. 
Regards
12  Using Arduino / Networking, Protocols, and Devices / Re: Arduino Ethernet Shield MAC on: January 26, 2014, 11:47:40 pm
Thanks Nick that Freetronics.com is an excellent link.
Happy Aussie day for yesterday
13  Using Arduino / Networking, Protocols, and Devices / Arduino Ethernet Shield MAC on: January 26, 2014, 09:54:39 pm
My ethernet shield has no sticker on the back but work ok with networking sketches.

Q1)  Are all Arduino Shields manufactured with a MAC of DE AD BE EF FE ED.  I thought that the chip manufacturer had a different   MAC for every chip produced.
Q2)  Is there a sketch to read back a shield's MAC?

Thanks in anticipation
14  Community / Exhibition / Gallery / Re: ThingSpeak Live Chart, multi channel, second axis, historical data, csv export on: January 26, 2014, 02:51:33 am
Are you awae of a tutorial in interfacing Arduino to HighStock ?
15  Using Arduino / Installation & Troubleshooting / Re: Need driver for SparkFun ProMicro 5V on: December 19, 2013, 08:14:23 am
Found later valuable info here:

https://learn.sparkfun.com/tutorials/pro-micro--fio-v3-hookup-guide/installing-windows

Enjoy
Pages: [1] 2 3 ... 6