Show Posts
Pages: 1 ... 59 60 [61] 62
901  International / Generale / Re: PWM non funzionante su pin 9 e 10 on: October 03, 2011, 04:06:14 am
Grazie leo72, ma è proprio quello che ho fatto, soltanto che nei pin 9 e 10 il fading non lo fà, negli altri pin si.
A questo punto penso si possa trattare di un chip difettoso e del relativo venditore dello stesso DISONESTO.
Attendo i nuovi 328 per provare a sostituirlo e vedere come si comporta.
902  International / Generale / Re: Problema IDE Arduino on: October 03, 2011, 04:03:17 am
... sinceramente sai che non l'ho riprovata su Windows, anche xkè avevo cancellato la virtualizzazione che mi scadeva tra 30 giorni l'os.

fammi sapere così aggiustiamo, intanto grazie.

Allora, ho trovato  l'inghippo.
Il problema come pensavo infatti è nei path.
Più per la precisione del path della libreria ArduinoCore del progetto template.
Quindi per risolvere il problema procedere come segue:

  • Da Eclipse indigo selezionare il progetto ArduinoTemplate, clickare con il tasto destro e selezionare 'Properties' (ultima voce)

  • Dal menu ad albero di sinistra selezionare C/C++ Build -> Settings

  • A questo punto nel tab 'Tool Settings'  selezionare AVR C++ Linker -> Libraries

  • Nel riquadro bianco in basso 'Libraries Path (-L)' selezionare la riga contenente ${workspace_loc}/${ProjName} e premere il pulsante modifica (Foglio con lapis)

  • A questo punto modificare il percorso aggiungendo sia in testa che in coda il carattere di DOPPIOAPICE (per intenderci SHIFT+2) in maniera tale da ottenere esattamente il seguente path:

    "${workspace_loc}/${ProjName}"

  • Clickare su 'Apply' e poi Ok

  • Eseguire Clean, refresh e ricompilare il progetto come indicato nella guida.

Spero di essere stato d'aiuto.
Saluti.

903  International / Generale / Re: Problema IDE Arduino on: October 02, 2011, 04:02:55 pm

Ciao Niki77, se hai riscontrato su Windows qualche problema, risolto o no, segnalalo qui che lo aggiungo alla guida che ho scritto, non sò se l'hai letta, fammi sapere anche un tuo parere in merito.

Al momento stò valutando anche l'opzione di usare Netbeans...

Lesto, che distro linux usi? così dò una vista che io uso solo Suse e Ubuntu da qualche anno.

Ciao, venerdi sera ho velocemente fatto una prova utilizzando la tua guida passo passo su una macchina virtuale vergine con S.O. windows xp sp3.
Utilizzando alla lettera le tue istruzioni e gli stessi pacchetti linkati da te (per eclipse la versione Indigo) ho notato solo che dà un problema alla compilazione finale del template.
Immagino che manchi un riferimento a qualche percorso.
Domattina appena ho un minuto lo rivedo e lo notifico.

Comunque, ottimo lavoro, una mano santa per chì non è molto esperto di eclipse e makefile varii.
Bravo.
904  International / Generale / Re: DISPONIBILI ATMEGA 328 on: September 30, 2011, 09:15:13 am
Ti ho mandato un messaggio privato in merito, attendo risposta.
905  International / Generale / Re: PWM non funzionante su pin 9 e 10 on: September 30, 2011, 07:54:45 am
Non ho provato perchè ho scoperto che non avrei potuto riscrivere il bootloader sul nuovo chip senza fare collegamenti esterni.
Mi sto preparando proprio in questi giorni una shield per programmare chip vergini con la mia uno.
Abbiate pietà, vengo dal mondo Microchip, non ho molte materiale per gli avr.
906  International / Generale / Re: Problema IDE Arduino on: September 30, 2011, 07:40:35 am
Anche io utilizzo correttamente eclipse da tempo per programmare arduino, e sinceramente molti problemi notificati da voi non li ho avuti.
Tempo fà, almeno un paio di mesi fà, seguivo la cosa in un altro post, molto interessante, dove mi ero offerto di aiutare quanti avessero riscontrato problemi nella messa in opera del tutto.
Se serve qualcosa sono disponibile, ma solo per installazioni di Eclipse su windows.
Saluti.
907  International / Generale / Re: fare un picolo trasformatore on: September 30, 2011, 07:30:39 am
In realtà non ti serve un trasformatore ma un semplice regolatore di tensione.
Se il servo in questione non ha bisogno di tanta corrente (immagino un servo da modellismo) va benissimo un lm7805 con un paio di condensatori elettrolitici(in rete trovi milioni di schemi es: http://www.febat.com/Elettronica/Elettronica_regolatori_tensione_fissa.html).
Oppure potresti utilizzare il regolatore interno della shceda arduino, però occhio perchè la corrente prelevabile non è molta , e io te lo sconsiglio in tutti i casi.
Saluti.
908  International / Generale / PWM non funzionante su pin 9 e 10 on: September 30, 2011, 07:26:40 am
Buongiorno a tutti,

Tempo fà lavorando ad un progetto di un regolatore di velocità per motore in continua scoprii che la mia scheda arduino uno mantenendo tutte le impostazioni di default non pilotava correttamente i pin 9 e 10 in modalità pwm (analogwrite)
Avevo effettuato i test connettendo correttamente un led su tali pin.

Il comportamento era il seguente : 

valori analogwrite da 0 a 254 led spento
valore analogwrite 255 led acceso

Ma di fading nessuna traccia.
Lo stesso codice sugli altri pin pwn invece risultava funzionare correttamente.
Ho trovato anche un video sulla rete di un altro utente brasiliano con lo stesso identico problema, ma non ho trovato indicata alcuna soluzione

http://youtu.be/4w2ULBLwUdE

I pin 9 e 10 per il pwm utilizzano se non sbaglio il timer 1 che ha come impostazione di prescaler di default lo stesso valore di timer 2 che controlla il pwm nei pin 11 e 3 che però risultano funzionare correttamente.

Qualcuno ha avuto lo stesso problema?

Saluti.

909  International / Generale / Re: Eclipse e Arduino on: August 01, 2011, 07:24:39 am
Buongiorno a tutti.

Mi intrometto perchè magari interessa.
Io ho installato ed utilizzo regolarmente eclipse per sviluppare su arduino.

Al momento non ho tempo fisico per fare una guida dettagliata, ma se mi dite quali sono i problemi specifici vi aiuto volentieri.
910  International / Generale / Re: Controllare motore con PWM on: August 01, 2011, 03:00:11 am
Lungi da me pensare che possano esistere macchine perfette, e capisco bene che qualche problemino ci possa pure stare.
La mia era più una affermazione di stile goliardico che altro ,  non ricordo nemmeno di aver imprecato verso qualcuno una volta scoperto il problema!! smiley-grin

Ritengo che il bootloader possa entrarci anche poco con questa storia...
Ritengo che il problema possa risiedere in qualche libreria di quelle di arduino.
Comunque non mancherò di riprogrammare anche il bootloader, magari risolvo pure il problema che spesso dopo un pò che la scheda è avviata, non riesce a scrivere il software inquanto dice che la seriale è occupata (nel sw non viene nemmeno inizializzata la seriale!)
Grazie dei consigli.
911  International / Generale / Re: Controllare motore con PWM on: August 01, 2011, 02:35:40 am
Piccolo aggiornamento.
In realtà non è il mio schema a non funzionare , ma i pin 9 e 10 di arduino in modalità PWM!
Infatti spostando il controllo al pin 3 (ma anche uno degli altri ad esclusione del 9 e del 10) funziona tutto regolarmente.
Ho trovato alcuni articoli in giro di gente che ha avuto gli stessi problemi, e pare che alcuni abbiano individuato la causa nel settaggio del prescaler del timer2.
Appena ho un pò di tempo verifico.

Ed io che pensavo che arduino fosse tutto esente da questi tipi di problemi !
Del resto se volevo continuare ad impazzire con prescaler e configurazione dei registri avrei potuto continuare tranquillamente ad usare i miei amati PIC !
912  International / Generale / Re: Controllare motore con PWM on: July 29, 2011, 08:32:07 am
Difatto il TIP122 fa parte della stessa famiglia, 120-121-122 , tutti darlinghton con caratteristiche leggermente diverse, tipo tensione collettore-base e collettore - emettitore più alti ( a salire da 60v del 120 a 100v del 122).
Hanno però tutti un hfe di 1000, quindi mi pare abbastanza strano che la resistenza da 1k non fornisca sufficiente corrente ... però tentar non nuoce.

E' che non vorrei 'spillare' troppo alle uscite del microcontrollore....

Potrei tentare a sostituire sennò il motore con un altro carico, tipo un led ( con opportuna resistenza ).
Delirio o può essere un test attendibile?
913  International / Generale / Re: Controllare motore con PWM on: July 29, 2011, 08:21:57 am
Ma veramente lo schema che ho usato è quello sopra.
Il tip122 è un transistor darlington se non sbaglio.
Nessun altro componente al di fuori dello schema sopra ( e del diodo ) è stato utilizzato .
914  International / Generale / Re: Controllare motore con PWM on: July 29, 2011, 08:11:07 am
Il motore è un piccolo motore elettrico ricavato da un auto radiocomandata (molto vecchia).
Non è un brushless, ha solo 2 contatti, ergo ne ho dedotto possa essere il classico motore a spazzole.

915  International / Generale / Re: Controllare motore con PWM on: July 29, 2011, 07:11:38 am
Ho pensato che se fosse collegato male il diodo ( cosa improbabile ) il motore non  avrebbe dovuto comunque girare neanche al massimo della velocità (ovvero con in base il +5 dell'arduino).
Comunque il diodo sta posto in parallelo al motore con l'anodo lato collettore, catodo lato +vcc.

P.S. le masse delle 2 alimentazioni (arduino e vcc motore) sono in comune.
Pages: 1 ... 59 60 [61] 62