Show Posts
Pages: 1 2 3 [4] 5 6 ... 13
46  Using Arduino / Networking, Protocols, and Devices / Re: I recall seeing an XBee socket device that used SPI. Can't remember what it was. on: November 14, 2012, 05:11:46 am
That would be an Xbee wifi module
47  Using Arduino / Programming Questions / Re: programming without bootloader on: November 05, 2012, 06:17:11 am
I am unsure of the current settings used and the ones that I would need. I am very new to this so any help would be appreciated. Thanks
48  Using Arduino / Programming Questions / Re: programming without bootloader on: November 02, 2012, 10:07:11 am
Sorry I thought my last post stalled a little.

My code seems to only work if it is uploaded onto optiboot. Not directly. What should the fuses be for an ATMega2560V running at 8Mhz on 3.3V?
49  Using Arduino / Programming Questions / Burning code straight to Arduino on: November 01, 2012, 08:32:39 pm
Hi,
How can I burn code directly to an arduinomwithout a boot loader. I have an AVR ISP mk2 to program with. Is there anything I need to add to my code??
50  Using Arduino / Programming Questions / Re: Code works on boot loader but not when directly programmed on: October 24, 2012, 05:09:58 am
I am using the Arduino IDE Version 1.0
I am not entirely sure what the fuse settings are.  How would I check them?
I also always get the following error when I upload to it. I am using an ATMega2560V running @8Mhz 3.3v
Code:
avrdude: verification error, first mismatch at byte 0x0000
         0xcf != 0x0f
avrdude: verification error; content mismatch
51  Using Arduino / Programming Questions / Re: Code works on boot loader but not when directly programmed on: October 20, 2012, 03:53:13 pm
How would I carry that out?
I thought it was just a case of having something working with the bootloader and then going upload using programmer
52  Using Arduino / Programming Questions / Code works on boot loader but not when directly programmed on: October 20, 2012, 03:20:06 pm
Hi,
I have some custom PCBs that I am trying to program.  They work fine if I burn the bootloader first.  However if I burn the program straight on they don't work at all.  I am using an AVRISP mkii.  This makes no sense to me.  Someone care to explain what may be causing this?  I am using the uplaod using programmer feature.
53  Using Arduino / Displays / Re: Adafruit ST7565 Partial Update. on: September 28, 2012, 11:28:29 am
Apparently not

I get
Code:
Current_Working_2_9_12.cpp: In function 'long unsigned int LCDBattery()':
Current_Working_2_9_12:1524: error: 'class ST7565' has no member named 'updateBoundingBox'
54  Using Arduino / Programming Questions / Re: Battery discharge curve mapping on: September 27, 2012, 01:52:07 pm
Hi,
Unfortunately I cannot add any extra items for my PCBs as this is a custom design that I was hoping to add as an extra feature in software.
And it is a LiPo battery
55  Using Arduino / Programming Questions / Re: Battery discharge curve mapping on: September 19, 2012, 11:01:56 am
So I guess I have to stick with my oversimplified calculation range then of
battPercent = (((battVoltage - 1.69) / 0.39) * 100);
56  Using Arduino / Programming Questions / Re: Battery discharge curve mapping on: September 19, 2012, 10:19:28 am
Hi,
Yes
http://www.gmbattery.com/upload/editorfiles/2008.9.6_13.39.34_5817.jpg
57  Using Arduino / Programming Questions / Battery discharge curve mapping on: September 19, 2012, 10:09:13 am
Hi,
I currently have a device that is reading the battery voltage over a voltage divider to drop it down to a usable value for the arduino.  However I would like to convert this into an accurate percentage value using the battery discharge curve such as one of these,


How would I go about mapping it to an equation to use for the arduino?
Thanks in advance.
58  Using Arduino / Displays / Re: Really weird LCD bug!!! on: September 19, 2012, 07:43:44 am
Care to give some error messages and details?
59  Using Arduino / Displays / Adafruit ST7565 Partial Update. on: September 19, 2012, 07:01:57 am
Hi,
I am using Adafruits ST7565 lcd library and I wanted to know how use the Partial Update feature, it seems to be mentioned a few times in the library but I cant figure it out.

https://github.com/adafruit/ST7565-LCD
What I have is

Code:
glcd.drawchar(102, 0, battString0);
 glcd.drawchar(107, 0, battString1);
 glcd.drawchar(112, 0, battString2);
 glcd.drawchar(117, 0, battString3);
 glcd.drawchar(122, 0, battString4);
 updateBoundingBox(102, 0, 127, 1);
but that doesn't work
I get
Code:
Current_Working_2_9_12:1519: error: 'updateBoundingBox' was not declared in this scope
60  Using Arduino / General Electronics / Re: TPS63001 to power arduino on: September 17, 2012, 06:49:28 am
Well as part of the rest of my circuit I have ethernet and SD on SPI, I have 2 devices on I2c and I am then bit banging 7 more devices on virtual I2C channels
Pages: 1 2 3 [4] 5 6 ... 13