Show Posts
Pages: [1] 2
1  International / Français / Re: actionneur linéaire firgelli on: January 14, 2013, 07:52:14 am
Le servo est alimenté par la carte arduino, j'ai aussi essayé de l'alimenter par un générateur continu 6V et ça n'a pas marché !!
Peut être que je l'ai mal branché...
2  International / Français / actionneur linéaire firgelli on: January 14, 2013, 05:01:37 am
Bonjour,
J'essaie un peu tous les moteurs comme vous avez pu le constater dans mes messages...
Je commence à comprendre leur fonctionnement!!
Par contre, je bloque sur le dernier que je viens d'acheter, c'est un firgelli L12-50-100-6R.
J'utilise une arduino Artmega 2560 et comme ce moteur marche comme un servo moteur, je mets comme programme dans l'IDE :
#include <Servo.h>
Servo myservo;
void setup()
{ myservo.attach(9); }
void loop() {
myservo.write(20);
   delay(4000);
myservo.write(100);
   delay(4000);
   


Mais ça ne marche pas !!
De temps en temps il bouge mais dès que je veux changer les angles la carte ne veut plus communiquer et elle met que le port com est déjà utilisé.
ça fait deux jours que je suis non stop sur ça, alors si vous avez une petite idée, je suis preneuse!!!
Merci d'avance et très bonne journée.
 
3  International / Français / motor shield rev3 on: October 05, 2012, 10:24:34 am
Bonjour,
Je viens d'avoir une carte motorshield rev3 que je mets sur arduino uno.
Evidemment, j'ai un problème!!!
Je veux juste brancher un moteur pas à pas (ITC-CNC2) 4 fils bipolaire et le faire tourner.
J'ai pris le programme suivant :
Code:
#include <AFMotor.h>
AF_Stepper motor(200, 1);
void setup() {
Serial.begin(9600); //
set up Serial library at 9600 bps
Serial.println("Stepper test!");
motor.setSpeed(10); // 10 rpm
motor.step(100, FORWARD, SINGLE);
motor.release();
delay(1000);
}
void loop() {
motor.step(100, FORWARD, SINGLE);
motor.step(100, BACKWARD,
SINGLE);
motor.step(100, FORWARD, DOUBLE);
motor.step(100, BACKWARD,
DOUBLE);
motor.step(100, FORWARD,
INTERLEAVE);
motor.step(100, BACKWARD,
INTERLEAVE);


et je me rends compte qu'il n'allume que deux leds  et non pas les quatres!!
Est-ce qu'il y a un moyen pour faire tourner les deux bobines??
Merci et bon week end
4  International / Français / Re: moteur pas à pas comment ne pas avoir à changer la tension?? on: September 27, 2012, 03:32:15 am
A vide et en charge.
5  International / Français / Re: moteur pas à pas comment ne pas avoir à changer la tension?? on: September 27, 2012, 02:57:43 am
Bonjour,
Si je ne fais pas varier la tension le moteur fait un gros bruit et ne bouge pas.
par exemple quand je passe de 60rpms à 100rpms je dois passer de 8.5V environ à 12.5V.
6  International / Français / moteur pas à pas comment ne pas avoir à changer la tension?? on: September 27, 2012, 01:58:21 am
Bonjour,
Je suis toujours sur mes moteurs pas à pas !!
J'ai réussi à faire marcher deux moteurs pas à pas ensemble et décalés, avec deux pont H L293D et le programme un peu modifier de http://arduino.cc/en/Tutorial/MotorKnob.
Par contre, j'ai encore un gros problème à chaque fois que j'augmente la vitesse ou le contraire, il faut que je diminue ou que j'augmente la tension.
Est-ce que quelqu'un sait comment y remédier??
Merci et bonne journée
7  International / Français / Re: moteur pas à pas!! on: September 12, 2012, 07:54:55 am
Merci beaucoup, ça y est j'arrive bien à contrôler un moteur pas à pas.
par contre pour faire fonctionner deux moteurs pas à pas ensemble, je ne vois toujours pas, est-ce qu'il y a un programme et un schémas quelque part???
Est-ce que je dois poser une autre question sur le forum??
bonne journée
8  International / Français / Re: moteur pas à pas!! on: September 11, 2012, 07:06:40 am
Oui c'est bien un pont H , mais je crois que ce n'était pas le bon , je croyais que le L293NE était presque pareil que le L293D mais apparemment pas car j'ai juste changé le pont H  et tout a marché.
Merci pour vos réponses.
Par contre j'ai deux questions encore, je veux maintenant un moteur qui a plus de couple, j'ai sous la main le moteur avec ces références :
Nombre de pas: 200
Angle par pas: 1,8°
Alimentation: 3,2 V
Réduction: 1:20
Résistance/phase: 1,13 ohms
Courant/phase: 2,8 A
Connexion: 4 fils

est-ce que mon alimentation je dois la changer ??? et si oui est-ce qu'il faut que j'en trouve une avec une intensité de 2.8A minimum??
la deuxième question:
est-ce possible de commander deux moteurs pas à pas simultanément ??
9  International / Français / moteur pas à pas!! on: September 11, 2012, 04:35:38 am
Bonjour,

J'ai un projet qui me paraissait simple comme ça mais je ne dois vraiment pas comprendre les choses!!!
Voilà, je dois faire tourner deux moteurs pas à pas identiques en continu et simultanément.
les références de mes moteurs sont les suivantes : 17HS3401
Alors j'ai réalisé le montage pour un moteur uniquement(voir photo ci-jointe) que nous propose : http://arduino.cc/en/Tutorial/MotorKnob
et le programme que j'utilise est le suivant :
Code:
#include <Stepper.h>

// change this to the number of steps on your motor
#define STEPS 200

Stepper stepper(STEPS, 4, 5, 6, 7);

void setup()
{
  // set the speed of the motor to 20 RPMs
  stepper.setSpeed(20);
}
void loop()
{
  // move a number of steps equal to the change in the
 
  stepper.step(200);

}

J'utilise une alimentation : 5V et 1.5A
Alors tout marche au départ et 10 secondes après ça vibre et ça ne tourne plus pareil.
J'ai lu beaucoup de forum mais je n'ai pas trouvé encore mon erreur alors si quelqu'un pouvait me donner une piste ça me sortirait d'un gros pétrin car c'est assez urgent.
Merci beaucoup d'avance et très bonne journée à vous.
10  International / Français / Re: phidget 1063 on: August 09, 2012, 02:45:09 am
Bonjour,
Merci pour ta réponse, par contre, je ne comprends toujours pas pourquoi le moteur qui fait 400 pas ne fait pas un tour complet lorsqu'on lui demande de faire 4000 pas. smiley-cry
Et une autre chose bizarre lorsque je lui mets une vitesse de rotation en dessous de 10 rpms, il vibre et ne bouge presque pas...
Sinon, si j'ai bien compris, tu ne peux pas lui demander d'aller d'un coup à la vitesse maximum.
Merci encore et bonne journée
11  International / Français / Re: phidget 1063 on: August 08, 2012, 10:09:40 am
Bonjour,
Merci pour les réponses.
Bon, j'ai réussi à faire fonctionner le moteur, mais maintenant j'ai un autre problème... c'est un moteur qui fait 400 pas, j'ai cherché partout, je ne trouve pas sa vitesse de rotation maximum. Et lorsque je mets dans le programme arduino : Programme :  (vu dans MotorKnob), je ne peux pas mettre plus de 20 rpms (ce qui veut dire tours par minute, c'est bien ça???) et ça ne tourne vraiment pas vite et en plus lorsque je lui mets stepper.step(400)et  stepper.step(-400) à la suite, il ne fait même pas un quart de tour en avant et pareil de l'autre côté ...
Est-ce que c'est normal??
Car s'il fait 400 pas, ça veut bien dire qu'i fait 400 pas pour faire le tour ou je me trompe complétement??

#include <Stepper.h>

#define STEPS 400

// create an instance of the stepper class, specifying
// the number of steps of the motor and the pins it's
// attached to
Stepper stepper(STEPS, 8, 9, 10, 11);

void setup()
{
  // set the speed of the motor to 20 RPMs
  stepper.setSpeed(20);
}

void loop()
{ // move a number of steps
  stepper.step(400);
 stepper.step(-400);
}

Merci encore d'avance pour votre aide, car je nage un peu!!!
Bonne journée
12  International / Français / Re: phidget 1063 on: August 07, 2012, 08:39:20 am
Bonjour,
C'est ce que je me suis dis depuis ce matin, donc j'ai essayé le schémas ci joint. Par contre, je n'ai pas L293D mais L293NE, est-ce que ça change quelque chose??
Et le moteur (références dans le fichier joint), je ne sais pas comment le brancher, j'ai essayé plusieurs combinaisons mais ça n'a pas marché...
Et je me demande aussi quelle alimentation, il faut que je prenne??
Bon, il y a aussi le programme, ce n'est peut être pas le bon??
Voilà, en fait le moteur ne bouge pas du tout, j'essaie pleins de chose et rien le fait bouger...
   
13  International / Français / phidget 1063 on: August 06, 2012, 08:00:15 am
Bonjour,
Je dois contrôler un moteur pas à pas avec la carte phidget 1063 conseiller avec. J'ai réussi à faire fonctionner le moteur avec le driver qui va avec (stepper bipolar) . Par contre je n'arrive qu'à le faire tourner pendant très peu de temps juste le temps qu'il fasse un angle précis et je voudrais qu'il fasse des allers et retours pendant au moins une demi heure. Est-ce que je peux communiquer avec la carte phidget en passant par arduino?? Et si oui est-ce que vous auriez un petit exemple, car je ne suis pas très experte...
Merci beaucoup d'avance
14  International / Français / Re: contrôler un haut parleur (150Watt,0.8Ohm) avec une fonction sinusoidale arduino on: March 20, 2012, 10:35:06 am
Rebonjour,
Vraiment merci beaucoup pour toutes vos réponses.
En fait dernièrement, j'ai fait un stage Arduino et j'aimerai continuer dans ma lancée.
Mais je peux aussi changer d'avis...
Je voudrais avec un haut parleur de grand diamètre faire bouger la membrane avec une grande amplitude (plus de 2cm en haut et en bas) et avec une fréquence de 10Hz environ.
mais pour ne pas abimer trop le haut parleur ce serait mieux de lui envoyer un signal sinusoïdal. Et comme après on veut transporter cette manip un peu partout, on aimerait bien
tout miniaturiser.
Bonne journée
15  International / Français / contrôler un haut parleur (150Watt,0.8Ohm) avec une fonction sinusoidale arduino on: March 20, 2012, 03:51:27 am
Bonjour,
Je suis sur un projet de recherche et je souhaiterai faire bouger la membrane d'un haut parleur avec un signal sinusoïdal (+5V,-5V).
Tout d'abord je ne sais pas comment aller dans les négatifs et ensuite j'ai essayé avec le montage suivant (pièce jointe)en remplaçant arduino avec un générateur de signal sinusoïdal et il me faut au moins 6V en amplitude pour voir bouger le haut parleur donc c'est plus que ce que peut délivrer arduino.
Je crois aussi que je ne comprends pas le fonctionnement de l'ampliop.
Si quelqu'un pouvait m'aider ce serait vraiment sympa, car je bloque depuis quelques semaines.
Bonne journée.
 
 
Pages: [1] 2