Show Posts
Pages: 1 ... 5 6 [7] 8 9 ... 40
91  International / Deutsch / Re: UNO R2 top, R3 flop on: June 09, 2014, 10:11:19 am
Hallo Jurs,

Du bist wieder auf dem richtigen Weg. Da kommen schlappe 1,6V an, und nachdem dieser Groschen bei mir gefallen ist scheinen einfach die Buchsenleisten Schrott zu sein.

Hab mal den 5V Pin gemessen. An der Lötstelle kommen noch 5V an, am Board auch nur noch ca. 2V. Ich denke, hier haben wir den Übeltäter.

Ich check das später nochmal, schonmal ein dickes Danke!
92  International / Deutsch / Re: UNO R2 top, R3 flop on: June 09, 2014, 08:17:25 am
Nachtrag: da klappt auch was mit dem SD-Schreiben nicht.
Es müßte ja zumindest ein File mit Kopfzeile erzeugt werden. Karte ist aber leer.
Der CardInfo Sketch aus der IDE findet auch keine Karte.

Passt da vielleicht das Timing nicht?

Ach, es ist einfach Mist wenn man sich nicht auskennt  smiley-sad-blue

93  International / Deutsch / Re: UNO R2 top, R3 flop on: June 09, 2014, 08:05:41 am
Danke euch, hier die neusten Erkenntnisse:

Wenn's kein Originaler ist dann ist's offenbar ne gute Fälschung. Aber das regel ich mit dem Verkäufer.

@Jurs:
Delay bringt keine sichtbare Veränderung, aber ich habe den Übeltäter identifiziert:

Code:
now = RTC.now();

läßt den Code abschmieren. Sprich, da bleibt er einfach hängen.
Stellt sich mir die Frage, ob es sich lohnt darüber noch weiter nachzudenken  smiley-confuse
Aber es will mir nicht in den Kopf, warum das nicht funktionieren will wenn doch der Rest - scheinbar - fluppt.
Den 328er habe ich auch schon mal getauscht, Fehler bleibt am Board.

Noch ne Pfingstmontagidee?
94  International / Deutsch / Re: saubere Spannung aus Schaltnetzteil, wie ? on: June 09, 2014, 04:32:44 am
Ist die Spannung denn halbwegs glatt? Kannste mit dem Hameg ja zumindest anschauen.
95  International / Deutsch / Re: saubere Spannung aus Schaltnetzteil, wie ? on: June 08, 2014, 01:31:55 pm
Nimm mal 100uF
96  International / Deutsch / Re: saubere Spannung aus Schaltnetzteil, wie ? on: June 08, 2014, 12:41:00 pm
Ich würde in den Fall tatsächlich auf 2 Stromversorgungen gehen oder die Module besser entkoppeln - ist ja Dein Ansatz.
Wenn Du rausbekommst mit welcher Frequenz Dein Netzteil arbeitet dann kannst Du auch besser filtern. Ich schätze aber mal, dass es eher die Felder um das Netzteil herum sind die stören und nicht die Versorgungsspannung so verseucht ist. Das kannst Du mit längeren Strippen ausprobieren.
Ansonsten mal rantasten mit R/C Glied, so 10 Ohm und Dein Elko (Größe?) mit 100nF parallel.
97  International / Deutsch / UNO R2 top, R3 flop on: June 08, 2014, 10:53:33 am
Hallo zusammen,

habe mir einen zusätzlichen UNO gegönnt weil ich ja nebenher immer noch mit den Tinys rumspiele und mir das ständige Sketchwechseln dann doch ... lassen wir das  smiley-mr-green

Ich gehe davon aus, dass beide Originale sind, jedenfalls sprechen alle Anzeichen dafür. Habe aber für die Profis noch Bilder angehängt, hilft vielleicht.

Jetzt mein Problem:
"Blink" als Test funktioniert einwandfrei, Upload geht also, Treiber funktioniert, scheint alles gut.
Jetzt nehme ich meinen Datalogger-Sketch der auf dem R2 völlig problemlos läuft, und der tut's nicht auf dem R3.
Sketch hängt auch dran, ist schnell zusammengeschustert, also nicht zu genau hinsehen  smiley-red

Das Ding hängt sich auf, bis dato nicht identifizierbar wann und warum. Gleicher USB-Port, gleiches Kabel, gleiches Shield (http://www.watterott.com/de/Adafruit-Data-Logging-Shield). Ist halt Com6 beim R3 statt Com3 beim R2.

Hat jemand ne plausible Erklärung?
Habe auch mal den Treiber gewechselt bis runter zu dem aus der IDE 023, bringt alles nix.

Danke für erhellende Hinweise
Klaus

98  International / Deutsch / Re: Tanklfüllung messen mit Arduino? on: June 08, 2014, 10:45:29 am
Wenn's linear geht nimm doch einfach die map-Funktion.

Edit: nachdem ich nochmal mit eingeschaltetem Hirn gelesen habe stelle ich fest: ist nicht linear  smiley-grin
Also könnte man nach guter alter Manier aus den 3 gegebenen Punkten eine Formel ableiten und die verwenden.

Vermutlich ist es der Genauigkeit aber zuträglicher, noch Zwischenwerte aufzunehmen. Oder halt nicht und dann die grobe Aufteilung zu verwenden.

Grüße
Klaus
99  International / Deutsch / Re: Pulldown Widerstand für 3,3V Eingang on: June 03, 2014, 03:24:42 pm
Nee, direkt rein und fein.
100  International / Deutsch / Re: Drehzahl auf LCD ausgeben - Problem mit Sketch on: June 03, 2014, 03:23:48 pm
Wenn der arduino mit 5V läuft darfst Du auch 5V anlegen. Wenn er mit 3,3 V läuft dann nur 3,3V.
Kurz: Eingangsspannung max Betriebsspannung
101  International / Deutsch / Re: Drehzahl auf LCD ausgeben - Problem mit Sketch on: June 03, 2014, 03:14:39 pm
Genau das habe ich mir auch gedacht. Aber da darf ich doch keine 5V drauf legen?!
Wie müsste denn der Sketch in der Zeile lauten, damit es über den A0 läuft? Einfach die "2" durch "A0" ersetzen?

Warum soll das nicht gehen? Geht!
102  International / Deutsch / Re: Pulldown Widerstand für 3,3V Eingang on: June 03, 2014, 03:08:18 pm
Kein R nötig (in der mir bekannten Bauweise)
103  International / Deutsch / Re: Drehzahl auf LCD ausgeben - Problem mit Sketch on: June 03, 2014, 03:07:27 pm
Auf die Schnelle:
const int hallPin=2;
klingt nicht nach A0
104  International / Deutsch / Re: Pulldown Widerstand für 3,3V Eingang on: June 03, 2014, 03:04:28 pm
Sag uns, welcher Sensor das ist und wir sagen Dir, ob der R nötig ist.
Ich sage aus dem Bauch: nicht nötig, die meisten (mir bekannten) Sensoren liefern sozusagen "aktiv" low wie auch high.
Außerdem ist ein Pulldown eher unüblich, bei Open Collector Ausgängen ist ein Pullup notwendig.
105  International / Deutsch / Re: Atmega328 Sketch direkt programmieren und nicht über Seriell on: May 31, 2014, 01:22:46 am
Dann nimm doch den Uno als ISP oder einen anderen ISP Programmer. Geht wunderbar.
Pages: 1 ... 5 6 [7] 8 9 ... 40