Show Posts
Pages: 1 ... 78 79 [80] 81 82 ... 93
1186  Using Arduino / Project Guidance / Re: Using Arduino to send texts and photos on: November 25, 2011, 03:30:40 pm
My project is somehow related, but I am not using the RAZR. 
I am using this camera mounted together with my Canon:
http://www.seeedstudio.com/depot/grove-serial-camera-p-945.html

Sending the image data with XBee.  Controlling a motorized panning head.  USB host to control Canon DSLR.
With a zoom lens I can zoom in to any part of the Lores image remotely.
Next step send the image object from the camera.
But it's really cool without that functionality!
1187  Using Arduino / Project Guidance / Re: Using Arduino to send texts and photos on: November 25, 2011, 03:08:21 pm
When I call my sndstr function that is when it occurs.  You can send any AT command or any string.  Do not put this function call in a loop() which gets called 100x (acm_terminal sketch) unless that's what you want.  The particular AT command in my example is the first command I must send to my Verizon phone to initialize it to accept AT commands.  It is specific to Verizon not GSM.  You will not need to send it.  The sndstr function is defined before I call it. 

I understand what you are planning to do.  What specific sequence of keystrokes take a picture and send it?  Unfortunately I don't think the CKPD command is supported by my Verizon RAZR.  Will try it.  I hope it works with yours!  Have you tested it in terminal mode?  I recommend you try that first.  Knowing that it is possible to automate later with my code.
1188  Using Arduino / Installation & Troubleshooting / Re: arduino pro mini 3.3v cant upload on: November 25, 2011, 10:28:45 am
I have no regrets using my Uno to burn the bootloader.
Because it worked!
Took 2 minutes including soldering!
The instructions were simple, there was no confusion.
This is what an ISP programmer does?

Should uploading a Sketch be even simpler?

Is it possible to change fuses with 2 Uno's?
1189  Using Arduino / Installation & Troubleshooting / Re: arduino pro mini 3.3v cant upload on: November 25, 2011, 09:57:59 am
But wait.  Shouldn't it be easy?  It's only 5 pins.  No soldering.  It's easy to remove the whole Uno board from a project.  I don't want to burn the new chip bootloader, it's already done using Uno.  It couldn't have been simpler. 

I just want to upload a sketch.  You're saying using a Uno is inappropriate?  Too complicated? 

Well you're right it doesn't work.  But neither does my Sparkfun Xbee dongle.  Would that be a better solution for me?  Why doesn't that work?

You're saying I need to try 3 completely different pieces of hardware to be successful?  I think the problem is my PCB soldering.  Or am I forgetting something totally obvious?
1190  Using Arduino / Programming Questions / Re: What am I doing wrong? Silly mistake? on: November 25, 2011, 09:53:22 am
You win a prize! 
It took me nearly an hour to figure that out.
I bet you got it immediately...
1191  Using Arduino / Installation & Troubleshooting / Re: New Mini-uino on: November 25, 2011, 09:45:35 am
The IDE says "Problem uploading to board".
I would expect the L,TX,RX to act the same with both chips when uploading?
What is the L LED?  I don't know, just that it blinks with original chip installed.
Reading... Ah I understand it should not blink. But TX should?
1192  Using Arduino / Project Guidance / Re: Using Arduino to send texts and photos on: November 25, 2011, 09:36:39 am
Serial.println does not go to the phone.  I've been doing something similar, let me find the code...

Code:
uint8_t sndstr(char *s) {
uint8_t i,j,k;
for(i=0;s[i]!=0;i++) {
  k=s[i];
  j=Acm.SndData(1,&k); //could do all at once?
  if(j) return j;
}
i=13;
j=Acm.SndData(1,&i);
return j;
}

//later on...
 sndstr("AT+MODE=2");

I have the Verizon RAZR.  
There are many differences that were difficult to overcome, but now it's working!

Which AT commands do you use to send a picture?  I'm interested!
1193  Using Arduino / Project Guidance / Re: program an atmega328 with a mega on: November 25, 2011, 09:29:16 am
http://arduino.cc/en/Tutorial/ArduinoToBreadboard
1194  Using Arduino / Programming Questions / Re: Hibernating XBee resets the Arduino on wake-up on: November 25, 2011, 09:19:06 am
I am also curious about this. 
Is it possible to wake the XBee without resetting Uno?
Your link says the 120 ohm resistor is not possible for Uno...
1195  Using Arduino / Installation & Troubleshooting / Re: arduino pro mini 3.3v cant upload on: November 25, 2011, 08:59:30 am
Do you have an Arduino board to use instead?
1196  Using Arduino / Installation & Troubleshooting / Re: New Mini-uino on: November 25, 2011, 08:57:44 am
No shorts.
I can see 3 problems according to this tutorial:
http://arduino.cc/en/Tutorial/ArduinoToBreadboard

It says NOT the Uno, at the top, in bold.
It says to select a different controller in the Board menu.
I have 4 extra caps in my circuit.
Which one of these is a problem?
1197  Using Arduino / Project Guidance / Re: program an atmega328 with a mega on: November 24, 2011, 10:43:11 pm
You mean load a sketch?  TX,RX,RST,5V,G
I'm trying to do something similar but it's not working.
1198  Using Arduino / Installation & Troubleshooting / Re: New Mini-uino on: November 24, 2011, 02:18:55 pm
Didn't you do this process with the same PCB?
How is my setup different?
I've tried 2 different methods, different pins, different hardware.
So it can't be just 1 bad solder joint.
The only thing they have in common is our PCB.
Maybe I have a soldering defect.
How do I troubleshoot?
Keep in mind the Optiloader process was a success.
Maybe I have made a stupid mistake, I'm new to Arduino.
Something so obvious to everyone they forgot to tell me?
That's why I need your questions!  No question is stupid or insulting.
Did you remember to plug in the USB cable?  smiley-wink

When I press reset with my old DIP 328 the lights do a sequence.
Shouldn't I expect a similar response even without a Sketch in the new chip?
This does not require a good solder connection to RX.
Does it prove the problem is with TX or Reset? 
(I tested power and GND)
Certainly we can eliminate anything related to the PC as suspect.

Let's assume I made a soldering mistake.
Which connections would fit the symptoms?
Works with Optiloader but not IDE loading sketches.
Seems there are only 3 possibilities?

The correct caps are marked 4x 104
2x 22
Res Brown Black Orange.
Getting desperate...

Thanks everyone for your time and effort so far,
especially Crossroads!
Steve
1199  Using Arduino / Installation & Troubleshooting / Re: New Mini-uino on: November 24, 2011, 09:49:03 am
Just tried again like this:
1200  Using Arduino / Installation & Troubleshooting / Re: New Mini-uino on: November 24, 2011, 09:30:11 am
Why is there a "1" next to "D0" on PCB printed in white?
Looks almost like "D01" except 1 is upside down.
There is also a "1" next to D5.

Also tried:
D10 to Mini-uino Reset,
D11 to D11,
D12 to D12,
D13 to D13,
+5 to +5,
Gnd to Gnd
using Sparkfun USB Xbee dongle.
Same error.
Pages: 1 ... 78 79 [80] 81 82 ... 93