Show Posts
Pages: [1]
1  International / Generale / Re: Serial Port non funziona Debian Squeeze on: March 10, 2013, 12:12:00 pm
ecco cosa accade nel terminale:

giacomo@portatile:~/arduino-1.0.3$ sh arduino
Experimental:  JNI_OnLoad called.
Stable Library
=========================================
Native lib Version = RXTX-2.1-7
Java lib Version   = RXTX-2.1-7


poi mi si apre l'ide e la sezione porta seriale è sempre inselezionabile.
2  International / Generale / Re: Serial Port non funziona Debian Squeeze on: March 09, 2013, 12:54:25 pm
ho provato a seguire la guida ma non funziona ancora... ho avuto solo un problema: quando dice di scaricarsi la libr con

wget http://ftp.us.debian.org/debian/pool/main/r/rxtx/librxtx-java_2.2pre2-10_i386.deb

non mi funzionava allora ho scaricato manualmente il pacchetto librxtx-java_2.2pre2-11_i386.deb che sia quello il problema?
3  International / Generale / Re: Serial Port non funziona Debian Squeeze on: March 09, 2013, 12:00:39 pm
Niente, ho provato ad installare il pacchetto ma la voce resta sempre inselezionabile, anche con la versione del pacchetto.
4  International / Generale / Re: Serial Port non funziona Debian Squeeze on: March 09, 2013, 11:43:09 am
Non ho usato il pacchetto precompilato perchè ho letto che non supporta arduino uno, la scheda che uso.
Ho dato dmesg | tail e questo è l'output:

root@portatile:/home/giacomo# dmesg | tail
[  254.805510] usb 2-1: configuration #1 chosen from 1 choice
[  254.808632] cdc_acm 2-1:1.0: ttyACM0: USB ACM device
[  283.120120] usb 2-1: USB disconnect, address 5
[  286.452058] usb 2-2: new full speed USB device using uhci_hcd and address 6
[  286.654082] usb 2-2: New USB device found, idVendor=2341, idProduct=0043
[  286.654091] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=220
[  286.654098] usb 2-2: Manufacturer: Arduino (www.arduino.cc)
[  286.654104] usb 2-2: SerialNumber: 6493633303735160D0B2
[  286.655517] usb 2-2: configuration #1 chosen from 1 choice
[  286.658205] cdc_acm 2-2:1.0: ttyACM0: USB ACM device
5  International / Generale / Re: Serial Port non funziona Debian Squeeze on: March 09, 2013, 11:26:53 am
Scusate mi ero dimenticato di dirlo, ma l'ho già fatto.   smiley-sad-blue
6  International / Generale / Serial Port non funziona Debian Squeeze on: March 09, 2013, 11:14:04 am
Ciao a tutti, mi servirebbe una consulenza riguardo all'IDE di Arduino. Sto usando un laptop con Debian Squeeze. Quando faccio partire lo script funziona tutto e si apre l' IDE senza problemi. Solo che quando vado ad aprire nel menu Tools la voce Serial Port è grigina e non riesco a selezionarla.

Ho letto un po' online qualche guida (http://playground.arduino.cc//Linux/Debian) e dicono di provare ad
aprirlo come root dopo aver installato il pacchetto "librxtx-java2.2pre2-3 or higher". Io l'ho installato ma quando faccio partire lo script (con il comando sh arduino) il terminale mi mostra questo messaggio:

root@portatile:/home/giacomo/arduino-1.0.3# sh arduino
Experimental:  JNI_OnLoad called.
Stable Library
=========================================
Native lib Version = RXTX-2.1-7
Java lib Version   = RXTX-2.1-7

quindi mi apre l'IDE. E la voce Serial Port è ancora grigina. Devo supporre che non stia utilizzando le librerie giuste?

Tutto ciò con la board attaccata via USB al computer. Se lancio lsusb la board non viene rilevata, ma è presente il file /dev/ttyACM0 quindi suppongo che il computer se ne accorga.

Qualcuno di voi ha avuto lo stesso problema e sa come aiutarmi?

Grazie mille in anticipo.
7  Products / The Arduino Starter Kit / Re: [3/Love-o-meter] it seems TMP36 doesn't work (volts: 0.00 ; degrees: -50.00) on: January 25, 2013, 04:13:44 pm
Hi to everyone,
i had a this problem too: i received an output on serial but the degrees was always negative (i tested it in a room, about 19/20°C) so i tried to check the code and the wiring and it was all right. So i used a multimeter to calculate the central pin output (black wire on GND red in central pin) and i had  0.0 V in output. Au contraire with the red wire on the positive pin of the sensor and the black on central I saw 4,36 V.
So i thought that the project is probably wrong in facts if you put a very "big" resistance (800 Kohms) between the positive pin and the central one it does work.
Maybe i'm wrong but try to fix this in your future starter kit version.
8  International / Generale / Re: Presentazioni nuovi iscritti, fatevi conoscere da tutti! on: January 04, 2013, 01:09:43 pm
Ciao a tutti scrivo da Bergamo e finalmente sto entrando nel mondo di arduino!
Pages: [1]