Your code would be much simpler if you refactored it. It looks to me like all conditions depend on "tow" being HIGH, so test that first, then your tone inputs, then read all the tone inputs in one go into variables, or better still, bit-packed into a single variable. Spreading code across the page with repeated digitalReads is hard to read.
In the code in reply #2, there are no explicit "return"s. It looks like if you replaced the calls to "loop();" with "return;", you'd probably be close to where you want to be. Use of auto format would make your code easier to follow.