Arduino Forum

Development => Suggestions for the Arduino Project => Topic started by: federicofissore on Jan 09, 2013, 06:36 pm

Title: R: Road to solve the delay on the Arduino IDE
Post by: federicofissore on Jan 09, 2013, 06:36 pm
The old original topic was http://arduino.cc/forum/index.php/topic,46977.0.html

Thanks to eried, to neophob (http://neophob.com/2011/05/serial-library-rxtx-v2-2pre5/) and to the guys and girls working on RXTX (the piece of software we use to make the pc communicate with our boards) I've managed to fix the "tools" menu delay issue.

I need someone volunteering and testing the fix. Instructions below:

Attached you can find a .zip which contains 2 files. You have to overwrite the existing ones with the ones attached. BEFORE you do so, back them up: copy them somewhere else, so you can restore them if bad things happen.

One file is "RXTXComm.jar": it is a multiplatform file, everyone of you has it under folder "lib" in the folder where you have installed your arduino ide.

The other file is specific to your operating system: I've managed to make the linux 32 and 64 bit and windows versions. Mac versions will soon follow.
If you have a 32bit or 64bit linux, copy file librxtxSerial.so from folder linux32 or linux64 into folder "lib" (right next RXTXComm.jar)
If you have windows, copy file windows/rxtxSerial.dll into the folder where you have installed your arduino ide (right next arduino.exe)

Run the ide and report back: is everything running as usual? If you were experiencing the tools menu delay: has it disappeared?

Thank you in advance

Federico
Title: Re: R: Road to solve the delay on the Arduino IDE
Post by: federicofissore on Jan 15, 2013, 12:19 pm
I've updated the zip file to include the mac specific lib: it's only for Intel based macs
Title: Re: R: Road to solve the delay on the Arduino IDE
Post by: Darkblade48 on Sep 23, 2013, 04:11 pm
The IDE seems to be running as usual after replacing the JAR file as well as the DLL, but the delay in the tool menu still seems to persist.
Title: Re: R: Road to solve the delay on the Arduino IDE
Post by: federicofissore on Sep 23, 2013, 05:16 pm
Have you tried latest IDE release? (1.5.4)
Title: Re: R: Road to solve the delay on the Arduino IDE
Post by: Rob Cameron on Sep 25, 2013, 11:34 pm
Speaking of an updated IDE, I just opened a ticket over the GitHub repo with a new proposed design and some missing features:

https://github.com/arduino/Arduino/issues/1590

Rob
Title: Re: R: Road to solve the delay on the Arduino IDE
Post by: federicofissore on Sep 26, 2013, 09:06 am
Very nice!
Title: Re: R: Road to solve the delay on the Arduino IDE
Post by: bd85 on Aug 17, 2014, 09:07 pm
I'm running OSX and recently upgraded my IDE from 1.0.5 to 1.5.7 to use the Yun and am experiencing the delay issues both on startup and when selecting the Tools menu.  I also tried older 1.5.x builds and had the same issue.  I don't have any problems using 1.0.5 and an Uno. 

I attempted to follow the instructions but haven't been able to figure out where to place the updated files.  They don't appear to already exist in the lib folder when I look through the Arduino package in OSX.  I searched my computer and couldn't find a file with RXTX other than the ones I downloaded using the links from this thread.  As an alternative I tried to place the files in the Extensions folder in HD/Library/Java/Extensions but to no avail.  I also tried turning off Bluetooth which had been suggested in other threads. 

Any suggestions would be greatly appreciated. 
Title: Re: R: Road to solve the delay on the Arduino IDE
Post by: westfw on Aug 19, 2014, 09:40 am
I thought that the original issue was window only, and is old.
A "delay" problem with Yun on Mac is probably a new and different problem; try starting a new thread.
Title: Re: R: Road to solve the delay on the Arduino IDE
Post by: coolfire on Nov 18, 2014, 04:40 pm
I purposely sign-up, just to say thanks Federico Fissore :)
I followed the steps exactly, and it resolved my 'Tool' menu lagging problem.
Title: Re: R: Road to solve the delay on the Arduino IDE
Post by: jjones11 on Dec 02, 2014, 07:24 pm
Why is this still a problem after 5 years?  I'm on a Win7-Pro 64-bit PC.  Yesterday, I downloaded and installed the latest and greatest Arduino (1.0.6) and immediately smacked into the "Tools Menu Delay" issue.

Googling reveals this has been an issue since 2009, and apparently with every release of Arduino since!  Tracking down and using the custom-built rxtxSerial.dll works fine (old fix - haven't yet tried Frederico's fix yet), but it's very disappointing that this has not been fixed by the powers-that-be years ago.  Is this the normal mode of operation with Arduino?

It's a pretty cool package regardless... thanks to you users out there, and this forum.
Title: Re: R: Road to solve the delay on the Arduino IDE
Post by: westfw on Dec 03, 2014, 11:14 am
Quote
Why is this still a problem after 5 years?
If that's a serious question, the answer is PROBABLY that rxtxserial is an imported component where the arduino team doesn't want to modify or support their own version, and the people who do maintain it didn't hear about the problem, haven't fixed it yet, or have chosen not to fix it.

Title: Re: R: Road to solve the delay on the Arduino IDE
Post by: smitex2 on Jan 16, 2015, 09:54 am
Thanks very much, works for me to, i'm using windows 8.1 on a hp netbook
Title: Re: R: Road to solve the delay on the Arduino IDE
Post by: bobcousins on Jan 16, 2015, 10:02 am
Googling reveals this has been an issue since 2009, and apparently with every release of Arduino since!  Tracking down and using the custom-built rxtxSerial.dll works fine (old fix - haven't yet tried Frederico's fix yet), but it's very disappointing that this has not been fixed by the powers-that-be years ago.  Is this the normal mode of operation with Arduino?
Sadly yes. :(

And it can't be said that it is because users fail to raise issues, or that devs are unwilling to commit changes and help improve Arduino, because there are hundreds of outstanding issues on github, and dozens of fixes and pull requests which never get incorporated.

Title: Re: R: Road to solve the delay on the Arduino IDE
Post by: ondronr on Feb 03, 2015, 01:31 am
rxtxSerial.dll should be replaced with JSSC as of ARDUINO 1.5.6 BETA - 2014.02.20
Quote
* Replaced RXTX library with JSSC (Alexey Sokolov)
http://code.google.com/p/java-simple-serial-connector/
https://github.com/arduino/Arduino/blob/master/build/shared/revisions.txt (https://github.com/arduino/Arduino/blob/master/build/shared/revisions.txt)