Arduino Forum

Using Arduino => LEDs and Multiplexing => Topic started by: carotgi1 on Jan 16, 2013, 07:12 pm

Title: LCD03 robot-electronic don't work
Post by: carotgi1 on Jan 16, 2013, 07:12 pm
Hi i'm new from topic and arduino too.
I buy a LCD 03 from robot electronics.
I read all the post in the forum and i search everywhere in google but i can't arrive to make it work.
I just arrive to get some blinking and wrong character.
I tried all the libraries from Wentz but nothing at all.
I have the correct i2C address to 0x63.
i have a Arduino uno R3 so i plug to pins close to aref.
i waste a week working on it without any result.
Please could anyone that has it working give me sketch and library or help me?
i don't realy know how to solve, thx in advance.
Title: Re: LCD03 robot-electronic don't work
Post by: codlink on Jan 17, 2013, 01:11 am
Here is the LCD he is talking about http://www.robot-electronics.co.uk/htm/Lcd03tech.htm

You need to post the code you are using.  Make sure to put the code in code tags(# button in the editor).
Title: Re: LCD03 robot-electronic don't work
Post by: carotgi1 on Jan 17, 2013, 07:36 pm
I don't have a code yet.....
i try to use the simple example hello world attached to the wenz LCDi2cR or LCDi2cW library suggested for my kind of LCD.
It don't work (exept for randow blink led or wrong character) so i don't have a code yet.
thx
Title: Re: LCD03 robot-electronic don't work
Post by: codlink on Jan 17, 2013, 08:52 pm
That's probably the most common screen for Arduino.  I don't think anybody is going to post a sketch because there is a ton of them out there.

List what libraries you have tried and state how they didn't work.
Also, you should post how you have it hooked up.