Arduino Forum

International => Italiano => Hardware => Topic started by: federico_maglione on Jun 26, 2013, 03:29 pm

Title: Problema Display HD44780
Post by: federico_maglione on Jun 26, 2013, 03:29 pm
Sera ragazzi ho un problema per il montaggio di un display compatibile hitachi hd44780 con l'arduino, vado ad illustrarvi i problemi:

1) Svolgo correttamente tutti i collegamenti tra arduino e display seguendo tale configurazione:

(http://www.maffucci.it/wp-content/uploads/2012/02/collegamenti-lcd.jpg)

2)Carico il programma di esempio dall'arduino stesso, LiquidCrystal ---> Hello World !
3)Sul display vengono visualizzati solo una serie di trattini neri
4)Regolo il contrasto con il potenziometro ma non succede altro che scomparire e comparire prima 1 e poi 2 linee nere
5) Per quanto riguarda la scritta nulla, i collegamenti sono quelli sicuramente è compatibile con hd44780 e il potenziometro è da 10k

Qualche consiglio si come risolvere ? grazie :)
 
Title: Re: Problema Display HD44780
Post by: PaoloP on Jun 26, 2013, 05:24 pm
Hai saldato i fili sul dispaly o sono "volanti"?
Title: Re: Problema Display HD44780
Post by: BaBBuino on Jun 26, 2013, 05:28 pm
Il contrasto è giusto che funzioni così. Sembra un problema sulle linee dati. Verificare bene.
Title: Re: Problema Display HD44780
Post by: federico_maglione on Jun 26, 2013, 07:42 pm
Sono volanti i fili può essere quello il problema ??
Title: Re: Problema Display HD44780
Post by: PaoloP on Jun 26, 2013, 07:48 pm
Si.
Dovresti saldare, se non i fili, almeno un pettine maschio o femmina, in modo da incastraci sopra i contatti.
Almeno sei più sicuro.
Title: Re: Problema Display HD44780
Post by: uwefed on Jun 27, 2013, 08:49 pm
Poi é da controllare se i Pin del Tuo Display corrispondono a quelli del esempio. Non é detto che tutti i display sono con quel tipo di disposizione dei segnali sul conettore.

Ciao Uwe
Title: Re: Problema Display HD44780
Post by: Faccina on Jun 27, 2013, 09:27 pm

Poi é da controllare se i Pin del Tuo Display corrispondono a quelli del esempio. Non é detto che tutti i display sono con quel tipo di disposizione dei segnali sul conettore.

Ciao Uwe

Non sono tutti uguali i pin dei display compatibili hitachi ?
Ne ho 3 diversi sono messi allo stesso modo tranne uno che è sottosopra ma i pin sono sempre 1-16 con 1 Vss e 15-16 led :smiley-roll-sweat:
Title: Re: Problema Display HD44780
Post by: uwefed on Jun 27, 2013, 11:10 pm
no, non sono uguali. La numerazione é da destra a sinistra o viceversa e il 15 e 16 possono essere prima / dopo il 1.
I numeri corrispondono dopo con i pin.
Chiarezza porta solo il datasheet.
Ciao Uwe
Title: Re: Problema Display HD44780
Post by: paulus1969 on Jun 28, 2013, 08:47 am
Ma la retroilluminazione la hai collegata?
Title: Re: Problema Display HD44780
Post by: menniti on Jun 29, 2013, 12:31 am
Secondo lo schema la retro illuminazione non è collegata e finché non funziona tutto conviene non collegarla, bisogna infatti verificare che essa non assorba troppa corrente, tale da mettere in difficoltà il regolatore di Arduino, molti vecchi modelli hanno questo problema.
Se i fili sono volanti il problema è certamente quello, ormai loo abbiamo appurato decine e decine di volte; attenzione che anche i connettori header di Arduino, se sono stati molto utilizzati (soprattutto con shield) possono dare problemi abbastanza seri.
Title: Re: Problema Display HD44780
Post by: padoang on Jun 30, 2013, 10:55 am
Facci vedere la funzione LiquidCrystal che usi, potrebbe essere scorretta, Giorgio