Arduino Forum

Development => Suggestions for the Arduino Project => Topic started by: tigger on Jan 24, 2018, 11:22 pm

Title: GetFileAttributesEx C: error
Post by: tigger on Jan 24, 2018, 11:22 pm
I wonder if this is a recent bug.
IDE 1.8.4
On compiling, I get this.

"GetFileAttributesEx C:\Users\****\AppData\Local\Temp\arduino_build_135940: The system cannot find the file specified."

Never used to happen, just irritating.
It seems to happen after a couple of days of working on a sketch. All the other sketches in the same "instance" of the IDE are affected as well.
The solution is to save everything, close everything and start again.
Get a message on compiling of something like "archiving build etc." then all is well again, for a couple of days.
Probably been going on for a year or more. Not aware of changing anything.
A minor irritation, that's all
Title: Re: GetFileAttributesEx C: error
Post by: pert on Jan 24, 2018, 11:27 pm
It's worth updating to the latest version of the IDE so see if it was caused by a bug that's already been fixed.
Title: Re: GetFileAttributesEx C: error
Post by: TWRackers on Oct 18, 2018, 06:46 am
Just happened to me under IDE 1.8.5, so whatever the root cause, it's not fixed.
Title: Re: GetFileAttributesEx C: error
Post by: Coding Badly on Oct 19, 2018, 10:17 am

Which anti-virus software are you using?

Title: Re: GetFileAttributesEx C: error
Post by: ballscrewbob on Nov 14, 2018, 11:45 pm
I am leaning to Coding's suggestion and another McAfee or Norton victim.