Go Down

Topic: Random Values from AD7730 24 Bits ADC (Read 286 times) previous topic - next topic

exodussian

Hello ,

I m facing with this problem,

I try to get values from ad7730  which is connected to arduino mega.

But I get such results;   random numbers are there if i press on the loadcell

Code: [Select]
15:49:53.487 -> 0
15:49:53.534 -> 0
15:49:53.534 -> 0
15:49:53.581 -> 0
15:49:53.581 -> 0
15:49:53.614 -> 0
15:49:53.614 -> 0                                      <----- Here i press on loadcell
15:49:53.651 -> 0
15:49:53.651 -> 354304
15:49:53.698 -> 4219392
15:49:53.698 -> 7788032
15:49:53.745 -> 10949632
15:49:53.745 -> 13662720
15:49:53.792 -> 15941377
15:49:53.792 -> 1053185
15:49:53.792 -> 2611711
15:49:53.839 -> 16776706
15:49:53.839 -> 9970690
15:49:53.886 -> 11869186
15:49:53.886 -> 13655039
15:49:53.932 -> 16776198
15:49:53.932 -> 1489926
15:49:53.932 -> 6118406
15:49:53.979 -> 11290630
15:49:53.979 -> 16756743
15:49:54.026 -> 5261319
15:49:54.026 -> 9701375
15:49:54.073 -> 15
15:49:54.073 -> 4519950
15:49:54.073 -> 9728013
15:49:54.107 -> 7852031
15:49:54.152 -> 20
15:49:54.152 -> 688143
15:49:54.152 -> 8560650
15:49:54.199 -> 6438916
15:49:54.199 -> 12722176                     <--- here i leave pressing loadcell
15:49:54.233 -> 0
15:49:54.233 -> 0
15:49:54.279 -> 0



the code is attached (i found it on the forum)








Idahowalker

Have you put a measuring device onto the input to the Mega to see if the output from the A:D is changing? Sort of like 1/2 splitting the problem so you know which direction to go into.

exodussian

you mean like oscilloscope?

or you mean mV measuring of loadcell output? i checked loadcell mV changing.

exodussian

Have you put a measuring device onto the input to the Mega to see if the output from the A:D is changing? Sort of like 1/2 splitting the problem so you know which direction to go into.
Oh , here is another thing.

It works well with potentiometer loadcell simulator. Very very good.

But when its connected to loadcell , same connection. it is like above.  random values.

MarkT

Lots of analog noise on the wires?  You are using a capacitor to suppress RFI?  You've checked the
loadcell works with a multimeter?
[ I will NOT respond to personal messages, I WILL delete them, use the forum please ]

Go Up