Go Down

Topic: Arduino vs Raspberry difference (Read 104 times) previous topic - next topic

Bamanio

Mar 22, 2019, 03:06 pm Last Edit: Mar 22, 2019, 03:10 pm by Bamanio
I have both working with the same 433 receivers.

I get calls from different rf buttons using RCSwitch for both!
On my RPI I get calls 2 different rf buttons but only 1 button is working with the Arduino.

Example:
I get this only on my Raspberry:
6034319 [pulselength 206, protocol 3]

I get this on both:
11277620 [pulselength 489, protocol 1]


does anyone know what is the cause for the difference, tolerance?

thanks

pylon

No links to the used hardware, no wiring diagram, no code used. Did you really read the sticky post at the top of the forum?

Quote
does anyone know what is the cause for the difference, tolerance?
If not you, nobody else can know it as everybody else doesn't have the necessary information.

Bamanio

#2
Mar 22, 2019, 06:53 pm Last Edit: Mar 22, 2019, 09:46 pm by Bamanio
Sorry, I will try to do a better job.

I use a raspberry pi 3 b+ and Arduino Uno.
I tried several different receivers all of them give the same results:

Button 1 is received on the Pi and Arduino, Button 2 only on Pi.


receivers I tried:

https://www.amazon.com/gp/product/B00HEDRHG6/ref=ppx_yo_dt_b_asin_title_o06_s00?ie=UTF8&psc=1

https://www.sparkfun.com/products/10532

https://www.amazon.com/gp/product/B07B9TVMW3/ref=ppx_yo_dt_b_asin_title_o00_s01?ie=UTF8&psc=1


I attached also the SDR screenshot of the two buttons. button 1 seems to work on 433.925
and Button 2 on 434.075

I use the rc-switch on the Arduino connected to digital PIN 2
For the Pi I use :
https://pypi.org/project/rpi-rf/






pylon

And which code do you use for detection? (Don't forget the code tags, that's the </> button in the editor!)

Go Up