Go Down

Topic: [Tuto] ds1307 Arduino Processing mise à l'heure NTP (Read 27666 times) previous topic - next topic

jfs

#30
Mar 26, 2014, 07:01 pm Last Edit: Mar 26, 2014, 07:04 pm by Jean-François Reason: 1
Après il y a aussi le choix du bon port série, il s'affiche normalement au démarrage du sketch Processing, il faut ensuite le changer directement dans le code, ici :

Quote
myPort = new Serial(this, Serial.list()[0], 115200); // ouvre une liaison série sur le port '0'
Pas d'aide par MP !!!

Concernant le fonctionnement du forum tout se trouve dans les messages épinglés en tête de page.

Uzuma

Oui et cela ne serait-il pas dans cette ligne de code ?! (pour processing)

Code: [Select]


myPort = new Serial(this, Serial.list()[0], 115200); // ouvre une liaison série sur le port '0'



Comme je le disais tantôt, j'ai COM3 jusqu'au COM7 affiché au bas après compilation. Moi je met donc 3 à la place du zero dans la ligne de code précédente.

jfs

Oui, pour le port, d'un ordi et d'un OS à l'autre ça change.... il faut adapter, C'est ce que tu as fait

Après il y a eu des soucis lorsque l'on est passé de l'IDE Arduino 0.23 à 1.xx, mais C'est corrigé, mais il faut tout de même charger le bon sketch sur l'arduino.
Pas d'aide par MP !!!

Concernant le fonctionnement du forum tout se trouve dans les messages épinglés en tête de page.

Uzuma

#33
Mar 26, 2014, 07:17 pm Last Edit: Mar 26, 2014, 07:23 pm by Uzuma Reason: 1
Pour ce qui est du sketch, je ne crois pas qu'il y ait de problème à ce niveau car celui-ci a confirmé l'exactitude du code pour arduino.
Après ... je ne sais pas ce qui ce passe chez moi.

Uzuma

Bonsoir,

Voilà j'ai téléchargé la version 1.5.1 de processing et j'ai fait comme ceci :
- J'ai enlevé la pile du rtc
- J'ai copier coller le code corrigé pour l'arduino
- j'ai copier coller le code pour processing
- j'ai téléversé le code pour Arduino
- j'ai ensuite fait "Run" pour processing

... après tout ça rien n'a changé

Et j'ai aussi ce message d'erreur de la version 1.5.1
Code: [Select]

Display 0 does not exist, using the default display instead.
WARNING:  RXTX Version mismatch
Jar version = RXTX-2.2pre1
native lib Version = RXTX-2.2pre2

jfs

J'arriverai pas à regarder plus avant ce week end.
Pas d'aide par MP !!!

Concernant le fonctionnement du forum tout se trouve dans les messages épinglés en tête de page.

Uzuma

ok, je vais continuer de chercher en attendant.

Felix83

une question bête (la réponse m'a peut être échapé dans le code)

dans le montage du post d'origine, qu'i y a t'il pour initier la comm NTP ?  un shield wifi ? Ethernet ? Gsm ?

merci

jfs

une liaison série avec le pc par le biais de Processing.... donc pas de shield.
Pas d'aide par MP !!!

Concernant le fonctionnement du forum tout se trouve dans les messages épinglés en tête de page.

Go Up