Pages: 1 [2]   Go Down
Author Topic: I2C Kommunikation mittels Wire.h funktioniert nicht  (Read 3179 times)
0 Members and 1 Guest are viewing this topic.
Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 247
Posts: 21058
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hast Du mit dem I2C scanner versucht die Adresse des Displays herauszufinden?
http://todbot.com/blog/2009/11/29/i2cscanner-pde-arduino-as-i2c-bus-scanner/
Grüße Uwe
Logged

Offline Offline
Full Member
***
Karma: 2
Posts: 137
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hier scheint es eine Library für den ST7032i zu geben, dein Display verwendet den ST7032 (ohne i). Versuch es doch einmal damit, ausser du möchtest als Übung dir selber eine Library dafür schreiben - so kompliziert scheint das nicht zu sein.

http://hmario.home.xs4all.nl/arduino/LiquidCrystal_I2C_ST7032i/
Logged

duemilanove / OSX & WIN
Arduino & Teensy: http://bit.ly/13rbdtQ

Offline Offline
Newbie
*
Karma: 0
Posts: 9
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Danke für den link uwe! hab das programm mal durchlaufen lassen. Bei mir findet er gar kein Device....
Logged

Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 247
Posts: 21058
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ok, dann ist nicht Dein Sketch Schuld.
Kontrolliere nochmal die Verdratung des Displays.
Grüße Uwe
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 9
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hatte einen kontaktfehler, nun findet er ein device mit adresse 62. also die Adresse 0111110 stimmt.
Wenn ich meinen sketch starte tut sich am display trotzdem nichts. Wenn ich es mit dem Befehl einschalte müsste ich doch was sehen oder?
Logged

Pages: 1 [2]   Go Up
Jump to: