Pages: [1]   Go Down
Author Topic: Problemas con Ethernet Shield  (Read 1111 times)
0 Members and 1 Guest are viewing this topic.
Orduña- Bizkaia
Offline Offline
Sr. Member
****
Karma: 0
Posts: 317
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Tengo un problemon con la tarjeta que me acaba de llegar, el caso esque estoy probando el ejemplo de ethernet webserver y hacerle ping desde windows 7 y no contesta me pone  "Tiempo de espera agotado para esta solicitud", he probao con el mismo cable en un portatil y sin problemas.

La tarjeta la he pillado por ebay en concreto es esta:
http://www.ebay.es/itm/170789100890?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649

El chip es el W5100 el caso esque subo el sketch y parece que algo hace, parpadea un poco el RX pero me pone ese error.

Hay que hacer algo mas ???  A ver si me podeis ayudar.

Un saludete.
Logged

0
Offline Offline
Edison Member
*
Karma: 8
Posts: 1040
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

No hay que hacer nada mas. Te debería de funcionar. Puedes poner el código que subes?
Logged

Trabajando en ...

    * Control Domotico (En montaje ...)
    http://casitadomotica.blogspot.com/
 

[url=https://bitbucket.org/fmalpartida

Alicante
Offline Offline
Sr. Member
****
Karma: 2
Posts: 413
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

¿Le has asignado una ip a tu Arduino desde el router?
Logged

Orduña- Bizkaia
Offline Offline
Sr. Member
****
Karma: 0
Posts: 317
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

El codigo es el que viene con el programa arduino la version 1.0 ethernet-->webserver  y  le he puesto la ip a la que accedo, he probao con varias de mi misma red 192.168.1.x pero ni se inmuta, me estoy mosquando y pensando que la placa esta defectuosa o algo porque creo q no es normal.

He estado mirando en el router y en los que estan con ip fija aparecen en ARP y este no aparece por ningun lado ni en la lista de ARP ni en la DHCP. Esto huele mal.
« Last Edit: April 18, 2012, 05:50:54 pm by riscking » Logged

COM22
Offline Offline
God Member
*****
Karma: 6
Posts: 702
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

[...] he probao con el mismo cable en un portatil y sin problemas. [...]

No creo que sea la placa, si dices que conectado directamente funciona, eso es más configuración de red ya que las redes son muy puñeteras hay veces que sin hacer nada funciona y otras que solo dan problemas.
Logged


Orduña- Bizkaia
Offline Offline
Sr. Member
****
Karma: 0
Posts: 317
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yo creo que no coge bien la ip y no acaba de conectarse con el router, he probado a darle a la mac una ip a mano en el router, la misma que la que le pongo en el sketch y da igual no hay manera y usando el webclient segun la version 1.0 no sale nada en el serial monitor y con la 22 pone:

connecting...
connection failed

disconnecting

No se que mas hacer, le he mandado un mensaje al chino a ver que me cuenta, lo ideal seria poderla probar en otro router u otra tarjeta en el mio, alguien de bilbao que este disponible el dia 25?, que tengo que ir por alli, para salir de dudas.
Logged

Alicante
Offline Offline
Sr. Member
****
Karma: 2
Posts: 413
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Si no te aparece en la lista es porque no tiene una ip fija. Que router tienes? Puede darse la posibilidad de una incompatibilidad con él.
Logged

Orduña- Bizkaia
Offline Offline
Sr. Member
****
Karma: 0
Posts: 317
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

a9965 tengo un sagem 2604, y en el aparece todo el que se conecta, movil, PC, .... aparece la mac y la ip asiganada y cuando se desconecta desaparece, por eso estoy super mosca de que no se le vea de ninguna manera a la placa, creo que ya he probado de todo y no hay manera, el tx de todas formas no lo he visto parpadear nunca solo el RX y creo que tienen que parapadear los dos.
Logged

Orduña- Bizkaia
Offline Offline
Sr. Member
****
Karma: 0
Posts: 317
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Al final el chico me ha mandado otra y me pasaba lo mismo, ya desesperado he ido conectando lo basico y lo que fallaba es dos pines el icsp que no hacen bien contacto, para que sirve el icsp en estas placas?? alguien me lo podria explicar??

Por si alguien le pasa lo mismo el modelo de la placa es HanRun HR911105A 10/49.
Un saludo.
Logged

COM22
Offline Offline
God Member
*****
Karma: 6
Posts: 702
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

[...] lo que fallaba es dos pines el icsp que no hacen bien contacto, para que sirve el icsp en estas placas?? alguien me lo podria explicar??
[...]

El conector ICSP es para darle compatibilidad con las placas arduino MEGA, en las placas Duemilanove, UNO, etc... en teoria no aria falta el conector ICSP.

[...]Por si alguien le pasa lo mismo el modelo de la placa es HanRun HR911105A 10/49.
[...]

Ese no es el modelo de la placa sino del conector RJ45 smiley, la tuya creo que es la Ethernet Shield v5.0.

Un saludo!
« Last Edit: May 01, 2012, 06:09:22 pm by JRodrigo » Logged


Pages: [1]   Go Up
Jump to: