Pages: [1]   Go Down
Author Topic: avrdude: stk500_recv(): programmer is not responding  (Read 720 times)
0 Members and 1 Guest are viewing this topic.
athens
Offline Offline
Newbie
*
Karma: 0
Posts: 9
warumgr.forumgreek.com
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello!


Recently,I had been given an arduino uno with a damaged atmega 8u2 usb to serial chip.The atmega328 is working perfectly but
I can't upload any sketch.I have bought a very cheap usb to serial converter which has the prolific pl2303 chip in order to upload a sketch to the arduino but it didn't work properly so I bought another interface with the ftdi ft232rl.I have connected the rx and the tx pins to see
if it works and it works.When I connect the the rx,tx,vcc,gnd pins to arduino and I try to upload a sketch,it appears true message in the title and if I set the arduino ide to show verbose output,the following message appears:
"avrdude: Version 5.11, compiled on Sep  2 2011 at 18:52:52
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf"
         User configuration file is "/Users/microsof/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/tty.usbserial-A9005cAz
         Using Programmer              : arduino
         Overriding Baud Rate          : 57600
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

avrdude done.  Thank you."

I've also tried setting the board menu to duelmilanove because it has the ftdi chip with no result.I've tried to change the way I connect them several times but with no result.

Can you help me???

Thanks...
Logged

warumgr.forumgreek.com

athens
Offline Offline
Newbie
*
Karma: 0
Posts: 9
warumgr.forumgreek.com
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

anyone?
Logged

warumgr.forumgreek.com

Offline Offline
Newbie
*
Karma: 0
Posts: 12
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

anyone?

Hi apple32,

I noticed this in the error message *before* the connection errors... "User configuration file does not exist or is not a regular file, skipping"

I'd run through the config text, to see what I could change so that error no longer appears. It could be that because the config file is skipped, the rest of the process doesn't happen properly?
Logged

athens
Offline Offline
Newbie
*
Karma: 0
Posts: 9
warumgr.forumgreek.com
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Thank you SarahC for your answer.
Luckily,the usb-serial chip wasn't damaged but wrong programmed.I followed this guide http://arduino.cc/en/Hacking/DFUProgramming8U2
and now the arduino works great with its internal atmel 8u2 chip
Logged

warumgr.forumgreek.com

Pages: [1]   Go Up
Jump to: