Pages: [1]   Go Down
Author Topic: Bootloader Issue Atmega328p acting as Arduino Pro Mini 3.3v PLEASE HELP!  (Read 1088 times)
0 Members and 1 Guest are viewing this topic.
Wisconsin
Offline Offline
Edison Member
*
Karma: 4
Posts: 1000
I LOVE THIS STUFF!!!!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello,

I currently have an issue with programming my atmega328P.  I want it to run at a 3.3v usage at 8MHz although I cannot figure it out.  I currently have a boards file with these two entries

Code:
pro.name=Arduino Pro or Pro Mini (3.3V, 8 MHz) w/ ATmega328

pro.upload.protocol=arduino
pro.upload.maximum_size=30720
pro.upload.speed=57600

pro.bootloader.low_fuses=0xFF
pro.bootloader.high_fuses=0xDA
pro.bootloader.extended_fuses=0x05
pro.bootloader.path=atmega
pro.bootloader.file=ATmegaBOOT_168_atmega328_pro_8MHz.hex
pro.bootloader.unlock_bits=0x3F
pro.bootloader.lock_bits=0x0F

pro.build.mcu=atmega328p
pro.build.f_cpu=8000000L
pro.build.core=arduino
pro.build.variant=standard

######################################################################

atmega328.name=Arduino Duemilanove w/ ATmega328

atmega328.upload.protocol=arduino
atmega328.upload.maximum_size=30720
atmega328.upload.speed=57600

atmega328.bootloader.low_fuses=0xFF
atmega328.bootloader.high_fuses=0xDA
atmega328.bootloader.extended_fuses=0x05
atmega328.bootloader.path=atmega
atmega328.bootloader.file=ATmegaBOOT_168_atmega328.hex
atmega328.bootloader.unlock_bits=0x3F
atmega328.bootloader.lock_bits=0x0F

atmega328.build.mcu=atmega328p
atmega328.build.f_cpu=16000000L
atmega328.build.core=arduino
atmega328.build.variant=standard


The arduino duemilanove is what I have and i use the atmega328p and I want it to function like an arduino pro mini at 3.3v at 8MHz although i don't know what kind of board entires to use. 

I also have been getting this error quite often

Code:
avrdude: Yikes!  Invalid device signature.
         Double check connections and try again, or use -F to override
         this check.

so I would like to get that all figured out
Logged

Accelerate to 88 miles per hour.

Wisconsin
Offline Offline
Edison Member
*
Karma: 4
Posts: 1000
I LOVE THIS STUFF!!!!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

please help!
Logged

Accelerate to 88 miles per hour.

Global Moderator
Offline Offline
Brattain Member
*****
Karma: 452
Posts: 18694
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

No response in 90 minutes, and then a bump? Must be desperate, huh? Bear in mind with time zones a lot of people might be asleep, or at work or something ... like answering the 40 other new questions that appeared today.


How are you programming it?
Logged

Wisconsin
Offline Offline
Edison Member
*
Karma: 4
Posts: 1000
I LOVE THIS STUFF!!!!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I'm sorry, I am extremely desperate.  I have till tonight to figure out the issue or else I have to settle for just turning them on all the time.

I am programming it with the arduino IDE. I'm trying to just burn a bootloader right now, but once I can do that, i'll be fine. 
I've modified the boards.txt already and I think i just missed someting so thats why I posted it.

The whole issue revolves around the device signature with the MC.  I can't figure out how to expect the atmega328p but still run at 3.3v with 8MHz
Logged

Accelerate to 88 miles per hour.

Wisconsin
Offline Offline
Edison Member
*
Karma: 4
Posts: 1000
I LOVE THIS STUFF!!!!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Anybody? I have 4 hours till i head to plan B
Logged

Accelerate to 88 miles per hour.

Global Moderator
Offline Offline
Brattain Member
*****
Karma: 452
Posts: 18694
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I'm sorry I just don't know. I don't know what the signature of your device is, and thus how to change anything to match it.

If you did avrdude with the -v option you might find the signature.

I don't have a Pro Mini running at 3.3V, and judging by the lack of response, neither does anyone else who is on the forum right now.

I'm in a different time zone to you I guess. I just got out of bed, so pleas for help "in the next four hours" which arrive in my inbox at 4 am, don't have much effect on me. zzzzzzzzz
Logged

29445
Offline Offline
Newbie
*
Karma: 0
Posts: 9
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Be sure to have 16 mhz oscillator connected during bootloading, and do not set low fuse to 0xFF, as will prevent run from internal oscillator.


R,

RadFly
Logged

Jj

Wisconsin
Offline Offline
Edison Member
*
Karma: 4
Posts: 1000
I LOVE THIS STUFF!!!!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

i dont needt the 16MHz after im done bootloading, correct?
Logged

Accelerate to 88 miles per hour.

Pages: [1]   Go Up
Jump to: